summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-02-02 18:33:29 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-02-02 23:10:43 +0800
commit02e2f260a63b8f01aabb307a996405b3613a280f (patch)
treeaf2a1efe952fdad4097d5515532772b86997dafc /dynamic-layers
parentd04876ff37c85cbcbff60d0630e52d64c62fe4bd (diff)
downloadmeta-intel-02e2f260a63b8f01aabb307a996405b3613a280f.tar.gz
vc-intrinsics: update to include latest commits
It includes: 77974f5 Wrap getTypeByName() to build with ToT LLVM 2de2dd4 Mangle intrinsic names 017cfcd Added predication for genx_masked_gather. 5032643 Add gather4_masked_scaled2 and gather_masked_scaled2 intrinsics a08fe5b Add internal llvm.genx.gaddr intrinsic for constant/global table support cf29e35 use a more strict version of cast operation in lowerUnmaskOps d2a2184 Use standard installation directory variables 7cbfe2e Allow OCL types without address convert in reader 410f50d Fix twice application of writer adaptor e42097e Add GENX_REWRITE_SEV environment variable for debug ca68b87 Rewrite single element vectors before spirv 008db27 Removing some whitespaces 3b2b67f Correct docs on gather/scatter scaled instructions 9bba8b5 Delete legacy intrinsics d684443 Add Instructions.h to llvmVCWrapper Add getNumElements func to llvmVCWrapper 4d724e3 CMCallable attribute conversion in AdaptorCM 73b335b Add Alignment.h to llvmVCWrapper 04d4900 Ignore non-vc kernels in reader type translation b3f075d Remove SPIRVMemoryModel setting in GenXSPIRVWriterAdaptor eabcd20 Add jump_table intrinsic 82711ce Fix to make lit tests pass for llvm7: forward isVolatile arg explicitly when creating load/store 6506440 add missing default initializer to CMSimdCFLower member 9a03e3e Fix for problem with incorrect MD in LLVM IR 4515d60 avoid returning potentially-unitialized value 414153d Fix for wrr predication if new value is a result of a bitcast 77974f5 (HEAD -> master, origin/master, origin/HEAD) Wrap getTypeByName() to build with ToT LLVM 2de2dd4 Mangle intrinsic names 017cfcd Added predication for genx_masked_gather. 5032643 Add gather4_masked_scaled2 and gather_masked_scaled2 intrinsics a08fe5b Add internal llvm.genx.gaddr intrinsic for constant/global table support cf29e35 use a more strict version of cast operation in lowerUnmaskOps d2a2184 Use standard installation directory variables 7cbfe2e Allow OCL types without address convert in reader 410f50d Fix twice application of writer adaptor e42097e Add GENX_REWRITE_SEV environment variable for debug ca68b87 Rewrite single element vectors before spirv 008db27 Removing some whitespaces 3b2b67f Correct docs on gather/scatter scaled instructions 9bba8b5 Delete legacy intrinsics d684443 Add Instructions.h to llvmVCWrapper Add getNumElements func to llvmVCWrapper 4d724e3 CMCallable attribute conversion in AdaptorCM 73b335b Add Alignment.h to llvmVCWrapper 04d4900 Ignore non-vc kernels in reader type translation b3f075d Remove SPIRVMemoryModel setting in GenXSPIRVWriterAdaptor eabcd20 Add jump_table intrinsic 82711ce Fix to make lit tests pass for llvm7: forward isVolatile arg explicitly when creating load/store 6506440 add missing default initializer to CMSimdCFLower member 9a03e3e Fix for problem with incorrect MD in LLVM IR 4515d60 avoid returning potentially-unitialized value 414153d Fix for wrr predication if new value is a result of a bitcast 23d4b41 Add SPIRV writer adaptor types translation 9eda835 Deduced number of channels under SIMD CFG for functions which use genx_replicate_mask attribute 3b3f9d9 Add llvm version to test features e13f274 Fix wrong address space for sampler type in reader 5829ad6 Fix missing compatibility with old translator in GenXSPIRVReaderAdaptor.cpp 3a287f5 Add GetOldStyleKernelMD function to GenXMetadata.h 60dec9a Uniform GenXMetadata.h with AdaptorsCommon.h ec7de0b Move SPIRV-specific parameters to AdaptorsCommon.h b869876 Use consume_front in SPIRV reader adaptor 2bb7a70 Fix SPIRV reader adaptor mistranslation of non-global pointers 40db2bb Add SPIRV reader adaptor types translation 65b7d2b Add more correct wrapper for global value address space 2e496ce Synchronize repository Drop patch, which is already merged and avaialble. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics/0001-Use-standard-installation-directory-variables.patch58
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb4
2 files changed, 1 insertions, 61 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics/0001-Use-standard-installation-directory-variables.patch b/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics/0001-Use-standard-installation-directory-variables.patch
deleted file mode 100644
index 35469a1c..00000000
--- a/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics/0001-Use-standard-installation-directory-variables.patch
+++ /dev/null
@@ -1,58 +0,0 @@
1From 33f60fe2c64272cf1472aa541bcb491a62f81ca5 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Mon, 26 Oct 2020 16:24:09 +0800
4Subject: [PATCH] Use standard installation directory variables
5
6Upstream-Status: Submitted [https://github.com/intel/vc-intrinsics/pull/35]
7
8Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
9---
10 GenXIntrinsics/CMakeLists.txt | 14 +++++++-------
11 1 file changed, 7 insertions(+), 7 deletions(-)
12
13diff --git a/GenXIntrinsics/CMakeLists.txt b/GenXIntrinsics/CMakeLists.txt
14index c59c589..5bcf0d1 100644
15--- a/GenXIntrinsics/CMakeLists.txt
16+++ b/GenXIntrinsics/CMakeLists.txt
17@@ -33,7 +33,7 @@ endif()
18 # this option is to switch on install when we are building not inside IGC
19 if(INSTALL_REQUIRED)
20 install(DIRECTORY include/llvm
21- DESTINATION include
22+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
23 COMPONENT genx-intrinsics-headers
24 FILES_MATCHING
25 PATTERN "*.h"
26@@ -43,7 +43,7 @@ if(INSTALL_REQUIRED)
27 # and then "install(DIRECTORY" installs them even if they are empty
28 # so generated file has to be installed separetely
29 install(FILES ${CMAKE_CURRENT_BINARY_DIR}/include/llvm/GenXIntrinsics/${GENX_INTRINSICS_DESCRIPTION}
30- DESTINATION include/llvm/GenXIntrinsics
31+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/llvm/GenXIntrinsics
32 COMPONENT genx-intrinsics-headers
33 )
34
35@@ -52,15 +52,15 @@ if(INSTALL_REQUIRED)
36 # we need to limit it to external build
37 if(BUILD_EXTERNAL)
38 install(TARGETS LLVMGenXIntrinsics EXPORT LLVMGenXIntrinsicsTargets
39- LIBRARY DESTINATION lib
40- ARCHIVE DESTINATION lib
41- RUNTIME DESTINATION bin
42- INCLUDES DESTINATION include
43+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
44+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
45+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
46+ INCLUDES DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
47 )
48
49 install(EXPORT LLVMGenXIntrinsicsTargets
50 FILE LLVMGenXIntrinsicsConfig.cmake
51- DESTINATION lib/cmake/LLVMGenXIntrinsics
52+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/LLVMGenXIntrinsics
53 )
54 endif() # BUILD_EXTERNAL
55 endif() # INSTALL_REQUIRED
56--
572.17.1
58
diff --git a/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb b/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb
index 39bf5803..eca1cb4d 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb
@@ -7,10 +7,8 @@ LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://License.md;md5=c18ea6bb4786a26bf4eee88a7424a408" 7LIC_FILES_CHKSUM = "file://License.md;md5=c18ea6bb4786a26bf4eee88a7424a408"
8 8
9SRC_URI = "git://github.com/intel/vc-intrinsics.git;protocol=https; \ 9SRC_URI = "git://github.com/intel/vc-intrinsics.git;protocol=https; \
10 file://0001-Use-standard-installation-directory-variables.patch \
11 " 10 "
12 11SRCREV = "77974f5a32e19475125531483bede9ee23935257"
13SRCREV = "c8c52b5fb14b33e32de9df573b7de186a0c97c94"
14 12
15S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
16 14