diff options
author | Anuj Mittal <anuj.mittal@intel.com> | 2020-03-19 07:13:09 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2020-04-04 18:18:52 +0800 |
commit | e226f8983bc33a9b76b69b3df29af3dda7aec988 (patch) | |
tree | 727bc910d87682b9d8b02144e35069f5785ac125 /dynamic-layers | |
parent | 19e46a93c042d5f1ba2747f2bff7f4a8db77c000 (diff) | |
download | meta-intel-e226f8983bc33a9b76b69b3df29af3dda7aec988.tar.gz |
intel-compute-runtime: upgrade 20.04.15428 -> 20.10.16259
Replace a local patch with a backport that allows defining value for
cloc_cmd_prefix.
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch | 46 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/enable-external-offline-compiler.patch | 44 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.12.16259.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.04.15428.bb) | 12 |
3 files changed, 51 insertions, 51 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch deleted file mode 100644 index 6f7cdff8..00000000 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | From ad3e325c1af4d6533fd9b3dfc5208267b678327a Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Thu, 6 Feb 2020 18:25:19 +0800 | ||
4 | Subject: [PATCH] don't use LD_LIBRARY_PATH for native offline compiler | ||
5 | |||
6 | Let us supply the correct path for it to be able to find the correct | ||
7 | libraries. | ||
8 | |||
9 | Upstream-Status: Inappropriate | ||
10 | |||
11 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
12 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
13 | --- | ||
14 | runtime/built_ins/kernels/CMakeLists.txt | 2 +- | ||
15 | runtime/scheduler/scheduler_binary.cmake | 2 +- | ||
16 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
17 | |||
18 | diff --git a/runtime/built_ins/kernels/CMakeLists.txt b/runtime/built_ins/kernels/CMakeLists.txt | ||
19 | index 863dba145..a385cf768 100644 | ||
20 | --- a/runtime/built_ins/kernels/CMakeLists.txt | ||
21 | +++ b/runtime/built_ins/kernels/CMakeLists.txt | ||
22 | @@ -66,7 +66,7 @@ function(compile_builtin gen_type platform_type builtin bits builtin_options) | ||
23 | if(DEFINED NEO__IGC_LIBRARY_PATH) | ||
24 | set(cloc_cmd_prefix LD_LIBRARY_PATH=${NEO__IGC_LIBRARY_PATH} $<TARGET_FILE:ocloc>) | ||
25 | else() | ||
26 | - set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc> $<TARGET_FILE:ocloc>) | ||
27 | + set(cloc_cmd_prefix ocloc) | ||
28 | endif() | ||
29 | endif() | ||
30 | list(APPEND __cloc__options__ "-cl-kernel-arg-info") | ||
31 | diff --git a/runtime/scheduler/scheduler_binary.cmake b/runtime/scheduler/scheduler_binary.cmake | ||
32 | index a7015b909..a720d2f5c 100644 | ||
33 | --- a/runtime/scheduler/scheduler_binary.cmake | ||
34 | +++ b/runtime/scheduler/scheduler_binary.cmake | ||
35 | @@ -37,7 +37,7 @@ function(compile_kernel target gen_type platform_type kernel) | ||
36 | if(DEFINED NEO__IGC_LIBRARY_PATH) | ||
37 | set(cloc_cmd_prefix LD_LIBRARY_PATH=${NEO__IGC_LIBRARY_PATH} $<TARGET_FILE:ocloc>) | ||
38 | else() | ||
39 | - set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc> $<TARGET_FILE:ocloc>) | ||
40 | + set(cloc_cmd_prefix ocloc) | ||
41 | endif() | ||
42 | endif() | ||
43 | list(APPEND __cloc__options__ "-cl-kernel-arg-info") | ||
44 | -- | ||
45 | 2.17.1 | ||
46 | |||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/enable-external-offline-compiler.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/enable-external-offline-compiler.patch new file mode 100644 index 00000000..d3e7d14a --- /dev/null +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/enable-external-offline-compiler.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | From 6f6d64569d75f6fc352ce7ce3a65dd88f0f84b99 Mon Sep 17 00:00:00 2001 | ||
2 | From: Dongwon Kim <dongwon.kim@intel.com> | ||
3 | Date: Wed, 25 Mar 2020 15:02:43 -0700 | ||
4 | Subject: [PATCH] Optionally enable external ocl offline compiler | ||
5 | |||
6 | Expand commit af78548e80cb293ccc6b02b45ac03d249de03bc6 to | ||
7 | scheduler's build configuration | ||
8 | |||
9 | Change-Id: I04a5fc5f85d15bac040ad699df4c39cc2e0182aa | ||
10 | Signed-off-by: Dongwon Kim <dongwon.kim@intel.com> | ||
11 | |||
12 | Upstream-Status: Backport | ||
13 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
14 | --- | ||
15 | opencl/source/scheduler/scheduler_binary.cmake | 15 +++++++++------ | ||
16 | 1 file changed, 9 insertions(+), 6 deletions(-) | ||
17 | |||
18 | diff --git a/opencl/source/scheduler/scheduler_binary.cmake b/opencl/source/scheduler/scheduler_binary.cmake | ||
19 | index 740ff7d63..c57e28f78 100644 | ||
20 | --- a/opencl/source/scheduler/scheduler_binary.cmake | ||
21 | +++ b/opencl/source/scheduler/scheduler_binary.cmake | ||
22 | @@ -31,13 +31,16 @@ function(compile_kernel target gen_type platform_type kernel) | ||
23 | set(OUTPUTPATH "${OUTPUTDIR}/${BASENAME}_${family_name_with_type}.bin") | ||
24 | |||
25 | set(SCHEDULER_CPP "${OUTPUTDIR}/${BASENAME}_${family_name_with_type}.cpp") | ||
26 | - if(WIN32) | ||
27 | - set(cloc_cmd_prefix ocloc) | ||
28 | - else() | ||
29 | - if(DEFINED NEO__IGC_LIBRARY_PATH) | ||
30 | - set(cloc_cmd_prefix LD_LIBRARY_PATH=${NEO__IGC_LIBRARY_PATH}:$<TARGET_FILE_DIR:ocloc_lib> $<TARGET_FILE:ocloc>) | ||
31 | + | ||
32 | + if(NOT DEFINED cloc_cmd_prefix) | ||
33 | + if(WIN32) | ||
34 | + set(cloc_cmd_prefix ocloc) | ||
35 | else() | ||
36 | - set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc_lib> $<TARGET_FILE:ocloc>) | ||
37 | + if(DEFINED NEO__IGC_LIBRARY_PATH) | ||
38 | + set(cloc_cmd_prefix LD_LIBRARY_PATH=${NEO__IGC_LIBRARY_PATH}:$<TARGET_FILE_DIR:ocloc_lib> $<TARGET_FILE:ocloc>) | ||
39 | + else() | ||
40 | + set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc_lib> $<TARGET_FILE:ocloc>) | ||
41 | + endif() | ||
42 | endif() | ||
43 | endif() | ||
44 | list(APPEND __cloc__options__ "-cl-kernel-arg-info") | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.04.15428.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.12.16259.bb index f6cfaf19..2ea9a685 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.04.15428.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.12.16259.bb | |||
@@ -9,12 +9,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae27f47fd6755510247c19e547e4c804 \ | |||
9 | file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b" | 9 | file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \ | 11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \ |
12 | file://enable-external-offline-compiler.patch \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | SRC_URI_append_class-target = " \ | 15 | SRCREV = "43016c65591bd125a9590ea05ca83d094a628f79" |
15 | file://dont-use-ld-library-path.patch \ | ||
16 | " | ||
17 | SRCREV = "98006aa2bf282ebc5914359e0e4c5f1c539de56f" | ||
18 | 16 | ||
19 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
20 | 18 | ||
@@ -33,9 +31,13 @@ EXTRA_OECMAKE = " \ | |||
33 | -DBUILD_TYPE=Release \ | 31 | -DBUILD_TYPE=Release \ |
34 | -DSKIP_UNIT_TESTS=1 \ | 32 | -DSKIP_UNIT_TESTS=1 \ |
35 | -DCCACHE_ALLOWED=FALSE \ | 33 | -DCCACHE_ALLOWED=FALSE \ |
34 | -Dcloc_cmd_prefix=ocloc \ | ||
36 | " | 35 | " |
37 | 36 | ||
38 | FILES_${PN} += "${libdir}/intel-opencl/libigdrcl.so" | 37 | FILES_${PN} += " \ |
38 | ${libdir}/intel-opencl/libigdrcl.so \ | ||
39 | ${libdir}/intel-opencl/libocloc.so \ | ||
40 | " | ||
39 | 41 | ||
40 | BBCLASSEXTEND = "native nativesdk" | 42 | BBCLASSEXTEND = "native nativesdk" |
41 | 43 | ||