diff options
author | Naveen Saini <naveen.kumar.saini@intel.com> | 2020-04-13 13:23:13 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2020-04-14 07:01:40 +0800 |
commit | b7d87376c71ecbbc74eea1100b6d12cfb8eba3fd (patch) | |
tree | 21639d7ec42e932f2ffc916ad85680e2bc4be580 /dynamic-layers | |
parent | 1dfb663acab752d3dc79f6ff7e9357398c634111 (diff) | |
download | meta-intel-b7d87376c71ecbbc74eea1100b6d12cfb8eba3fd.tar.gz |
intel-compute-runtime: upgrade 20.12.16259 -> 20.14.16441
Dropped the backported patch.
Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/enable-external-offline-compiler.patch | 44 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.14.16441.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.12.16259.bb) | 3 |
2 files changed, 1 insertions, 46 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/enable-external-offline-compiler.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/enable-external-offline-compiler.patch deleted file mode 100644 index d3e7d14a..00000000 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/enable-external-offline-compiler.patch +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | From 6f6d64569d75f6fc352ce7ce3a65dd88f0f84b99 Mon Sep 17 00:00:00 2001 | ||
2 | From: Dongwon Kim <dongwon.kim@intel.com> | ||
3 | Date: Wed, 25 Mar 2020 15:02:43 -0700 | ||
4 | Subject: [PATCH] Optionally enable external ocl offline compiler | ||
5 | |||
6 | Expand commit af78548e80cb293ccc6b02b45ac03d249de03bc6 to | ||
7 | scheduler's build configuration | ||
8 | |||
9 | Change-Id: I04a5fc5f85d15bac040ad699df4c39cc2e0182aa | ||
10 | Signed-off-by: Dongwon Kim <dongwon.kim@intel.com> | ||
11 | |||
12 | Upstream-Status: Backport | ||
13 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
14 | --- | ||
15 | opencl/source/scheduler/scheduler_binary.cmake | 15 +++++++++------ | ||
16 | 1 file changed, 9 insertions(+), 6 deletions(-) | ||
17 | |||
18 | diff --git a/opencl/source/scheduler/scheduler_binary.cmake b/opencl/source/scheduler/scheduler_binary.cmake | ||
19 | index 740ff7d63..c57e28f78 100644 | ||
20 | --- a/opencl/source/scheduler/scheduler_binary.cmake | ||
21 | +++ b/opencl/source/scheduler/scheduler_binary.cmake | ||
22 | @@ -31,13 +31,16 @@ function(compile_kernel target gen_type platform_type kernel) | ||
23 | set(OUTPUTPATH "${OUTPUTDIR}/${BASENAME}_${family_name_with_type}.bin") | ||
24 | |||
25 | set(SCHEDULER_CPP "${OUTPUTDIR}/${BASENAME}_${family_name_with_type}.cpp") | ||
26 | - if(WIN32) | ||
27 | - set(cloc_cmd_prefix ocloc) | ||
28 | - else() | ||
29 | - if(DEFINED NEO__IGC_LIBRARY_PATH) | ||
30 | - set(cloc_cmd_prefix LD_LIBRARY_PATH=${NEO__IGC_LIBRARY_PATH}:$<TARGET_FILE_DIR:ocloc_lib> $<TARGET_FILE:ocloc>) | ||
31 | + | ||
32 | + if(NOT DEFINED cloc_cmd_prefix) | ||
33 | + if(WIN32) | ||
34 | + set(cloc_cmd_prefix ocloc) | ||
35 | else() | ||
36 | - set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc_lib> $<TARGET_FILE:ocloc>) | ||
37 | + if(DEFINED NEO__IGC_LIBRARY_PATH) | ||
38 | + set(cloc_cmd_prefix LD_LIBRARY_PATH=${NEO__IGC_LIBRARY_PATH}:$<TARGET_FILE_DIR:ocloc_lib> $<TARGET_FILE:ocloc>) | ||
39 | + else() | ||
40 | + set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc_lib> $<TARGET_FILE:ocloc>) | ||
41 | + endif() | ||
42 | endif() | ||
43 | endif() | ||
44 | list(APPEND __cloc__options__ "-cl-kernel-arg-info") | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.12.16259.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.14.16441.bb index 0eb0655a..d8b2fab5 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.12.16259.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.14.16441.bb | |||
@@ -9,10 +9,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae27f47fd6755510247c19e547e4c804 \ | |||
9 | file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b" | 9 | file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \ | 11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \ |
12 | file://enable-external-offline-compiler.patch \ | ||
13 | " | 12 | " |
14 | 13 | ||
15 | SRCREV = "43016c65591bd125a9590ea05ca83d094a628f79" | 14 | SRCREV = "4786f1a6c2910207b9f544ef3a087c4cb04280dc" |
16 | 15 | ||
17 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
18 | 17 | ||