diff options
author | Robi Buranyi <rburanyi@google.com> | 2021-04-12 21:48:13 -0700 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2021-04-13 14:38:54 +0800 |
commit | d847f56b4a98311c8249fda7b074cf76e02eff0b (patch) | |
tree | 55eb6fe18f0734d5ecef2becdb8f2765b108fa65 /dynamic-layers | |
parent | 1a4adcb8b18141db84b654e645fb07679ee41c1d (diff) | |
download | meta-intel-d847f56b4a98311c8249fda7b074cf76e02eff0b.tar.gz |
ipmctl: support CRLF line endings in EDK2
The EDK2 sources are DOS-style on server (contains CRLF) and this may
cause interop issues on Linux machines (patches do not apply clean) The
standard solution is to use the "dos2unix" bbclass, but that can modify
only files under the ${S} folder - meaning we have to move the edk2
checkout folder from ${S}/../edk2 to ${S}/edk2. Also, the LICENSE file
checksum is going to be impacted by the dos2unix conversion.
Signed-off-by: Robi Buranyi <rburanyi@google.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb | 10 |
1 files changed, 5 insertions, 5 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb index 688ad108..dce7dacb 100644 --- a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb +++ b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb | |||
@@ -13,11 +13,11 @@ BUGTRACKER = "https://github.com/intel/ipmctl/issues" | |||
13 | 13 | ||
14 | LICENSE = "BSD-3-Clause | BSD-2-Clause" | 14 | LICENSE = "BSD-3-Clause | BSD-2-Clause" |
15 | LIC_FILES_CHKSUM = "file://LICENSE;md5=72b9da60da6219d612ce30b746a0fe71 \ | 15 | LIC_FILES_CHKSUM = "file://LICENSE;md5=72b9da60da6219d612ce30b746a0fe71 \ |
16 | file://../edk2/License.txt;md5=2b415520383f7964e96700ae12b4570a" | 16 | file://edk2/License.txt;md5=6123e5bf044a66db96c4ce88a36b2d08" |
17 | 17 | ||
18 | SRC_URI = "git://github.com/intel/ipmctl.git;protocol=https;branch=development;name=ipmctl; \ | 18 | SRC_URI = "git://github.com/intel/ipmctl.git;protocol=https;branch=development;name=ipmctl; \ |
19 | git://github.com/tianocore/edk2.git;protocol=https;name=edk2;destsuffix=edk2; \ | 19 | git://github.com/tianocore/edk2.git;protocol=https;name=edk2;destsuffix=git/edk2; \ |
20 | file://0001-Ignore-STATIC_ASSERT-and-NULL-definition-so-we-can-c.patch;patchdir=../edk2 \ | 20 | file://0001-Ignore-STATIC_ASSERT-and-NULL-definition-so-we-can-c.patch;patchdir=edk2 \ |
21 | " | 21 | " |
22 | 22 | ||
23 | SRCREV_ipmctl = "4579c7ec127d6c678ce25136f928b66c7ba51097" | 23 | SRCREV_ipmctl = "4579c7ec127d6c678ce25136f928b66c7ba51097" |
@@ -26,7 +26,7 @@ SRCREV_edk2 = "ef91b07388e1c0a50c604e5350eeda98428ccea6" | |||
26 | 26 | ||
27 | S = "${WORKDIR}/git" | 27 | S = "${WORKDIR}/git" |
28 | 28 | ||
29 | inherit cmake | 29 | inherit cmake dos2unix |
30 | 30 | ||
31 | DEPENDS = "ndctl" | 31 | DEPENDS = "ndctl" |
32 | 32 | ||
@@ -34,6 +34,6 @@ EXTRA_OECMAKE = "-DRELEASE=ON" | |||
34 | 34 | ||
35 | do_configure_prepend() { | 35 | do_configure_prepend() { |
36 | for dir in BaseTools MdeModulePkg MdePkg ShellPkg ; do | 36 | for dir in BaseTools MdeModulePkg MdePkg ShellPkg ; do |
37 | ln -sf ../edk2/${dir} ${S} | 37 | ln -sf edk2/${dir} ${S} |
38 | done | 38 | done |
39 | } | 39 | } |