summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorEzhilarasan <ezhilarasanx.s@intel.com>2022-03-02 11:00:51 +0530
committerAnuj Mittal <anuj.mittal@intel.com>2022-03-02 17:39:01 +0800
commitf25cc6b70760f8b32c67efb8dd6770ce71b60b21 (patch)
treef965162a269209d46b1427d3df3a0f891d6877c7 /dynamic-layers
parentb4680fd41687f0f4dfdeccdaa1ac46287598776b (diff)
downloadmeta-intel-f25cc6b70760f8b32c67efb8dd6770ce71b60b21.tar.gz
ipsc: upgrade 1.16.1 -> 1.17.0
Release notes: https://github.com/ispc/ispc/releases/tag/v1.17.0 Signed-off-by: Ezhilarasan <ezhilarasanx.s@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Enable-LLVM-15.0-support.patch52
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch20
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc/8b5d0f26916e776bc3664e6a4dc68eff3a198d7a.patch38
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.17.0.bb (renamed from dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.16.1.bb)6
4 files changed, 65 insertions, 51 deletions
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Enable-LLVM-15.0-support.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Enable-LLVM-15.0-support.patch
new file mode 100644
index 00000000..fe82ff25
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Enable-LLVM-15.0-support.patch
@@ -0,0 +1,52 @@
1From 9b722217a2818bc4335bf2c7d3293d30aa5977b1 Mon Sep 17 00:00:00 2001
2From: Dmitry Babokin <dmitry.y.babokin@intel.com>
3Date: Fri, 4 Feb 2022 16:45:34 -0800
4Subject: [PATCH 01/24] Enable LLVM 15.0 support
5
6Upstream-Status: Backport [https://github.com/ispc/ispc/commit/9b722217a2818bc4335bf2c7d3293d30aa5977b1]
7
8Signed-off-by: Dmitry Babokin <dmitry.y.babokin@intel.com>
9---
10 src/ispc.h | 4 ++--
11 src/ispc_version.h | 3 ++-
12 2 files changed, 4 insertions(+), 3 deletions(-)
13
14diff --git a/src/ispc.h b/src/ispc.h
15index 362c2b93..581d5de6 100644
16--- a/src/ispc.h
17+++ b/src/ispc.h
18@@ -1,5 +1,5 @@
19 /*
20- Copyright (c) 2010-2021, Intel Corporation
21+ Copyright (c) 2010-2022, Intel Corporation
22 All rights reserved.
23
24 Redistribution and use in source and binary forms, with or without
25@@ -42,7 +42,7 @@
26 #include "target_registry.h"
27
28 #if ISPC_LLVM_VERSION < OLDEST_SUPPORTED_LLVM || ISPC_LLVM_VERSION > LATEST_SUPPORTED_LLVM
29-#error "Only LLVM 11.0 - 13.0 and 14.0 development branch are supported"
30+#error "Only LLVM 11.0 - 14.0 and 15.0 development branch are supported"
31 #endif
32
33 #if defined(_WIN32) || defined(_WIN64)
34diff --git a/src/ispc_version.h b/src/ispc_version.h
35index e8487e5b..04a3cf64 100644
36--- a/src/ispc_version.h
37+++ b/src/ispc_version.h
38@@ -50,9 +50,10 @@
39 #define ISPC_LLVM_12_0 120000
40 #define ISPC_LLVM_13_0 130000
41 #define ISPC_LLVM_14_0 140000
42+#define ISPC_LLVM_15_0 150000
43
44 #define OLDEST_SUPPORTED_LLVM ISPC_LLVM_10_0
45-#define LATEST_SUPPORTED_LLVM ISPC_LLVM_14_0
46+#define LATEST_SUPPORTED_LLVM ISPC_LLVM_15_0
47
48 #ifdef __ispc__xstr
49 #undef __ispc__xstr
50--
512.17.1
52
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch
index 5f3c7d0b..a13ade9f 100644
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch
+++ b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch
@@ -1,6 +1,6 @@
1From 3f3f81bde7d9d80921515ed0bf7fe36e69319bc4 Mon Sep 17 00:00:00 2001 1From 493e886d6dae2ed7bdc12ed03f717ee0e98dfe09 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com> 2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Wed, 30 Jun 2021 13:47:41 +0800 3Date: Thu, 24 Feb 2022 20:01:11 +0530
4Subject: [PATCH] cmake: don't build for 32-bit targets 4Subject: [PATCH] cmake: don't build for 32-bit targets
5 5
6Error log: 6Error log:
@@ -20,10 +20,10 @@ Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
20 1 file changed, 4 insertions(+), 4 deletions(-) 20 1 file changed, 4 insertions(+), 4 deletions(-)
21 21
22diff --git a/cmake/GenerateBuiltins.cmake b/cmake/GenerateBuiltins.cmake 22diff --git a/cmake/GenerateBuiltins.cmake b/cmake/GenerateBuiltins.cmake
23index 15a74788..db30f809 100644 23index fa228247..7adc7e52 100644
24--- a/cmake/GenerateBuiltins.cmake 24--- a/cmake/GenerateBuiltins.cmake
25+++ b/cmake/GenerateBuiltins.cmake 25+++ b/cmake/GenerateBuiltins.cmake
26@@ -249,7 +249,7 @@ function(builtin_to_cpp bit os_name arch supported_archs supported_oses resultFi 26@@ -272,7 +272,7 @@ function(builtin_to_cpp bit os_name arch supported_archs supported_oses resultFi
27 # In this case headers will be installed in /usr/arm-linux-gnueabihf/include and will not be picked up 27 # In this case headers will be installed in /usr/arm-linux-gnueabihf/include and will not be picked up
28 # by clang by default. So the following line adds such path explicitly. If this path doesn't exist and 28 # by clang by default. So the following line adds such path explicitly. If this path doesn't exist and
29 # the headers can be found in other locations, this should not be a problem. 29 # the headers can be found in other locations, this should not be a problem.
@@ -32,7 +32,7 @@ index 15a74788..db30f809 100644
32 endif() 32 endif()
33 endif() 33 endif()
34 34
35@@ -331,7 +331,7 @@ function (generate_target_builtins resultList) 35@@ -354,7 +354,7 @@ function (generate_target_builtins resultList)
36 set(regular_targets ${ARGN}) 36 set(regular_targets ${ARGN})
37 list(FILTER regular_targets EXCLUDE REGEX wasm) 37 list(FILTER regular_targets EXCLUDE REGEX wasm)
38 foreach (ispc_target ${regular_targets}) 38 foreach (ispc_target ${regular_targets})
@@ -41,7 +41,7 @@ index 15a74788..db30f809 100644
41 foreach (os_name ${TARGET_OS_LIST_FOR_LL}) 41 foreach (os_name ${TARGET_OS_LIST_FOR_LL})
42 target_ll_to_cpp(target-${ispc_target} ${bit} ${os_name} output${os_name}${bit}) 42 target_ll_to_cpp(target-${ispc_target} ${bit} ${os_name} output${os_name}${bit})
43 list(APPEND tmpList ${output${os_name}${bit}}) 43 list(APPEND tmpList ${output${os_name}${bit}})
44@@ -392,7 +392,7 @@ function (generate_common_builtins resultList) 44@@ -415,7 +415,7 @@ function (generate_common_builtins resultList)
45 endif() 45 endif()
46 46
47 message (STATUS "ISPC will be built with support of ${supported_oses} for ${supported_archs}") 47 message (STATUS "ISPC will be built with support of ${supported_oses} for ${supported_archs}")
@@ -50,14 +50,14 @@ index 15a74788..db30f809 100644
50 foreach (os_name "windows" "linux" "freebsd" "macos" "android" "ios" "ps4" "web") 50 foreach (os_name "windows" "linux" "freebsd" "macos" "android" "ios" "ps4" "web")
51 foreach (arch "x86" "arm" "wasm32") 51 foreach (arch "x86" "arm" "wasm32")
52 builtin_to_cpp(${bit} ${os_name} ${arch} "${supported_archs}" "${supported_oses}" res${bit}${os_name}${arch}) 52 builtin_to_cpp(${bit} ${os_name} ${arch} "${supported_archs}" "${supported_oses}" res${bit}${os_name}${arch})
53@@ -405,7 +405,7 @@ function (generate_common_builtins resultList) 53@@ -428,7 +428,7 @@ function (generate_common_builtins resultList)
54 endforeach() 54 endforeach()
55 endforeach() 55 endforeach()
56 if (GENX_ENABLED) 56 if (XE_ENABLED)
57- foreach (bit 32 64) 57- foreach (bit 32 64)
58+ foreach (bit 64) 58+ foreach (bit 64)
59 builtin_genx_to_cpp(${bit} res_genx_${bit}) 59 builtin_xe_to_cpp(${bit} res_xe_${bit})
60 list(APPEND tmpList ${res_genx_${bit}} ) 60 list(APPEND tmpList ${res_xe_${bit}} )
61 if(MSVC) 61 if(MSVC)
62-- 62--
632.17.1 632.17.1
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/8b5d0f26916e776bc3664e6a4dc68eff3a198d7a.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/8b5d0f26916e776bc3664e6a4dc68eff3a198d7a.patch
deleted file mode 100644
index 1b87af4c..00000000
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/8b5d0f26916e776bc3664e6a4dc68eff3a198d7a.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From 8b5d0f26916e776bc3664e6a4dc68eff3a198d7a Mon Sep 17 00:00:00 2001
2From: Dmitry Babokin <dmitry.y.babokin@intel.com>
3Date: Wed, 16 Jun 2021 20:38:44 -0700
4Subject: [PATCH] Do not use depricated file open flags
5
6Upstream-Status: Backport [https://github.com/ispc/ispc/commit/8b5d0f26916e776bc3664e6a4dc68eff3a198d7a]
7Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
8---
9 src/module.cpp | 2 +-
10 src/opt.cpp | 2 +-
11 2 files changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/src/module.cpp b/src/module.cpp
14index 1e68d30c4..352bcd09e 100644
15--- a/src/module.cpp
16+++ b/src/module.cpp
17@@ -1314,7 +1314,7 @@ bool Module::writeObjectFileOrAssembly(llvm::TargetMachine *targetMachine, llvm:
18 llvm::CodeGenFileType fileType = (outputType == Object) ? llvm::CGFT_ObjectFile : llvm::CGFT_AssemblyFile;
19 bool binary = (fileType == llvm::CGFT_ObjectFile);
20
21- llvm::sys::fs::OpenFlags flags = binary ? llvm::sys::fs::F_None : llvm::sys::fs::F_Text;
22+ llvm::sys::fs::OpenFlags flags = binary ? llvm::sys::fs::OF_None : llvm::sys::fs::OF_Text;
23
24 std::error_code error;
25
26diff --git a/src/opt.cpp b/src/opt.cpp
27index ae1a11d3d..de1b27e1e 100644
28--- a/src/opt.cpp
29+++ b/src/opt.cpp
30@@ -4687,7 +4687,7 @@ void DebugPassFile::run(llvm::Module &module, bool init) {
31 std::error_code EC;
32 char fname[100];
33 snprintf(fname, sizeof(fname), "%s_%d_%s.ll", init ? "init" : "ir", pnum, sanitize(std::string(pname)).c_str());
34- llvm::raw_fd_ostream OS(fname, EC, llvm::sys::fs::F_None);
35+ llvm::raw_fd_ostream OS(fname, EC, llvm::sys::fs::OF_None);
36 Assert(!EC && "IR dump file creation failed!");
37 module.print(OS, 0);
38 }
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.16.1.bb b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.17.0.bb
index c319885f..fa03a3d0 100644
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.16.1.bb
+++ b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.17.0.bb
@@ -11,12 +11,12 @@ inherit cmake python3native
11 11
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
14SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=releases/v1.16.x \ 14SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \
15 file://0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch \ 15 file://0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch \
16 file://0002-cmake-don-t-build-for-32-bit-targets.patch \ 16 file://0002-cmake-don-t-build-for-32-bit-targets.patch \
17 file://8b5d0f26916e776bc3664e6a4dc68eff3a198d7a.patch \ 17 file://0001-Enable-LLVM-15.0-support.patch \
18 " 18 "
19SRCREV = "ae404c1da54422bc70696fbdaa4055bca0d1711e" 19SRCREV = "7ad8429369a4d5ced6b524fdfffe623939d8fe9a"
20 20
21COMPATIBLE_HOST = '(x86_64).*-linux' 21COMPATIBLE_HOST = '(x86_64).*-linux'
22 22