summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-04-05 12:24:38 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-04-06 10:09:02 +0800
commitf5cbba628b36008a4d2cc8820e2c004483094135 (patch)
tree63414e7762262ed80e65efadf3a851486cccc9ff /dynamic-layers
parent8f6c78dce214688b9c592e80ffb16ecfc03153b5 (diff)
downloadmeta-intel-f5cbba628b36008a4d2cc8820e2c004483094135.tar.gz
ipmctl: upgrade 02.00.00.3869 -> 03.00.00.0302
Ref: https://github.com/intel/ipmctl/releases/tag/v03.00.00.0302 Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/0001-Ignore-STATIC_ASSERT-and-NULL-definition-so-we-can-c.patch66
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_02.00.00.3869.bb27
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb39
3 files changed, 105 insertions, 27 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/0001-Ignore-STATIC_ASSERT-and-NULL-definition-so-we-can-c.patch b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/0001-Ignore-STATIC_ASSERT-and-NULL-definition-so-we-can-c.patch
new file mode 100644
index 00000000..4a3b26c7
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/0001-Ignore-STATIC_ASSERT-and-NULL-definition-so-we-can-c.patch
@@ -0,0 +1,66 @@
1From cc0e412ad05574d22938586172c56863666eb2a5 Mon Sep 17 00:00:00 2001
2From: Nolan Hergert <nolan.hergert@intel.com>
3Date: Mon, 5 Apr 2021 11:15:09 +0800
4Subject: [PATCH] Ignore STATIC_ASSERT and NULL definition so we can compile in
5 OS
6
7Upstream-Status: Backport [from ipmctl patches; https://github.com/intel/ipmctl/blob/development/src/os/patches/0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch]
8
9Signed-off-by: Nolan Hergert <nolan.hergert@intel.com>
10Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
11---
12 MdePkg/Include/Base.h | 13 ++++++++++++-
13 1 file changed, 12 insertions(+), 1 deletion(-)
14
15diff --git a/MdePkg/Include/Base.h b/MdePkg/Include/Base.h
16index 8e4271f6ea..c39511a064 100644
17--- a/MdePkg/Include/Base.h
18+++ b/MdePkg/Include/Base.h
19@@ -318,7 +318,11 @@ struct _LIST_ENTRY {
20 ///
21 /// NULL pointer (VOID *)
22 ///
23+#ifndef OS_BUILD
24+#ifndef UNIT_TEST_UEFI_BUILD
25 #define NULL ((VOID *) 0)
26+#endif
27+#endif
28
29 //
30 // Null character
31@@ -809,7 +813,8 @@ typedef UINTN *BASE_LIST;
32 // Verify that ProcessorBind.h produced UEFI Data Types that are compliant with
33 // Section 2.3.1 of the UEFI 2.3 Specification.
34 //
35-
36+#ifndef OS_BUILD
37+#ifndef UNIT_TEST_UEFI_BUILD
38 STATIC_ASSERT (sizeof (BOOLEAN) == 1, "sizeof (BOOLEAN) does not meet UEFI Specification Data Type requirements");
39 STATIC_ASSERT (sizeof (INT8) == 1, "sizeof (INT8) does not meet UEFI Specification Data Type requirements");
40 STATIC_ASSERT (sizeof (UINT8) == 1, "sizeof (UINT8) does not meet UEFI Specification Data Type requirements");
41@@ -821,6 +826,8 @@ STATIC_ASSERT (sizeof (INT64) == 8, "sizeof (INT64) does not meet UEFI Specifi
42 STATIC_ASSERT (sizeof (UINT64) == 8, "sizeof (UINT64) does not meet UEFI Specification Data Type requirements");
43 STATIC_ASSERT (sizeof (CHAR8) == 1, "sizeof (CHAR8) does not meet UEFI Specification Data Type requirements");
44 STATIC_ASSERT (sizeof (CHAR16) == 2, "sizeof (CHAR16) does not meet UEFI Specification Data Type requirements");
45+#endif
46+#endif
47
48 //
49 // The following three enum types are used to verify that the compiler
50@@ -841,9 +848,13 @@ typedef enum {
51 __VerifyUint32EnumValue = 0xffffffff
52 } __VERIFY_UINT32_ENUM_SIZE;
53
54+#ifndef OS_BUILD
55+#ifndef UNIT_TEST_UEFI_BUILD
56 STATIC_ASSERT (sizeof (__VERIFY_UINT8_ENUM_SIZE) == 4, "Size of enum does not meet UEFI Specification Data Type requirements");
57 STATIC_ASSERT (sizeof (__VERIFY_UINT16_ENUM_SIZE) == 4, "Size of enum does not meet UEFI Specification Data Type requirements");
58 STATIC_ASSERT (sizeof (__VERIFY_UINT32_ENUM_SIZE) == 4, "Size of enum does not meet UEFI Specification Data Type requirements");
59+#endif
60+#endif
61
62 /**
63 Macro that returns a pointer to the data structure that contains a specified field of
64--
652.17.1
66
diff --git a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_02.00.00.3869.bb b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_02.00.00.3869.bb
deleted file mode 100644
index e424a390..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_02.00.00.3869.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1SUMMARY = "Utility for managing Intel Optane DC persistent memory modules"
2DESCRIPTION = "Utility for configuring and managing Intel Optane Persistent \
3Memory modules (PMem). It supports functionality to: \
4Discover DCPMMs on the platform. \
5Provision the platform memory configuration. \
6View and update the firmware on DCPMMs. \
7Configure data-at-rest security on DCPMMs. \
8Track health and performance of DCPMMs. \
9Debug and troubleshoot DCPMMs."
10
11HOMEPAGE = "https://github.com/intel/ipmctl"
12BUGTRACKER = "https://github.com/intel/ipmctl/issues"
13
14LICENSE = "BSD-3-Clause"
15LIC_FILES_CHKSUM = "file://LICENSE;md5=a3eb8e660b3e1c7257002b6fe4141d4f \
16 file://thirdpartynotice.txt;md5=cba483cb16e3fc688a1e366c75800e91"
17
18SRC_URI = "git://github.com/intel/ipmctl.git;branch=master_2_0;protocol=https"
19
20SRCREV = "001596fa2c6a3b16dae0a74c004443edd0d01095"
21S = "${WORKDIR}/git"
22
23inherit cmake
24
25DEPENDS = "ndctl"
26
27EXTRA_OECMAKE = "-DRELEASE=ON"
diff --git a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb
new file mode 100644
index 00000000..688ad108
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Utility for managing Intel Optane DC persistent memory modules"
2DESCRIPTION = "Utility for configuring and managing Intel Optane Persistent \
3Memory modules (PMem). It supports functionality to: \
4Discover DCPMMs on the platform. \
5Provision the platform memory configuration. \
6View and update the firmware on DCPMMs. \
7Configure data-at-rest security on DCPMMs. \
8Track health and performance of DCPMMs. \
9Debug and troubleshoot DCPMMs."
10
11HOMEPAGE = "https://github.com/intel/ipmctl"
12BUGTRACKER = "https://github.com/intel/ipmctl/issues"
13
14LICENSE = "BSD-3-Clause | BSD-2-Clause"
15LIC_FILES_CHKSUM = "file://LICENSE;md5=72b9da60da6219d612ce30b746a0fe71 \
16 file://../edk2/License.txt;md5=2b415520383f7964e96700ae12b4570a"
17
18SRC_URI = "git://github.com/intel/ipmctl.git;protocol=https;branch=development;name=ipmctl; \
19 git://github.com/tianocore/edk2.git;protocol=https;name=edk2;destsuffix=edk2; \
20 file://0001-Ignore-STATIC_ASSERT-and-NULL-definition-so-we-can-c.patch;patchdir=../edk2 \
21"
22
23SRCREV_ipmctl = "4579c7ec127d6c678ce25136f928b66c7ba51097"
24#tag: edk2-stable202102
25SRCREV_edk2 = "ef91b07388e1c0a50c604e5350eeda98428ccea6"
26
27S = "${WORKDIR}/git"
28
29inherit cmake
30
31DEPENDS = "ndctl"
32
33EXTRA_OECMAKE = "-DRELEASE=ON"
34
35do_configure_prepend() {
36 for dir in BaseTools MdeModulePkg MdePkg ShellPkg ; do
37 ln -sf ../edk2/${dir} ${S}
38 done
39}