summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2022-10-07 15:18:07 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-10-12 13:57:11 +0800
commit6e5caa6396e6b8e7d4e0cc8a9f7d81ebab0e2906 (patch)
tree37e5cd90960d2be87b38e8255b5e0e2c5ad3f285 /dynamic-layers
parent3217386ee4c452a47406e2558749e3101123dc4f (diff)
downloadmeta-intel-6e5caa6396e6b8e7d4e0cc8a9f7d81ebab0e2906.tar.gz
icc: add Intel(R) C++ Compiler Classic (ICC) support
Using the Intel® C++ Compiler Classic, you can compile and generate applications that can run on Intel® 64 architecture. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-oneapi/compiler/intel-oneapi-compiler-classic_2022.1.0-3768.bb34
-rw-r--r--dynamic-layers/openembedded-layer/recipes-oneapi/compiler/intel-oneapi-runtime-compilers_2022.1.0-3768.bb59
2 files changed, 93 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/compiler/intel-oneapi-compiler-classic_2022.1.0-3768.bb b/dynamic-layers/openembedded-layer/recipes-oneapi/compiler/intel-oneapi-compiler-classic_2022.1.0-3768.bb
new file mode 100644
index 00000000..db9fd730
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-oneapi/compiler/intel-oneapi-compiler-classic_2022.1.0-3768.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Intel® C++ Compiler Classic"
2
3DESCRIPTION = "Intel® C++ Compiler Classic generates applications \
4that can run on Intel® 64 architecture."
5
6HOMEPAGE = "https://software.intel.com/content/www/us/en/develop/documentation/cpp-compiler-developer-guide-and-reference/top/introducing-the-intel-c-compiler-classic.html"
7
8LICENSE="EULA"
9
10LIC_FILES_CHKSUM = " \
11 file://opt/intel/oneapi/licensing/2022.1.0/license.htm;md5=f721d37d5ef65590e052bc47e15feec3 \
12 "
13
14SRC_URI = " \
15 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-compiler-dpcpp-cpp-and-cpp-classic-2022.1.0-${PV}_amd64.deb;subdir=${BPN};name=classic-compiler \
16 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-common-licensing-2022.1.0-2022.1.0-161_all.deb;subdir=${BPN};name=license \
17 "
18
19SRC_URI[classic-compiler.sha256sum] = "0407cf12127f641f1e1b50e8e8e3c6c9cd27be40b849d697401fa8c140604c23"
20SRC_URI[license.sha256sum] = "30f36ef653964ac629ce77c2c2d21a923c7ba4ff88936c39a8f39237b7446cca"
21
22S = "${WORKDIR}/${BPN}"
23
24inherit bin_package update-alternatives
25RDEPENDS:${PN} += " intel-oneapi-runtime-compilers"
26
27INHIBIT_PACKAGE_STRIP = "1"
28INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
29
30do_install () {
31 install -d ${D}/${bindir}/
32 cp -r ${S}/opt/intel/oneapi/compiler/2022.1.0/linux/bin/intel64/* ${D}${bindir}/
33}
34BBCLASSEXTEND = "native nativesdk"
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/compiler/intel-oneapi-runtime-compilers_2022.1.0-3768.bb b/dynamic-layers/openembedded-layer/recipes-oneapi/compiler/intel-oneapi-runtime-compilers_2022.1.0-3768.bb
new file mode 100644
index 00000000..0faf277d
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-oneapi/compiler/intel-oneapi-runtime-compilers_2022.1.0-3768.bb
@@ -0,0 +1,59 @@
1SUMMARY = "Intel® C++ Compiler Classic runtime common files"
2
3DESCRIPTION = "Intel® C++ Compiler Classic generates applications \
4that can run on Intel® 64 architecture."
5
6HOMEPAGE = "https://software.intel.com/content/www/us/en/develop/documentation/cpp-compiler-developer-guide-and-reference/top/introducing-the-intel-c-compiler-classic.html"
7
8LICENSE="EULA"
9
10LIC_FILES_CHKSUM = " \
11 file://opt/intel/oneapi/lib/licensing/compiler/Intel%20Developer%20Tools%20EULA;md5=7bfc91523de2e84e7131d0eacf2827d4 \
12 "
13
14SRC_URI = " \
15 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-runtime-compilers-${PV}_amd64.deb;subdir=${BPN};name=runtime-compilers \
16 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-runtime-compilers-common-${PV}_all.deb;subdir=${BPN};name=common-compilers \
17 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-compiler-dpcpp-cpp-classic-fortran-shared-runtime-2022.1.0-${PV}_amd64.deb;subdir=${BPN};name=shared-runtime \
18 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-compiler-shared-2022.1.0-${PV}_amd64.deb;subdir=${BPN};name=compiler-linker \
19 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-compiler-dpcpp-cpp-common-2022.1.0-${PV}_all.deb;subdir=${BPN};name=dpcpp-common \
20 "
21
22SRC_URI[runtime-compilers.sha256sum] = "0f27cbde635f30e79329248398e36e5610aa78aeda4ebc9ed1f3538ffbf0ea8d"
23SRC_URI[common-compilers.sha256sum] = "7347588844ad9e86291586c049185381ec960cde09b6fd220c626fb865f8865c"
24SRC_URI[shared-runtime.sha256sum] = "77b7201b5fe991152528ec40d586114edef12bb79c1a1a8fbfd6bd23c2aba5e1"
25SRC_URI[compiler-linker.sha256sum] = "3185dc02473b3d3a34234dd82a17c285e43701455636f93be235b52c2ac6f2c6"
26SRC_URI[dpcpp-common.sha256sum] = "5bc6452a32f5781c96498515d061d8fe9d7bba13b41eb983fe9bb0f792621906"
27
28S = "${WORKDIR}/${BPN}"
29
30inherit bin_package update-alternatives
31
32RDEPENDS:${PN} += " ocl-icd zlib"
33
34INHIBIT_PACKAGE_STRIP = "1"
35INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
36
37# doesn't have GNU_HASH (didn't pass LDFLAGS?)
38INSANE_SKIP:${PN} += "textrel dev-so dev-elf ldflags"
39FILES_SOLIBSDEV = ""
40
41
42do_install () {
43 install -d ${D}${libdir}/
44 install -d ${D}${bindir}/
45 install -d ${D}${libdir}/licensing/compiler/
46 cp -r ${S}/opt/intel/oneapi/compiler/2022.1.0/linux/bin/intel64/* ${D}${bindir}/
47 cp -r ${S}/opt/intel/oneapi/lib/intel64/*.so* ${D}${libdir}/
48 cp -r ${S}/opt/intel/oneapi/lib/*.so* ${D}${libdir}/
49 cp -r ${S}/opt/intel/oneapi/lib/*.a ${D}${libdir}/
50 cp -r ${S}/opt/intel/oneapi/lib/libsycl-fallback-cstring.o ${D}${libdir}/
51 cp -r ${S}/opt/intel/oneapi/lib/libsycl-fallback-cstring.spv ${D}${libdir}/
52 cp -r ${S}/opt/intel/oneapi/lib/licensing/compiler/* ${D}${libdir}/licensing/compiler/
53 cp -r ${S}/opt/intel/oneapi/compiler/2022.1.0/linux/compiler/lib/intel64_lin/* ${D}${libdir}/
54 cp -r ${S}/opt/intel/oneapi/compiler/2022.1.0/linux/lib/clang ${D}${libdir}/
55 rm -rf ${D}/${bindir}/*.so*
56 rm -rf ${D}/opt
57}
58
59BBCLASSEXTEND = "native nativesdk"