diff options
author | Chin Huat Ang <chin.huat.ang@intel.com> | 2019-10-09 01:42:58 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2019-10-10 12:16:10 +0800 |
commit | ef18ef563bee5e0c11ff94c518fae91b166296ac (patch) | |
tree | 6de20876658438b34cfeba7d401dd0ddaf7f2b18 /dynamic-layers/openembedded-layer | |
parent | 13fcf624491cdd0d9b3eb78a4f0cd1781b482b51 (diff) | |
download | meta-intel-ef18ef563bee5e0c11ff94c518fae91b166296ac.tar.gz |
dldt-inference-engine: add PACKAGECONFIG for python API
Add PACKAGECONFIG[python3] for building dldt-inference-engine-python3
package which contains the inference engine python API.
Also tweak recipe to inherit python3native instead of relying on host
python as building the python API requires python3-cython which might
not be available on the host.
Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb | 16 |
1 files changed, 11 insertions, 5 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb index a7db09ae..b8d5d3d5 100644 --- a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb +++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb | |||
@@ -27,7 +27,7 @@ SRC_URI[ma2x8x.sha256sum] = "93640eb13e235d3f71a83cd503c36ff8a63235349e1f528d903 | |||
27 | LICENSE = "Apache-2.0" | 27 | LICENSE = "Apache-2.0" |
28 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" | 28 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
29 | 29 | ||
30 | inherit cmake ptest | 30 | inherit cmake ptest python3native |
31 | 31 | ||
32 | S = "${WORKDIR}/git/inference-engine" | 32 | S = "${WORKDIR}/git/inference-engine" |
33 | 33 | ||
@@ -38,7 +38,7 @@ EXTRA_OECMAKE += " \ | |||
38 | -DENABLE_SAMPLES_CORE=1 \ | 38 | -DENABLE_SAMPLES_CORE=1 \ |
39 | -DENABLE_PLUGIN_RPATH=0 \ | 39 | -DENABLE_PLUGIN_RPATH=0 \ |
40 | -DENABLE_GNA=0 \ | 40 | -DENABLE_GNA=0 \ |
41 | -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \ | 41 | -DPYTHON_EXECUTABLE=${PYTHON} \ |
42 | -DTHREADING=TBB \ | 42 | -DTHREADING=TBB \ |
43 | -DCMAKE_INSTALL_LOCAL_ONLY=OFF \ | 43 | -DCMAKE_INSTALL_LOCAL_ONLY=OFF \ |
44 | -DCMAKE_BUILD_TYPE=DebugWithRelInfo \ | 44 | -DCMAKE_BUILD_TYPE=DebugWithRelInfo \ |
@@ -65,6 +65,7 @@ COMPATIBLE_HOST_libc-musl = "null" | |||
65 | 65 | ||
66 | PACKAGECONFIG ?= "" | 66 | PACKAGECONFIG ?= "" |
67 | PACKAGECONFIG[opencl] = "-DENABLE_CLDNN=1, -DENABLE_CLDNN=0, opencl-icd-loader, opencl-icd-loader intel-compute-runtime" | 67 | PACKAGECONFIG[opencl] = "-DENABLE_CLDNN=1, -DENABLE_CLDNN=0, opencl-icd-loader, opencl-icd-loader intel-compute-runtime" |
68 | PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native, python3" | ||
68 | 69 | ||
69 | do_install_ptest_base_prepend() { | 70 | do_install_ptest_base_prepend() { |
70 | # While not a Makefile based project that strictly falls into the category of | 71 | # While not a Makefile based project that strictly falls into the category of |
@@ -74,9 +75,6 @@ do_install_ptest_base_prepend() { | |||
74 | mv ${D}${bindir}/InferenceEngineUnitTests ${D}${PTEST_PATH}/ | 75 | mv ${D}${bindir}/InferenceEngineUnitTests ${D}${PTEST_PATH}/ |
75 | } | 76 | } |
76 | 77 | ||
77 | # Move inference engine samples into a separate package | ||
78 | PACKAGES =+ "${PN}-samples" | ||
79 | |||
80 | FILES_${PN}-dev = "${includedir} \ | 78 | FILES_${PN}-dev = "${includedir} \ |
81 | ${libdir}/cmake \ | 79 | ${libdir}/cmake \ |
82 | ${libdir}/libinference_engine.so \ | 80 | ${libdir}/libinference_engine.so \ |
@@ -86,4 +84,12 @@ FILES_${PN} += "${libdir}/lib*${SOLIBSDEV} \ | |||
86 | ${datadir}/openvino \ | 84 | ${datadir}/openvino \ |
87 | " | 85 | " |
88 | 86 | ||
87 | # Move inference engine samples into a separate package | ||
88 | PACKAGES =+ "${PN}-samples" | ||
89 | |||
89 | FILES_${PN}-samples = "${bindir}" | 90 | FILES_${PN}-samples = "${bindir}" |
91 | |||
92 | # Package for inference engine python API | ||
93 | PACKAGES =+ "${PN}-${PYTHON_PN}" | ||
94 | |||
95 | FILES_${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}/openvino" | ||