summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer
diff options
context:
space:
mode:
authorVtiurina, Mariia <mariia.vtiurina@intel.com>2021-11-01 19:19:35 +0300
committerAnuj Mittal <anuj.mittal@intel.com>2021-11-03 21:56:15 +0800
commit4bdaff2a2f41adc3b420c8abdb3dc380b9307653 (patch)
tree29a47d5b2a6964a031715dd2cf5091a2eee9cd16 /dynamic-layers/openembedded-layer
parent6a38cec44b0b96ecd78157fcac2a925609171bee (diff)
downloadmeta-intel-4bdaff2a2f41adc3b420c8abdb3dc380b9307653.tar.gz
intel-oneapi-mkl: add recipe for mkl library (runtime only)
Intel® oneAPI Math Kernel Library (oneMKL) runtime library. For more details, see: https://www.intel.com/content/www/us/en/developer/tools/oneapi/onemkl.html Signed-off-by: Mariia Vtiurina <mariia.vtiurina@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-oneapi/mkl/intel-oneapi-mkl_2021.4.0-640.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/mkl/intel-oneapi-mkl_2021.4.0-640.bb b/dynamic-layers/openembedded-layer/recipes-oneapi/mkl/intel-oneapi-mkl_2021.4.0-640.bb
new file mode 100644
index 00000000..add4c806
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-oneapi/mkl/intel-oneapi-mkl_2021.4.0-640.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Intel® oneAPI Math Kernel Library (oneMKL)"
2DESCRIPTION = "The Intel® oneAPI Math Kernel Library (oneMKL) is a computing \
3 math library of highly optimized and extensively parallelized routines \
4 for applications that require maximum performance. oneMKL contains \
5 the high-performance optimizations from the full Intel® Math Kernel Library \
6 for CPU architectures (with C/Fortran programming language interfaces)\
7 and adds to them a set of DPC++ programming language interfaces for \
8 achieving performance on various CPU architectures \
9 and Intel Graphics Technology for certain key functionalities."
10HOMEPAGE = "https://software.intel.com/content/www/us/en/develop/tools/oneapi/components/onemkl.html"
11
12LICENSE = "ISSL"
13
14LIC_FILES_CHKSUM = " \
15 file://opt/intel/oneapi/lib/licensing/mkl/license.txt;md5=4867389dfbeb11811d66cdcbcc8712a6 \
16 file://opt/intel/oneapi/lib/licensing/mkl/third-party-programs-benchmarks.txt;md5=cb98e1a1f14c05ea85a979ea8982e7a4 \
17 file://opt/intel/oneapi/lib/licensing/mkl/third-party-programs-ipp.txt;md5=a4b2bf15e38f5c1267cdafed18bc0b09 \
18 file://opt/intel/oneapi/lib/licensing/mkl/third-party-programs-openmp.txt;md5=6b3c1aa2a11393060074c0346ce21e49 \
19 file://opt/intel/oneapi/lib/licensing/mkl/third-party-programs-safestring.txt;md5=c3aeee91c6d35a0f0753aed6c2633b82 \
20 file://opt/intel/oneapi/lib/licensing/mkl/third-party-programs.txt;md5=980965cf1f086d40998ca4981968b6a4 \
21 "
22
23SRC_URI = " \
24 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-runtime-mkl-${PV}_amd64.deb;subdir=${BPN};name=runtime \
25 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-runtime-mkl-common-${PV}_all.deb;subdir=${BPN};name=common \
26 "
27
28SRC_URI[runtime.sha256sum] = "0ff97d07e6db5d55edf9a744b0b0ee0ea75866e80ab5510f596c57d5535c20d4"
29SRC_URI[common.sha256sum] = "70ecfe07b2f888f66938a0e207aa8cb0637eb8d4deb659f6f6d924b8ee70a76e"
30
31S = "${WORKDIR}/${BPN}"
32
33inherit bin_package
34
35INHIBIT_PACKAGE_STRIP = "1"
36INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
37
38RDEPENDS:${PN} += "tbb intel-oneapi-compiler setup-intel-oneapi-env"
39INSANE_SKIP:${PN} = "ldflags textrel dev-so"