summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch
diff options
context:
space:
mode:
authorChin Huat Ang <chin.huat.ang@intel.com>2019-09-27 06:11:51 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-09-28 17:18:30 +0800
commit096598691de246c23902d49d228c7562ba2c9cc5 (patch)
tree8df7c03aaf84bd38374ae049ba0f31031c20c6d0 /dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch
parent7aef51c962c023f27e3fcda4c2419f1ced9942b9 (diff)
downloadmeta-intel-096598691de246c23902d49d228c7562ba2c9cc5.tar.gz
dldt-inference-engine: add recipe
This recipe builds the inference engine from opencv/dldt 2019 R1.1 release. OpenVINO™ toolkit, short for Open Visual Inference and Neural network Optimization toolkit, provides developers with improved neural network performance on a variety of Intel® processors and helps further unlock cost-effective, real-time vision applications. The toolkit enables deep learning inference and easy heterogeneous execution across multiple Intel® platforms (CPU, Intel® Processor Graphics)—providing implementations across cloud architectures to edge device. For more details, see: https://01.org/openvinotoolkit The recipe needs components from meta-oe so move it to dynamic-layers/openembedded-layer. GPU plugin support needs intel-compute-runtime which can be built by including clang layer in the mix as well. CPU and GPU plugins have been sanity tested to work using classification_sample. Further fine-tuning is still needed to improve the performance. Original patch by Anuj Mittal. Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch
new file mode 100644
index 00000000..8af9527e
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch
@@ -0,0 +1,32 @@
1From 6e225e85d5763e883128ee7b8a97ac247c46b465 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 20 Aug 2019 12:40:09 +0800
4Subject: [PATCH] use ade and pugixml from system
5
6Don't build a local copy and use the one from sysroot.
7
8Upstream-Status: Submitted
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 inference-engine/thirdparty/CMakeLists.txt | 5 ++---
13 1 file changed, 2 insertions(+), 3 deletions(-)
14
15diff --git a/inference-engine/thirdparty/CMakeLists.txt b/inference-engine/thirdparty/CMakeLists.txt
16index f65f38c..7f23e8f 100644
17--- a/inference-engine/thirdparty/CMakeLists.txt
18+++ b/inference-engine/thirdparty/CMakeLists.txt
19@@ -7,11 +7,10 @@ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
20 set(CMAKE_CC_FLAGS "${CMAKE_CC_FLAGS} -Wno-unknown-warning-option -Wno-inconsistent-missing-override -Wno-pass-failed")
21 endif()
22
23-add_subdirectory(pugixml)
24-export(TARGETS pugixml NAMESPACE IE:: APPEND FILE "${CMAKE_BINARY_DIR}/targets.cmake")
25+# add_subdirectory(pugixml)
26+# export(TARGETS pugixml NAMESPACE IE:: APPEND FILE "${CMAKE_BINARY_DIR}/targets.cmake")
27
28 add_subdirectory(stb_lib)
29-add_subdirectory(ade)
30
31 if (ENABLE_CLDNN)
32 set(CLDNN__OUTPUT_BIN_DIR ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})