summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-use-provided-paths.patch
diff options
context:
space:
mode:
authorChin Huat Ang <chin.huat.ang@intel.com>2019-09-27 06:11:51 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-09-28 17:18:30 +0800
commit096598691de246c23902d49d228c7562ba2c9cc5 (patch)
tree8df7c03aaf84bd38374ae049ba0f31031c20c6d0 /dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-use-provided-paths.patch
parent7aef51c962c023f27e3fcda4c2419f1ced9942b9 (diff)
downloadmeta-intel-096598691de246c23902d49d228c7562ba2c9cc5.tar.gz
dldt-inference-engine: add recipe
This recipe builds the inference engine from opencv/dldt 2019 R1.1 release. OpenVINO™ toolkit, short for Open Visual Inference and Neural network Optimization toolkit, provides developers with improved neural network performance on a variety of Intel® processors and helps further unlock cost-effective, real-time vision applications. The toolkit enables deep learning inference and easy heterogeneous execution across multiple Intel® platforms (CPU, Intel® Processor Graphics)—providing implementations across cloud architectures to edge device. For more details, see: https://01.org/openvinotoolkit The recipe needs components from meta-oe so move it to dynamic-layers/openembedded-layer. GPU plugin support needs intel-compute-runtime which can be built by including clang layer in the mix as well. CPU and GPU plugins have been sanity tested to work using classification_sample. Further fine-tuning is still needed to improve the performance. Original patch by Anuj Mittal. Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-use-provided-paths.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-use-provided-paths.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-use-provided-paths.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-use-provided-paths.patch
new file mode 100644
index 00000000..d20ea111
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-use-provided-paths.patch
@@ -0,0 +1,33 @@
1From 3700b244d0906f339f33bcdbfc198f3ba97bf1a0 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 20 Aug 2019 15:58:04 +0800
4Subject: [PATCH] use provided paths
5
6Use the CMake paths provided by environment instead of hardcoding them here.
7
8Upstream-Status: Pending
9Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
10
11---
12 inference-engine/CMakeLists.txt | 8 --------
13 1 file changed, 8 deletions(-)
14
15diff --git a/inference-engine/CMakeLists.txt b/inference-engine/CMakeLists.txt
16index 1c3d6ea..9e15382 100644
17--- a/inference-engine/CMakeLists.txt
18+++ b/inference-engine/CMakeLists.txt
19@@ -99,14 +99,6 @@ if(NOT(UNIX))
20 set (CMAKE_RUNTIME_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER})
21 set (LIBRARY_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER})
22 set (LIBRARY_OUTPUT_PATH ${LIBRARY_OUTPUT_DIRECTORY}) # compatibility issue: linux uses LIBRARY_OUTPUT_PATH, windows uses LIBRARY_OUTPUT_DIRECTORY
23-else ()
24- set (CMAKE_LIBRARY_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER}/${IE_BUILD_CONFIGURATION}/lib)
25- set (CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER}/${IE_BUILD_CONFIGURATION}/lib)
26- set (CMAKE_COMPILE_PDB_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER}/${IE_BUILD_CONFIGURATION})
27- set (CMAKE_PDB_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER}/${IE_BUILD_CONFIGURATION})
28- set (CMAKE_RUNTIME_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER}/${IE_BUILD_CONFIGURATION})
29- set (LIBRARY_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER}/${IE_BUILD_CONFIGURATION}/lib)
30- set (LIBRARY_OUTPUT_PATH ${LIBRARY_OUTPUT_DIRECTORY}/lib)
31 endif()
32
33 if (APPLE)