summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-04-05 12:24:38 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-04-06 10:09:02 +0800
commitf5cbba628b36008a4d2cc8820e2c004483094135 (patch)
tree63414e7762262ed80e65efadf3a851486cccc9ff /dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb
parent8f6c78dce214688b9c592e80ffb16ecfc03153b5 (diff)
downloadmeta-intel-f5cbba628b36008a4d2cc8820e2c004483094135.tar.gz
ipmctl: upgrade 02.00.00.3869 -> 03.00.00.0302
Ref: https://github.com/intel/ipmctl/releases/tag/v03.00.00.0302 Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb
new file mode 100644
index 00000000..688ad108
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0302.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Utility for managing Intel Optane DC persistent memory modules"
2DESCRIPTION = "Utility for configuring and managing Intel Optane Persistent \
3Memory modules (PMem). It supports functionality to: \
4Discover DCPMMs on the platform. \
5Provision the platform memory configuration. \
6View and update the firmware on DCPMMs. \
7Configure data-at-rest security on DCPMMs. \
8Track health and performance of DCPMMs. \
9Debug and troubleshoot DCPMMs."
10
11HOMEPAGE = "https://github.com/intel/ipmctl"
12BUGTRACKER = "https://github.com/intel/ipmctl/issues"
13
14LICENSE = "BSD-3-Clause | BSD-2-Clause"
15LIC_FILES_CHKSUM = "file://LICENSE;md5=72b9da60da6219d612ce30b746a0fe71 \
16 file://../edk2/License.txt;md5=2b415520383f7964e96700ae12b4570a"
17
18SRC_URI = "git://github.com/intel/ipmctl.git;protocol=https;branch=development;name=ipmctl; \
19 git://github.com/tianocore/edk2.git;protocol=https;name=edk2;destsuffix=edk2; \
20 file://0001-Ignore-STATIC_ASSERT-and-NULL-definition-so-we-can-c.patch;patchdir=../edk2 \
21"
22
23SRCREV_ipmctl = "4579c7ec127d6c678ce25136f928b66c7ba51097"
24#tag: edk2-stable202102
25SRCREV_edk2 = "ef91b07388e1c0a50c604e5350eeda98428ccea6"
26
27S = "${WORKDIR}/git"
28
29inherit cmake
30
31DEPENDS = "ndctl"
32
33EXTRA_OECMAKE = "-DRELEASE=ON"
34
35do_configure_prepend() {
36 for dir in BaseTools MdeModulePkg MdePkg ShellPkg ; do
37 ln -sf ../edk2/${dir} ${S}
38 done
39}