diff options
author | Vtiurina, Mariia <mariia.vtiurina@intel.com> | 2021-10-20 12:27:02 +0300 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2021-10-21 13:28:10 +0800 |
commit | 272e0889026e6479fd366d4447e7345e4dd52d11 (patch) | |
tree | 1776ea7b0c7bddb7a6b91330d7b427401d9bdd55 /dynamic-layers/openembedded-layer/recipes-oneapi | |
parent | 16e1c7d376758f9bc167a209580446bb12f65578 (diff) | |
download | meta-intel-272e0889026e6479fd366d4447e7345e4dd52d11.tar.gz |
intel-oneapi-ipp: add recipe for Intel OneAPI IPP library (runtime only)
The initial version of the recipe for Intel OneAPI IPP library.
IPP is an extensive library of ready-to-use, domain-specific functions
that are highly optimized for diverse Intel architectures.
Signed-off-by: Mariia Vtiurina <mariia.vtiurina@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-oneapi')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-oneapi/ipp/intel-oneapi-ipp_2021.3.0-333.bb | 42 |
1 files changed, 42 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/ipp/intel-oneapi-ipp_2021.3.0-333.bb b/dynamic-layers/openembedded-layer/recipes-oneapi/ipp/intel-oneapi-ipp_2021.3.0-333.bb new file mode 100644 index 00000000..231e5433 --- /dev/null +++ b/dynamic-layers/openembedded-layer/recipes-oneapi/ipp/intel-oneapi-ipp_2021.3.0-333.bb | |||
@@ -0,0 +1,42 @@ | |||
1 | DESCRIPTION = "IntelĀ® Integrated Performance Primitives are production-ready \ | ||
2 | building blocks for cross-platform performance. Develop high-performance vision, \ | ||
3 | signal, security, and storage applications with this multithreaded software library." | ||
4 | HOMEPAGE = "https://software.intel.com/content/www/us/en/develop/tools/oneapi/components/ipp.html" | ||
5 | |||
6 | LICENSE = "ISSL" | ||
7 | |||
8 | LIC_FILES_CHKSUM = " \ | ||
9 | file://opt/intel/oneapi/lib/licensing/ipp/license.txt;md5=4867389dfbeb11811d66cdcbcc8712a6 \ | ||
10 | file://opt/intel/oneapi/lib/licensing/ipp/third-party-programs.txt;md5=934f899238546b3250e8d1de7262e563 \ | ||
11 | " | ||
12 | |||
13 | SRC_URI = " \ | ||
14 | https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-runtime-ipp-${PV}_amd64.deb;subdir=${BPN};name=runtime \ | ||
15 | https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-runtime-ipp-common-${PV}_all.deb;subdir=${BPN};name=common \ | ||
16 | " | ||
17 | |||
18 | SRC_URI[runtime.sha256sum] = "10f611fe4d68e0b8e55cae0c8ed48e25c15e79dd1b7f83d87c2a342fe601485f" | ||
19 | SRC_URI[common.sha256sum] = "dc733ccc61b7c74a3ffa1c9f63a321e678cba8e09afd1c4ac882954d4602ed97" | ||
20 | |||
21 | S = "${WORKDIR}/${BPN}" | ||
22 | |||
23 | COMPATIBLE_HOST:libc-musl = "null" | ||
24 | |||
25 | inherit bin_package | ||
26 | |||
27 | INHIBIT_PACKAGE_STRIP = "1" | ||
28 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
29 | |||
30 | RDEPENDS:${PN} += "tbb setup-intel-oneapi-env" | ||
31 | INSANE_SKIP:${PN} += "ldflags dev-so" | ||
32 | |||
33 | # Some libraries are linking against the unversioned lib and there's no soname entry. | ||
34 | # Workaround errors like: | ||
35 | # Problem: conflicting requests | ||
36 | # - nothing provides libippcore_tl_omp.so()(64bit) needed by intel-oneapi-ipp-2021.3.0+333-r0.skylake_64 | ||
37 | do_install:append () { | ||
38 | install -m 755 ${D}/opt/intel/oneapi/lib/intel64/libippcore_tl_omp.so.10.2 ${D}/opt/intel/oneapi/lib/intel64/libippcore_tl_omp.so | ||
39 | install -m 755 ${D}/opt/intel/oneapi/lib/intel64/libippcore_tl_tbb.so.10.2 ${D}/opt/intel/oneapi/lib/intel64/libippcore_tl_tbb.so | ||
40 | install -m 755 ${D}/opt/intel/oneapi/lib/intel64/libippi_tl_omp.so.10.2 ${D}/opt/intel/oneapi/lib/intel64/libippi_tl_omp.so | ||
41 | install -m 755 ${D}/opt/intel/oneapi/lib/intel64/libippi_tl_tbb.so.10.2 ${D}/opt/intel/oneapi/lib/intel64/libippi_tl_tbb.so | ||
42 | } | ||