summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-oneapi/ospray/ospray_2.11.0.bb
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2023-03-17 15:22:13 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-03-17 15:49:31 +0800
commit476275e9c035808860a9e2e399df214a5cf349e5 (patch)
treeed996667b9902b87e439d177281472a727907385 /dynamic-layers/openembedded-layer/recipes-oneapi/ospray/ospray_2.11.0.bb
parenta2657c7cea2713ab01cb044a6033fbda28704b27 (diff)
downloadmeta-intel-476275e9c035808860a9e2e399df214a5cf349e5.tar.gz
ospray: upgrade 2.10.0 -> 2.11.0
Added entry for Intel(R) Implicit SPMD Program Compiler (ISPC) in third-party-programs.txt. Target ospray_module_cpu library build need libispcrt from ispc, so added ispc also to DEPENDS. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-oneapi/ospray/ospray_2.11.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-oneapi/ospray/ospray_2.11.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/ospray/ospray_2.11.0.bb b/dynamic-layers/openembedded-layer/recipes-oneapi/ospray/ospray_2.11.0.bb
new file mode 100644
index 00000000..6ea2333e
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-oneapi/ospray/ospray_2.11.0.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Intel OSPray, Ray Tracing based Rendering Engine"
2DESCRIPTION = "Intel OSPRay is an open source, scalable, and portable ray \
3tracing engine for high-performance, high-fidelity visualization on \
4Intel Architecture CPUs."
5HOMEPAGE = "https://www.ospray.org/"
6
7LICENSE = "Apache-2.0 & BSD-3-Clause & MIT & Zlib"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1dece7821bf3fd70fe1309eaa37d52a2 \
9 file://third-party-programs.txt;md5=978092834060d3f38dbcb11ade918e2c \
10 "
11
12inherit pkgconfig cmake
13
14S = "${WORKDIR}/git"
15
16SRC_URI = "git://github.com/ospray/ospray.git;protocol=https;branch=master \
17 "
18SRCREV = "cdb39c88a2fb806feaae30de897acd30297f8e94"
19
20COMPATIBLE_HOST = '(x86_64).*-linux'
21COMPATIBLE_HOST:libc-musl = "null"
22
23DEPENDS = "rkcommon ispc ispc-native openvkl embree"
24
25EXTRA_OECMAKE += " \
26 -DISPC_EXECUTABLE=${STAGING_BINDIR_NATIVE}/ispc \
27 -DOSPRAY_ENABLE_APPS_BENCHMARK=OFF \
28 -DOSPRAY_ENABLE_APPS_TESTING=OFF \
29 "
30
31PACKAGES =+ "${PN}-apps"
32FILES:${PN}-apps = "\
33 ${bindir} \
34 "
35
36UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>(\d+(\.\d+)+))$"