summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2322.0.0.0.bb
diff options
context:
space:
mode:
authorLee Chee Yang <chee.yang.lee@intel.com>2023-10-30 14:32:06 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-10-30 15:42:30 +0800
commit7b62d64d1ed1b31a8be7b1ca36bd97049b3b2324 (patch)
treee70b61dc2f6d0747c5083bbbd095fb96a9c6bbd8 /dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2322.0.0.0.bb
parent758d05bc76332f207a96a19ff812d624b328c983 (diff)
downloadmeta-intel-7b62d64d1ed1b31a8be7b1ca36bd97049b3b2324.tar.gz
lms: 2245.0.0.0 -> 2322.0.0.0
Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2322.0.0.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2322.0.0.0.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2322.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2322.0.0.0.bb
new file mode 100644
index 00000000..f981af75
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2322.0.0.0.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Intel(R) Local Managability Service"
2DESCRIPTION = "Intel Local Manageability Service allows applications \
3to access the Intel Active Management Technology (AMT) firmware via \
4the Intel Management Engine Interface (MEI)."
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=2ee41112a44fe7014dce33e26468ba93"
8
9COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
10
11COMPATIBLE_HOST:libc-musl = "null"
12
13inherit cmake systemd features_check
14
15DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native pkgconfig-native"
16
17EXTRA_OECMAKE += "-DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3"
18
19# Enable either connman or networkmanager or none but not both.
20PACKAGECONFIG ??= "connman"
21PACKAGECONFIG[connman] = "-DNETWORK_CN=ON, -DNETWORK_CN=OFF, connman"
22PACKAGECONFIG[networkmanager] = "-DNETWORK_NM=ON, -DNETWORK_NM=OFF, networkmanager"
23
24REQUIRED_DISTRO_FEATURES= "systemd"
25
26FILES:${PN} += "${datadir}/dbus-1/system-services/*.service"
27
28S = "${WORKDIR}/git"
29
30SYSTEMD_SERVICE:${PN} = "lms.service"
31
32SRC_URI = "git://github.com/intel/lms.git;branch=master;protocol=https \
33 file://fix-gcc13.patch \
34 file://0001-UNS-CMakeLists.txt-migrate-udev-rules-to-usr.patch \
35 "
36SRCREV = "cbc1e1019cf5dc2d03a3b722ee07fbfb9a90f2d1"
37
38do_install:append() {
39 install -d ${D}${systemd_system_unitdir}
40 install -m 0644 ${B}/UNS/lms.service ${D}${systemd_system_unitdir}
41 install -d ${D}${sysconfdir}/udev/rules.d
42 install -m 0644 ${S}/UNS/linux_scripts/70-mei-wdt.rules ${D}${sysconfdir}/udev/rules.d/70-mei-wdt.rules
43}
44
45RDEPENDS:${PN} += "ace"
46
47# This CVE is for Lan Management System software and not this lms.
48CVE_CHECK_IGNORE += "CVE-2018-1000535"