diff options
author | Anuj Mittal <anuj.mittal@intel.com> | 2020-11-20 23:16:50 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2020-11-21 00:09:14 +0800 |
commit | a693b4d6b9521ace1b96c6833693ab6e39737088 (patch) | |
tree | d4f050de6c013cfe8a7ee989ace0f9f26eef90ca /dynamic-layers/clang-layer | |
parent | 05da12b7667c098b5bee5be5b9b896410438ce1a (diff) | |
download | meta-intel-a693b4d6b9521ace1b96c6833693ab6e39737088.tar.gz |
intel-compute-runtime: upgrade 20.40.18075 -> 20.40.18403
Release notes:
https://github.com/intel/compute-runtime/releases/tag/20.45.18403
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch | 14 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.40.18403.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.40.18075.bb) | 2 |
2 files changed, 8 insertions, 8 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch index 881359c8..631e0ce6 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From bde2a2b58d7f7b3063406db600e5b988fbcf01aa Mon Sep 17 00:00:00 2001 | 1 | From 32851d269ac0c027730168c04d9ce32d0eb50905 Mon Sep 17 00:00:00 2001 |
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | 2 | From: Naveen Saini <naveen.kumar.saini@intel.com> |
3 | Date: Wed, 27 May 2020 11:12:09 +0000 | 3 | Date: Wed, 27 May 2020 11:12:09 +0000 |
4 | Subject: [PATCH] intel-compute-runtime: allow to find cpp_generation_tool | 4 | Subject: [PATCH] intel-compute-runtime: allow to find cpp_generation_tool |
@@ -12,22 +12,22 @@ Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | |||
12 | 1 file changed, 4 insertions(+), 4 deletions(-) | 12 | 1 file changed, 4 insertions(+), 4 deletions(-) |
13 | 13 | ||
14 | diff --git a/shared/source/built_ins/kernels/CMakeLists.txt b/shared/source/built_ins/kernels/CMakeLists.txt | 14 | diff --git a/shared/source/built_ins/kernels/CMakeLists.txt b/shared/source/built_ins/kernels/CMakeLists.txt |
15 | index 84935be2d..150c450d7 100644 | 15 | index 1b1225077..2e8148c25 100644 |
16 | --- a/shared/source/built_ins/kernels/CMakeLists.txt | 16 | --- a/shared/source/built_ins/kernels/CMakeLists.txt |
17 | +++ b/shared/source/built_ins/kernels/CMakeLists.txt | 17 | +++ b/shared/source/built_ins/kernels/CMakeLists.txt |
18 | @@ -84,9 +84,9 @@ function(compile_builtin gen_type platform_type builtin bits builtin_options) | 18 | @@ -93,9 +93,9 @@ function(compile_builtin gen_type platform_type builtin bits builtin_options mod |
19 | ) | 19 | ) |
20 | add_custom_command( | 20 | add_custom_command( |
21 | OUTPUT ${OUTPUT_FILE_CPP} | 21 | OUTPUT ${OUTPUT_FILE_CPP} |
22 | - COMMAND $<TARGET_FILE:cpp_generate_tool> --file ${OUTPUTPATH_BASE}.gen --output ${OUTPUT_FILE_CPP} --array ${BASENAME} --platform ${family_name_with_type} | 22 | - COMMAND $<TARGET_FILE:cpp_generate_tool> --file ${OUTPUTPATH_BASE}.gen --output ${OUTPUT_FILE_CPP} --array ${mode}_${BASENAME} --platform ${family_name_with_type} |
23 | + COMMAND cpp_generate_tool --file ${OUTPUTPATH_BASE}.gen --output ${OUTPUT_FILE_CPP} --array ${BASENAME} --platform ${family_name_with_type} | 23 | + COMMAND cpp_generate_tool --file ${OUTPUTPATH_BASE}.gen --output ${OUTPUT_FILE_CPP} --array ${mode}_${BASENAME} --platform ${family_name_with_type} |
24 | WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} | 24 | WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} |
25 | - DEPENDS ${OUTPUTPATH_BASE}.gen $<TARGET_FILE:cpp_generate_tool> | 25 | - DEPENDS ${OUTPUTPATH_BASE}.gen $<TARGET_FILE:cpp_generate_tool> |
26 | + DEPENDS ${OUTPUTPATH_BASE}.gen cpp_generate_tool | 26 | + DEPENDS ${OUTPUTPATH_BASE}.gen cpp_generate_tool |
27 | ) | 27 | ) |
28 | endfunction() | 28 | endfunction() |
29 | 29 | ||
30 | @@ -127,9 +127,9 @@ function(generate_cpp_spirv builtin) | 30 | @@ -136,9 +136,9 @@ function(generate_cpp_spirv builtin) |
31 | ) | 31 | ) |
32 | add_custom_command( | 32 | add_custom_command( |
33 | OUTPUT ${OUTPUT_FILE_CPP} | 33 | OUTPUT ${OUTPUT_FILE_CPP} |
@@ -40,5 +40,5 @@ index 84935be2d..150c450d7 100644 | |||
40 | endfunction() | 40 | endfunction() |
41 | 41 | ||
42 | -- | 42 | -- |
43 | 2.26.2 | 43 | 2.28.0 |
44 | 44 | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.40.18075.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.40.18403.bb index bc096833..1cefa1a8 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.40.18075.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.40.18403.bb | |||
@@ -12,7 +12,7 @@ SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \ | |||
12 | " | 12 | " |
13 | SRC_URI_append_class-target = " file://allow-to-find-cpp-generation-tool.patch" | 13 | SRC_URI_append_class-target = " file://allow-to-find-cpp-generation-tool.patch" |
14 | 14 | ||
15 | SRCREV = "7e31ec37d78693c08a1fcb2ec31801e64cb497d3" | 15 | SRCREV = "152f89f2f2b38efe3d3c0423b76d65a8f63916be" |
16 | 16 | ||
17 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
18 | 18 | ||