diff options
author | Naveen Saini <naveen.kumar.saini@intel.com> | 2020-02-07 13:59:55 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2020-02-11 14:32:30 +0800 |
commit | f8771831bb368be7eb3575ae68447176cce118ad (patch) | |
tree | daaf97e5358dcb132ebfd5d341db09eb332e0663 /dynamic-layers/clang-layer/recipes-opencl | |
parent | 0b6fd29c9f166fce4cdb45e26e5f2bb9255e5df1 (diff) | |
download | meta-intel-f8771831bb368be7eb3575ae68447176cce118ad.tar.gz |
intel-graphics-compiler: upgrade 1.0.2714.1 -> 1.0.3151
Dropped the patch which is already upstream.
Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-skip-execution-of-ElfPackager.patch | 34 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/files/0002-comment-out-dump-functions.patch | 87 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3151.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.2714.1.bb) | 5 |
3 files changed, 21 insertions, 105 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-skip-execution-of-ElfPackager.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-skip-execution-of-ElfPackager.patch index 3f3e1d49..65342d9c 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-skip-execution-of-ElfPackager.patch +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-skip-execution-of-ElfPackager.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 4e903a6914d5124d616cf085e30e8cbaa20afb77 Mon Sep 17 00:00:00 2001 | 1 | From 5501fab763aa2b11437fbdb19e07a11157a7d3e6 Mon Sep 17 00:00:00 2001 |
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | 2 | From: Naveen Saini <naveen.kumar.saini@intel.com> |
3 | Date: Wed, 12 Jun 2019 14:10:23 +0800 | 3 | Date: Thu, 6 Feb 2020 14:56:56 +0800 |
4 | Subject: [PATCH 1/4] skip execution of ElfPackager | 4 | Subject: [PATCH] skip execution of ElfPackager |
5 | 5 | ||
6 | ElfPackager adds the ability to convert llvm bitcode into elf files for | 6 | ElfPackager adds the ability to convert llvm bitcode into elf files for |
7 | easier partitioning. Skip for now until we start building a native | 7 | easier partitioning. Skip for now until we start building a native |
@@ -12,25 +12,29 @@ Upstream-Status: Inappropriate [configuration specific] | |||
12 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | 12 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> |
13 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | 13 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> |
14 | --- | 14 | --- |
15 | IGC/ElfPackager/CMakeLists.txt | 8 ++++---- | 15 | IGC/ElfPackager/CMakeLists.txt | 12 ++++++------ |
16 | 1 file changed, 4 insertions(+), 4 deletions(-) | 16 | 1 file changed, 6 insertions(+), 6 deletions(-) |
17 | 17 | ||
18 | diff --git a/IGC/ElfPackager/CMakeLists.txt b/IGC/ElfPackager/CMakeLists.txt | 18 | diff --git a/IGC/ElfPackager/CMakeLists.txt b/IGC/ElfPackager/CMakeLists.txt |
19 | index d9487aeb..bc728ada 100644 | 19 | index 563ac9d6..c6c74ce9 100644 |
20 | --- a/IGC/ElfPackager/CMakeLists.txt | 20 | --- a/IGC/ElfPackager/CMakeLists.txt |
21 | +++ b/IGC/ElfPackager/CMakeLists.txt | 21 | +++ b/IGC/ElfPackager/CMakeLists.txt |
22 | @@ -71,10 +71,10 @@ include_directories ( | 22 | @@ -71,12 +71,12 @@ include_directories ( |
23 | ${IGC_SOURCE_DIR}/AdaptorOCL/CLElfLib/ | 23 | ${IGC_SOURCE_DIR}/AdaptorOCL/CLElfLib/ |
24 | ) | 24 | ) |
25 | 25 | ||
26 | -add_custom_command(TARGET ${IGC_BUILD__PROJ__ElfPackager} | 26 | -if(NOT ANDROID) |
27 | - POST_BUILD | 27 | - add_custom_command(TARGET ${IGC_BUILD__PROJ__ElfPackager} |
28 | - COMMAND $<TARGET_FILE:${IGC_BUILD__PROJ__ElfPackager}> -includeSizet -funcList ${CMAKE_CURRENT_SOURCE_DIR}/function_bin.txt ${IGC_BUILD__BIF_DIR}/OCLBiFImpl.bc ${IGC_BUILD__BIF_DIR}/igdclbif.bin | 28 | - POST_BUILD |
29 | - ) | 29 | - COMMAND $<TARGET_FILE:${IGC_BUILD__PROJ__ElfPackager}> -includeSizet -funcList ${CMAKE_CURRENT_SOURCE_DIR}/function_bin.txt ${IGC_BUILD__BIF_DIR}/OCLBiFImpl.bc ${IGC_BUILD__BIF_DIR}/igdclbif.bin |
30 | +#add_custom_command(TARGET ${IGC_BUILD__PROJ__ElfPackager} | 30 | - ) |
31 | +# POST_BUILD | 31 | -endif() |
32 | +# COMMAND $<TARGET_FILE:${IGC_BUILD__PROJ__ElfPackager}> -includeSizet -funcList ${CMAKE_CURRENT_SOURCE_DIR}/function_bin.txt ${IGC_BUILD__BIF_DIR}/OCLBiFImpl.bc ${IGC_BUILD__BIF_DIR}/igdclbif.bin | 32 | +#if(NOT ANDROID) |
33 | +# ) | 33 | +# add_custom_command(TARGET ${IGC_BUILD__PROJ__ElfPackager} |
34 | +# POST_BUILD | ||
35 | +# COMMAND $<TARGET_FILE:${IGC_BUILD__PROJ__ElfPackager}> -includeSizet -funcList ${CMAKE_CURRENT_SOURCE_DIR}/function_bin.txt ${IGC_BUILD__BIF_DIR}/OCLBiFImpl.bc ${IGC_BUILD__BIF_DIR}/igdclbif.bin | ||
36 | +# ) | ||
37 | +#endif() | ||
34 | 38 | ||
35 | 39 | ||
36 | add_dependencies("${IGC_BUILD__PROJ__ElfPackager}" "${IGC_BUILD__PROJ__BiFModule_OCL}") | 40 | add_dependencies("${IGC_BUILD__PROJ__ElfPackager}" "${IGC_BUILD__PROJ__BiFModule_OCL}") |
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0002-comment-out-dump-functions.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0002-comment-out-dump-functions.patch deleted file mode 100644 index 517dc36f..00000000 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0002-comment-out-dump-functions.patch +++ /dev/null | |||
@@ -1,87 +0,0 @@ | |||
1 | From 15a23e549636626cf32b062a5308a29cc53ce360 Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Wed, 21 Aug 2019 17:29:00 +0800 | ||
4 | Subject: [PATCH 2/4] comment out dump functions | ||
5 | |||
6 | Otherwise it leads to errors when linking with lld: | ||
7 | |||
8 | | ld.lld: error: undefined symbol: llvm::Value::dump() const | ||
9 | | >>> referenced by PreRAScheduler.cpp:252 (build/tmp/work/x86_64-linux/intel-graphics-compiler-native/1.0.10-r0/git/IGC/Compiler/CISACodeGen/PreRAScheduler.cpp:252) | ||
10 | | >>> PreRAScheduler.cpp.o:(IGC::PreRAScheduler::dumpDDGContents()) in archive IGC/Release/libCompiler.a | ||
11 | | | ||
12 | | ld.lld: error: undefined symbol: llvm::Value::dump() const | ||
13 | | >>> referenced by PreRAScheduler.cpp:855 (build/tmp/work/x86_64-linux/intel-graphics-compiler-native/1.0.10-r0/git/IGC/Compiler/CISACodeGen/PreRAScheduler.cpp:855) | ||
14 | | >>> PreRAScheduler.cpp.o:(IGC::PreRAScheduler::dumpPriorityQueueContents()) in archive IGC/Release/libCompiler.a | ||
15 | | | ||
16 | | ld.lld: error: undefined symbol: llvm::Value::dump() const | ||
17 | | >>> referenced by PreRAScheduler.cpp:876 (build/tmp/work/x86_64-linux/intel-graphics-compiler-native/1.0.10-r0/git/IGC/Compiler/CISACodeGen/PreRAScheduler.cpp:876) | ||
18 | | >>> PreRAScheduler.cpp.o:(IGC::PreRAScheduler::dumpPriorityQueueContents()) in archive IGC/Release/libCompiler.a | ||
19 | | | ||
20 | | ld.lld: error: undefined symbol: llvm::Value::dump() const | ||
21 | | >>> referenced by PreRAScheduler.cpp:888 (build/tmp/work/x86_64-linux/intel-graphics-compiler-native/1.0.10-r0/git/IGC/Compiler/CISACodeGen/PreRAScheduler.cpp:888) | ||
22 | | >>> PreRAScheduler.cpp.o:(IGC::PreRAScheduler::dumpPriorityQueueContents()) in archive IGC/Release/libCompiler.a | ||
23 | | | ||
24 | | ld.lld: error: undefined symbol: llvm::Value::dump() const | ||
25 | | >>> referenced by PreRAScheduler.cpp:902 (build/tmp/work/x86_64-linux/intel-graphics-compiler-native/1.0.10-r0/git/IGC/Compiler/CISACodeGen/PreRAScheduler.cpp:902) | ||
26 | | >>> PreRAScheduler.cpp.o:(IGC::PreRAScheduler::dumpPriorityQueueContents()) in archive IGC/Release/libCompiler.a | ||
27 | | clang-8: error: linker command failed with exit code 1 (use -v to see invocation) | ||
28 | | ninja: build stopped: subcommand failed. | ||
29 | |||
30 | Upstream-Status: Submitted [https://github.com/intel/intel-graphics-compiler/pull/105] | ||
31 | |||
32 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
33 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
34 | --- | ||
35 | IGC/Compiler/CISACodeGen/PreRAScheduler.cpp | 6 ++++++ | ||
36 | 1 file changed, 6 insertions(+) | ||
37 | |||
38 | diff --git a/IGC/Compiler/CISACodeGen/PreRAScheduler.cpp b/IGC/Compiler/CISACodeGen/PreRAScheduler.cpp | ||
39 | index 62e89c0c..ba01af01 100644 | ||
40 | --- a/IGC/Compiler/CISACodeGen/PreRAScheduler.cpp | ||
41 | +++ b/IGC/Compiler/CISACodeGen/PreRAScheduler.cpp | ||
42 | @@ -178,8 +178,10 @@ namespace IGC { | ||
43 | AU.addRequired<RegisterEstimator>(); | ||
44 | } | ||
45 | |||
46 | +#if !defined(NDEBUG) || defined(LLVM_ENABLE_DUMP) | ||
47 | void dumpDDGContents(); | ||
48 | void dumpPriorityQueueContents(); | ||
49 | +#endif | ||
50 | |||
51 | void clearDDG(); | ||
52 | |||
53 | @@ -228,6 +230,7 @@ IGC_INITIALIZE_PASS_DEPENDENCY(RegisterEstimator) | ||
54 | IGC_INITIALIZE_PASS_DEPENDENCY(DominatorTreeWrapperPass) | ||
55 | IGC_INITIALIZE_PASS_END(PreRAScheduler, PASS_FLAG, PASS_DESC, PASS_CFG_ONLY, PASS_ANALYSIS) | ||
56 | |||
57 | +#if !defined(NDEBUG) || defined(LLVM_ENABLE_DUMP) | ||
58 | void PreRAScheduler::dumpDDGContents() | ||
59 | { | ||
60 | IGC_SET_FLAG_VALUE(PrintToConsole, 1); | ||
61 | @@ -259,6 +262,7 @@ void PreRAScheduler::dumpDDGContents() | ||
62 | |||
63 | IGC_SET_FLAG_VALUE(PrintToConsole, 0); | ||
64 | } | ||
65 | +#endif | ||
66 | |||
67 | void PreRAScheduler::clearDDG() | ||
68 | { | ||
69 | @@ -841,6 +845,7 @@ bool PreRAScheduler::ScheduleReadyNodes( | ||
70 | return Changed; | ||
71 | } | ||
72 | |||
73 | +#if !defined(NDEBUG) || defined(LLVM_ENABLE_DUMP) | ||
74 | void PreRAScheduler::dumpPriorityQueueContents() | ||
75 | { | ||
76 | llvm::PriorityQueue<Node*, std::vector<Node*>, PreRAScheduler::OrderByLatency> longLatencyQueueCopy = longLatencyDelaySortedReadyQueue; | ||
77 | @@ -912,6 +917,7 @@ void PreRAScheduler::dumpPriorityQueueContents() | ||
78 | |||
79 | IGC_SET_FLAG_VALUE(PrintToConsole, 0); | ||
80 | } | ||
81 | +#endif | ||
82 | |||
83 | bool PreRAScheduler::runOnFunction(Function& F) { | ||
84 | CodeGenContext* ctx = getAnalysis<CodeGenContextWrapper>().getCodeGenContext(); | ||
85 | -- | ||
86 | 2.17.1 | ||
87 | |||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.2714.1.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3151.bb index 7070223d..d4827283 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.2714.1.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3151.bb | |||
@@ -7,12 +7,11 @@ LICENSE = "MIT & BSD-3-Clause" | |||
7 | LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \ | 7 | LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \ |
8 | file://IGC/Compiler/LegalizationPass.cpp;beginline=1;endline=25;md5=4abf1738ff96b18e34186eb763e28eeb" | 8 | file://IGC/Compiler/LegalizationPass.cpp;beginline=1;endline=25;md5=4abf1738ff96b18e34186eb763e28eeb" |
9 | 9 | ||
10 | SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;branch=releases/igc-1.0.2714 \ | 10 | SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \ |
11 | file://0001-skip-execution-of-ElfPackager.patch \ | 11 | file://0001-skip-execution-of-ElfPackager.patch \ |
12 | file://0002-comment-out-dump-functions.patch \ | ||
13 | " | 12 | " |
14 | 13 | ||
15 | SRCREV = "710e6273dd1698e8b11763e9ff74c0dd57dddb83" | 14 | SRCREV = "ee341708a3d95738e942b6d3c5cd25b1f4b430f1" |
16 | 15 | ||
17 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
18 | 17 | ||