diff options
author | Naveen Saini <naveen.kumar.saini@intel.com> | 2020-04-16 16:22:38 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2020-04-17 08:06:37 +0800 |
commit | 52dc0273759daaf167bf38656bab5cb2da27028f (patch) | |
tree | 85c795ce568d6b6b4393271be7f9acff310791c6 /dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/link-with-all-libs.patch | |
parent | ee6810244211e6226cde0d2433e79461ae89b750 (diff) | |
download | meta-intel-52dc0273759daaf167bf38656bab5cb2da27028f.tar.gz |
opencl-clang: fix runtime error
Error log:
clang (LLVM option parsing): Unknown command line argument '-pgo-warn-misexpect'.
Try: 'clang (LLVM option parsing) --help'
Force opencl-clang to link with shared clang-cpp for target builds and
explicitly link with spirv library because of a change in behaviour in llvm 10.
Use the patch to link with all static libs only for native cases where meta-clang
default to building static libs only by default.
Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/link-with-all-libs.patch')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/link-with-all-libs.patch | 32 |
1 files changed, 0 insertions, 32 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/link-with-all-libs.patch b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/link-with-all-libs.patch deleted file mode 100644 index bd6c9676..00000000 --- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/link-with-all-libs.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From cc0769fb72561f82976e40c5b7ea8bf07069c87a Mon Sep 17 00:00:00 2001 | ||
2 | From: Anuj Mittal <anuj.mittal@intel.com> | ||
3 | Date: Thu, 19 Mar 2020 16:30:07 +0800 | ||
4 | Subject: [PATCH] link to all libs | ||
5 | |||
6 | LINK_COMPONENTS=all isn't working for static libs for out of tree builds. Use | ||
7 | LLVM_AVAILABLE_LIBS instead. Reported: | ||
8 | |||
9 | https://github.com/intel/opencl-clang/issues/114 | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
14 | --- | ||
15 | CMakeLists.txt | 1 + | ||
16 | 1 file changed, 1 insertion(+) | ||
17 | |||
18 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
19 | index 4590a11..2ff9901 100644 | ||
20 | --- a/CMakeLists.txt | ||
21 | +++ b/CMakeLists.txt | ||
22 | @@ -261,6 +261,7 @@ add_llvm_library(${TARGET_NAME} SHARED | ||
23 | clangLex | ||
24 | clangBasic | ||
25 | ${ADDITIONAL_LIBS} | ||
26 | + ${LLVM_AVAILABLE_LIBS} | ||
27 | ) | ||
28 | |||
29 | # Configure resource file on Windows | ||
30 | -- | ||
31 | 2.25.1 | ||
32 | |||