summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2022-05-19 22:04:22 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-06-13 10:40:13 +0800
commit26d268b690dd1544dec91be897f1241521340b48 (patch)
treed385e0ae8af3ebbb19a3103efa67aa90ea12012b /dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb
parent6702aec8ff8230dac967a11a79d639c3d7778845 (diff)
downloadmeta-intel-26d268b690dd1544dec91be897f1241521340b48.tar.gz
intel-graphics-compiler: upgrade 1.0.10395 -> 1.0.11279
* Remove upstreamed patches and refresh others. * Include the LICENSE.md file and remove the cpp file which just points to MIT license. * Update the license to MIT and Apache-2.0 * Install vcb tool from -native recipe. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> (cherry picked from commit 7cd06a4a7151341fca82a08b5f820fae6504d409) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb72
1 files changed, 0 insertions, 72 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb
deleted file mode 100644
index 0fa9352e..00000000
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb
+++ /dev/null
@@ -1,72 +0,0 @@
1SUMMARY = "The Intel(R) Graphics Compiler for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compiler for OpenCL(TM) is an \
3llvm based compiler for OpenCL(TM) targeting Intel Gen graphics \
4hardware architecture."
5
6LICENSE = "MIT & BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \
8 file://IGC/Compiler/LegalizationPass.cpp;beginline=1;endline=23;md5=4a985f2545dd5a846e205b1e60a51cd9 \
9 file://NOTICES.txt;md5=7f4fbc3eb2c34807465e63b1ec3c9d1a"
10
11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;name=igc;branch=master \
12 git://github.com/intel/vc-intrinsics.git;protocol=https;destsuffix=git/vc-intrinsics;name=vc;branch=master \
13 git://github.com/KhronosGroup/SPIRV-Tools.git;protocol=https;destsuffix=SPIRV-Tools;name=spirv-tools;branch=master \
14 git://github.com/KhronosGroup/SPIRV-Headers.git;protocol=https;destsuffix=SPIRV-Headers;name=spirv-headers;branch=master \
15 file://0001-llvm_deps.cmake-don-t-copy-header-file-when-building.patch \
16 file://0003-Improve-Reproducibility-for-src-package.patch \
17 file://0004-find-external-llvm-tblgen.patch \
18 file://0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch \
19 file://0001-llvm-link-external.patch \
20 file://fix-header.patch \
21 file://4369c970d4e02258b3c53e854faaa34197124a33.patch \
22 "
23
24SRCREV_igc = "775a850f9b0c2d7249503b47ad6bd39a4eb9b3d7"
25SRCREV_vc = "5066d947985dd0c5107765daec5f24f735f3259a"
26SRCREV_spirv-tools = "eeb973f5020a5f0e92ad6da879bc4df9f5985a1c"
27SRCREV_spirv-headers = "ae217c17809fadb232ec94b29304b4afcd417bb4"
28
29SRCREV_FORMAT = "igc_vc_spirv-tools_spirv-headers"
30
31# Used to replace with relative path in reproducibility patch
32export B
33
34S = "${WORKDIR}/git"
35
36inherit cmake pkgconfig
37
38CXXFLAGS:append = " -Wno-error=nonnull"
39
40COMPATIBLE_HOST = '(x86_64).*-linux'
41COMPATIBLE_HOST:libc-musl = "null"
42
43DEPENDS += " flex-native bison-native clang opencl-clang"
44DEPENDS:append:class-target = " clang-cross-x86_64 intel-graphics-compiler-native"
45
46RDEPENDS:${PN} += "opencl-clang"
47
48PACKAGECONFIG ??= "vc"
49PACKAGECONFIG[vc] = "-DIGC_BUILD__VC_ENABLED=ON -DIGC_OPTION__LINK_KHRONOS_SPIRV_TRANSLATOR=ON -DIGC_OPTION__USE_KHRONOS_SPIRV_TRANSLATOR_IN_VC=ON -DIGC_OPTION__SPIRV_TRANSLATOR_MODE=Prebuilds,-DIGC_BUILD__VC_ENABLED=OFF,"
50
51EXTRA_OECMAKE = " \
52 -DIGC_OPTION__LLVM_PREFERRED_VERSION=${LLVMVERSION} \
53 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
54 -DVC_INTRINSICS_SRC="${S}/vc-intrinsics" \
55 -DIGC_OPTION__LLVM_MODE=Prebuilds \
56 "
57
58do_install:append:class-native () {
59 install -d ${D}${bindir}
60 install ${B}/IGC/Release/elf_packager ${D}${bindir}/
61 if ${@bb.utils.contains('PACKAGECONFIG', 'vc', 'true', 'false', d)}; then
62 install ${B}/IGC/Release/CMCLTranslatorTool ${D}${bindir}/
63 fi
64}
65
66BBCLASSEXTEND = "native nativesdk"
67
68UPSTREAM_CHECK_GITTAGREGEX = "^igc-(?P<pver>(?!19\..*)\d+(\.\d+)+)$"
69
70FILES:${PN} += " \
71 ${libdir}/igc/NOTICES.txt \
72 "