summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2021-07-31 17:47:03 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-07-31 17:47:03 +0800
commit0584f638797a816b29b909d4611d5a099df7bbc1 (patch)
tree1ec4bdacf824c304290b5086fd54bba9b84158e2 /dynamic-layers/clang-layer/recipes-opencl/compute-runtime
parent7a5e47b6a594eb29dfe84e47f043a49974bc0402 (diff)
downloadmeta-intel-0584f638797a816b29b909d4611d5a099df7bbc1.tar.gz
Convert to new override syntax
Use the convert-overrides.py to convert to new syntax and manually fix some additional changes. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.04.18912.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.04.18912.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.04.18912.bb
index d0078f3a..73a98732 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.04.18912.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.04.18912.bb
@@ -10,21 +10,21 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae27f47fd6755510247c19e547e4c804 \
10 10
11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \ 11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \
12 " 12 "
13SRC_URI_append_class-target = " file://allow-to-find-cpp-generation-tool.patch" 13SRC_URI:append:class-target = " file://allow-to-find-cpp-generation-tool.patch"
14 14
15SRCREV = "5a05d7643c4d8cc14e281b686c78101a7a01e8e1" 15SRCREV = "5a05d7643c4d8cc14e281b686c78101a7a01e8e1"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19DEPENDS += " intel-graphics-compiler gmmlib" 19DEPENDS += " intel-graphics-compiler gmmlib"
20DEPENDS_append_class-target = " intel-compute-runtime-native libva" 20DEPENDS:append:class-target = " intel-compute-runtime-native libva"
21 21
22RDEPENDS_${PN} += " intel-graphics-compiler gmmlib" 22RDEPENDS:${PN} += " intel-graphics-compiler gmmlib"
23 23
24inherit cmake pkgconfig 24inherit cmake pkgconfig
25 25
26COMPATIBLE_HOST = '(x86_64).*-linux' 26COMPATIBLE_HOST = '(x86_64).*-linux'
27COMPATIBLE_HOST_libc-musl = "null" 27COMPATIBLE_HOST:libc-musl = "null"
28 28
29EXTRA_OECMAKE = " \ 29EXTRA_OECMAKE = " \
30 -DIGC_DIR=${STAGING_INCDIR}/igc \ 30 -DIGC_DIR=${STAGING_INCDIR}/igc \
@@ -32,24 +32,24 @@ EXTRA_OECMAKE = " \
32 -DSKIP_UNIT_TESTS=1 \ 32 -DSKIP_UNIT_TESTS=1 \
33 -DCCACHE_ALLOWED=FALSE \ 33 -DCCACHE_ALLOWED=FALSE \
34 " 34 "
35EXTRA_OECMAKE_append_class-target = " \ 35EXTRA_OECMAKE:append:class-target = " \
36 -Dcloc_cmd_prefix=ocloc \ 36 -Dcloc_cmd_prefix=ocloc \
37 " 37 "
38 38
39PACKAGECONFIG ??= "" 39PACKAGECONFIG ??= ""
40PACKAGECONFIG[levelzero] = "-DBUILD_WITH_L0=ON, -DBUILD_WITH_L0=OFF, level-zero" 40PACKAGECONFIG[levelzero] = "-DBUILD_WITH_L0=ON, -DBUILD_WITH_L0=OFF, level-zero"
41 41
42do_install_append_class-native() { 42do_install:append:class-native() {
43 install -d ${D}${bindir} 43 install -d ${D}${bindir}
44 install ${B}/bin/cpp_generate_tool ${D}${bindir}/ 44 install ${B}/bin/cpp_generate_tool ${D}${bindir}/
45} 45}
46 46
47FILES_${PN} += " \ 47FILES:${PN} += " \
48 ${libdir}/intel-opencl/libigdrcl.so \ 48 ${libdir}/intel-opencl/libigdrcl.so \
49 ${libdir}/libocloc.so \ 49 ${libdir}/libocloc.so \
50 " 50 "
51 51
52FILES_${PN}-dev = "${includedir}" 52FILES:${PN}-dev = "${includedir}"
53 53
54BBCLASSEXTEND = "native nativesdk" 54BBCLASSEXTEND = "native nativesdk"
55 55