summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.32.23937.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2022-08-17 14:27:54 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-08-17 14:27:54 +0800
commit87d4088ecff5c07ddb0b2764bd4c2cee8803685a (patch)
tree55da7c573e901ecbeaa52b5448186c7b66151bb1 /dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.32.23937.bb
parent0a7687b2c1e174b055213db7e535eec03828d3d1 (diff)
downloadmeta-intel-87d4088ecff5c07ddb0b2764bd4c2cee8803685a.tar.gz
intel-compute-runtime: upgrade 22.31.23852 -> 22.32.23937
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.32.23937.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.32.23937.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.32.23937.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.32.23937.bb
new file mode 100644
index 00000000..99391d00
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.32.23937.bb
@@ -0,0 +1,62 @@
1SUMMARY = "The Intel(R) Graphics Compute Runtime for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compute Runtime for OpenCL(TM) \
3is an open source project to converge Intel's development efforts \
4on OpenCL(TM) compute stacks supporting the GEN graphics hardware \
5architecture."
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9280143b568466d8fbe385f838078b93 \
9 file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b"
10
11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=master \
12 "
13
14SRC_URI:append:class-target = "file://allow-to-find-cpp-generation-tool.patch \
15 file://external-ocloc.patch \
16 "
17
18SRCREV = "b38c750cc40d7f5e8bbb2b9b74c6d67120abe0bf"
19
20S = "${WORKDIR}/git"
21
22DEPENDS += " intel-graphics-compiler gmmlib"
23DEPENDS:append:class-target = " intel-compute-runtime-native libva"
24
25RDEPENDS:${PN} += " intel-graphics-compiler gmmlib"
26
27inherit cmake pkgconfig
28
29COMPATIBLE_HOST = '(x86_64).*-linux'
30COMPATIBLE_HOST:libc-musl = "null"
31
32EXTRA_OECMAKE = " \
33 -DIGC_DIR=${STAGING_INCDIR}/igc \
34 -DBUILD_TYPE=Release \
35 -DSKIP_UNIT_TESTS=1 \
36 -DCCACHE_ALLOWED=FALSE \
37 -DNEO_DISABLE_LD_LLD=ON \
38 -DNEO_DISABLE_LD_GOLD=ON \
39 "
40
41EXTRA_OECMAKE:append:class-target = " \
42 -Docloc_cmd_prefix=ocloc \
43 "
44
45PACKAGECONFIG ??= ""
46PACKAGECONFIG[levelzero] = "-DBUILD_WITH_L0=ON, -DBUILD_WITH_L0=OFF, level-zero"
47
48do_install:append:class-native() {
49 install -d ${D}${bindir}
50 install ${B}/bin/cpp_generate_tool ${D}${bindir}/
51}
52
53FILES:${PN} += " \
54 ${libdir}/intel-opencl/libigdrcl.so \
55 ${libdir}/libocloc.so \
56 "
57
58FILES:${PN}-dev = "${includedir}"
59
60BBCLASSEXTEND = "native nativesdk"
61
62UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"