summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.16.0.bb
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-07-02 16:47:17 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-07-03 22:48:10 +0800
commitf808528a90bc6fff3f25c69de2103af827c5d7e6 (patch)
tree88d93a1506caf1c6e26d1ab48c1d0b99329fe224 /dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.16.0.bb
parent73a27c9d8044280681486c871225afd21c2f9554 (diff)
downloadmeta-intel-f808528a90bc6fff3f25c69de2103af827c5d7e6.tar.gz
ispc: add recipe
Intel(R) Implicit SPMD Program Compiler (Intel(R) ISPC) ispc is a compiler for a variant of the C programming language, with extensions for single program, multiple data programming. Under the SPMD model, the programmer writes a program that generally appears to be a regular serial program, though the execution model is actually that a number of program instances execute in parallel on the hardware. https://ispc.github.io/downloads.html https://github.com/ispc/ispc Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.16.0.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.16.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.16.0.bb b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.16.0.bb
new file mode 100644
index 00000000..5355140b
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.16.0.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Intel(R) Implicit SPMD Program Compiler"
2DESCRIPTION = "ispc is a compiler for a variant of the C programming language, \
3with extensions for single program, multiple data programming."
4HOMEPAGE = "https://github.com/ispc/ispc"
5
6LICENSE = "BSD-3-Clause & Apache-2.0-with-LLVM-exception"
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=da5ecffdd210b3cf776b32b41c182e87 \
8 file://third-party-programs.txt;md5=3cd6f8a7c3bd9d2bb898fcb27c75221a"
9
10inherit cmake python3native
11
12S = "${WORKDIR}/git"
13
14SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \
15 file://0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch \
16 file://0002-cmake-don-t-build-for-32-bit-targets.patch \
17 file://8b5d0f26916e776bc3664e6a4dc68eff3a198d7a.patch \
18 "
19SRCREV = "bdd411085d3e398cf7927cb3b94b00af676737ba"
20
21COMPATIBLE_HOST = '(x86_64).*-linux'
22
23DEPENDS += " clang-native bison-native "
24RDEPENDS_${PN} += " clang-libllvm clang"
25
26EXTRA_OECMAKE += " \
27 -DISPC_INCLUDE_TESTS=OFF \
28 -DISPC_INCLUDE_EXAMPLES=OFF \
29 -DISPC_NO_DUMPS=ON \
30 -DARM_ENABLED=OFF \
31 -DISPC_CROSS=ON \
32 -DSYSROOT_DIR=${STAGING_DIR_NATIVE} \
33 "
34
35TOOLCHAIN = "clang"
36BBCLASSEXTEND = "native nativesdk"