summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.5.2.bb
diff options
context:
space:
mode:
authorezhilarasan s <ezhilarasanx.s@intel.com>2022-02-11 20:55:43 +0530
committerAnuj Mittal <anuj.mittal@intel.com>2022-02-12 00:37:48 +0800
commit2c6d52453c56af85eb21ed9bd8e95a34fa382f9b (patch)
tree9d640a4b12649f2e5a17b92fc4509381a684443d /dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.5.2.bb
parent623a96b34ea725c667e91a4b1070681e8c221445 (diff)
downloadmeta-intel-2c6d52453c56af85eb21ed9bd8e95a34fa382f9b.tar.gz
onednn: upgrade 2.4.4 -> 2.5.2
*Fixed performance regression in binary primitive with broadcast (b972174, ff75122). *Fixed issue with SYCL device properties initialization (cabc5ca, 095f13e). *Fixed issue in matmul primitive with zero points (3157354). *Fixed segmentation fault in depthwise convolution primitive for shapes with huge spatial size for processors with Intel AVX-512 support (6834764, 1d2addc). *Fixed issue in forward convolution primitive for processors with Intel AVX2 support (d691137). *Fixed performance regression on GPUs with SYCL runtime (d8364e5). Signed-off-by: ezhilarasan s <ezhilarasanx.s@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.5.2.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.5.2.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.5.2.bb b/dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.5.2.bb
new file mode 100644
index 00000000..fbea19f7
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-core/dnn/onednn_2.5.2.bb
@@ -0,0 +1,54 @@
1HOMEPAGE = "https://www.oneapi.com"
2SUMMARY = "Deep Neural Network Library"
3DESCRIPTION = "This software is a user mode library that accelerates\
4deep-learning applications and frameworks on Intel architecture."
5LICENSE = "Apache-2.0 & BSD-3-Clause & BSL-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=b48e3de3bfd47c27882a0d85b20823f5 \
7 file://tests/gtests/gtest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
8 file://src/cpu/x64/xbyak/COPYRIGHT;md5=3b9bf048d063d54cdb28964db558bcc7 \
9 file://src/common/ittnotify/LICENSE.BSD;md5=e671ff178b24a95a382ba670503c66fb \
10 "
11SECTION = "lib"
12
13inherit pkgconfig cmake ptest
14
15S = "${WORKDIR}/git"
16SRCREV = "ee7eacb012b95a677c3c1dae0d05e730d99f180e"
17SRC_URI = "git://github.com/oneapi-src/oneDNN.git;branch=rls-v2.5;protocol=https \
18 file://run-ptest \
19 "
20
21UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>(\d+(\.\d+)+))$"
22
23CVE_PRODUCT = "intel:math_kernel_library"
24
25COMPATIBLE_HOST = '(x86_64).*-linux'
26COMPATIBLE_HOST:libc-musl = 'null'
27
28EXTRA_OECMAKE += " \
29 -DDNNL_LIBRARY_TYPE=SHARED \
30 -DDNNL_BUILD_EXAMPLES=ON \
31 -DDNNL_BUILD_TESTS=ON \
32 -DDNNL_CPU_RUNTIME=OMP \
33 -DDNNL_ARCH_OPT_FLAGS="" \
34 -DCMAKE_SKIP_RPATH=ON \
35 "
36
37PACKAGECONFIG ??= ""
38PACKAGECONFIG[gpu] = "-DDNNL_GPU_RUNTIME=OCL, , opencl-headers ocl-icd, intel-compute-runtime"
39
40do_install:append () {
41 install -d ${D}${bindir}/mkl-dnn/tests/benchdnn/inputs
42 install -m 0755 ${B}/tests/benchdnn/benchdnn ${D}${bindir}/mkl-dnn/tests/benchdnn
43 cp -r ${B}/tests/benchdnn/inputs/* ${D}${bindir}/mkl-dnn/tests/benchdnn/inputs
44}
45
46do_install_ptest () {
47 install -d ${D}${PTEST_PATH}/tests
48 install -m 0755 ${B}/tests/api-c ${D}${PTEST_PATH}/tests
49 install -m 0755 ${B}/tests/test_c_symbols-c ${D}${PTEST_PATH}/tests
50}
51
52PACKAGES =+ "${PN}-test"
53
54FILES:${PN}-test = "${bindir}/mkl-dnn/*"