summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-12-01 01:49:35 (GMT)
committerTom Zanussi <tom.zanussi@intel.com>2012-12-03 17:33:03 (GMT)
commitb4141a6404fa7d3445d660860b6bf68acec9f114 (patch)
tree01cb9f23103460d351322f2dfb1097e08d793aac /conf
parent6365370517414b0c074f275db13989365e14a366 (diff)
downloadmeta-intel-b4141a6404fa7d3445d660860b6bf68acec9f114.tar.gz
meta-intel.inc: fix xorg packaging issue for emgd BSPs
BSPs using emgd graphics stack need to use older version of xserver. And these older xserver recipes still use modules which need to be specified in the meta-intel.inc. This is needed in addition to Ross's xorg packaging fixes in oecore. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'conf')
-rw-r--r--conf/machine/include/meta-intel.inc9
1 files changed, 9 insertions, 0 deletions
diff --git a/conf/machine/include/meta-intel.inc b/conf/machine/include/meta-intel.inc
index 61b2dd5..1d591a3 100644
--- a/conf/machine/include/meta-intel.inc
+++ b/conf/machine/include/meta-intel.inc
@@ -7,7 +7,16 @@
7# 7#
8# XSERVER subcomponents, used to build the XSERVER variable 8# XSERVER subcomponents, used to build the XSERVER variable
9# 9#
10
11# for Xserver older than 1.13.0
12OLD_XSERVER_IA32_EXT = "xserver-xorg-extension-dri \
13 xserver-xorg-extension-dri2 \
14 xserver-xorg-extension-extmod \
15 xserver-xorg-extension-dbe \
16 "
17
10XSERVER_IA32_EMGD = "emgd-driver-bin \ 18XSERVER_IA32_EMGD = "emgd-driver-bin \
19 ${OLD_XSERVER_IA32_EXT} \
11 " 20 "
12 21
13XSERVER_IA32_MATROX_MGA = "xf86-video-mga \ 22XSERVER_IA32_MATROX_MGA = "xf86-video-mga \