summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2017-06-30 15:31:54 -0700
committerSaul Wold <sgw@linux.intel.com>2017-07-05 08:39:59 -0700
commitd5a6d49a89ba28ca2dc2ffdc4e189468190d4c92 (patch)
tree29ef9a38e8f27d1964d7132d4b85e9da42421190 /common
parente88f7e629dbc77cee044471f685e0fddc0e39d88 (diff)
downloadmeta-intel-d5a6d49a89ba28ca2dc2ffdc4e189468190d4c92.tar.gz
core-image-tiny-initramfs: Fixes WKS_FILE for Intel MACHINES
Since there could be a case on which meta-intel is parsed but no Intel MACHINE is selected which would turn out in an error where no value is assigned to WKS_FILE. We set WKS_FILE directly and specifically for any of the available Intel MACHINES, and otherwise we leave it as it is. Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-core/images/core-image-tiny-initramfs.bbappend9
1 files changed, 5 insertions, 4 deletions
diff --git a/common/recipes-core/images/core-image-tiny-initramfs.bbappend b/common/recipes-core/images/core-image-tiny-initramfs.bbappend
index bb1a4770..6fe2d7c4 100644
--- a/common/recipes-core/images/core-image-tiny-initramfs.bbappend
+++ b/common/recipes-core/images/core-image-tiny-initramfs.bbappend
@@ -1,10 +1,11 @@
1# Set WKS file depending on the MACHINE picked by the user 1# Set WKS file depending on the MACHINE picked by the user applies
2def wks_intel(d): 2# only when using an Intel MACHINE, otherwise leaves it as it is.
3
4python (){
3 if d.getVar('MACHINE', True) == "intel-core2-32": 5 if d.getVar('MACHINE', True) == "intel-core2-32":
4 d.setVar('WKS_FILE', "systemd-bootdisk-tiny32.wks") 6 d.setVar('WKS_FILE', "systemd-bootdisk-tiny32.wks")
5 elif d.getVar('MACHINE', True) == "intel-corei7-64": 7 elif d.getVar('MACHINE', True) == "intel-corei7-64":
6 d.setVar('WKS_FILE', "systemd-bootdisk-tiny64.wks") 8 d.setVar('WKS_FILE', "systemd-bootdisk-tiny64.wks")
7 elif d.getVar('MACHINE', True) == "intel-quark": 9 elif d.getVar('MACHINE', True) == "intel-quark":
8 d.setVar('WKS_FILE', "mktinygalileodisk.wks") 10 d.setVar('WKS_FILE', "mktinygalileodisk.wks")
9 11}
10WKS_FILE_poky-tiny ?= "${@wks_intel(d)}"