summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2017-09-28 11:16:38 -0700
committerSaul Wold <sgw@linux.intel.com>2017-09-28 11:21:25 -0700
commita1518230dcf8d1f59e981e874e38ab293db0e60f (patch)
treefb5de8868e33912aefca57521c381173107de24d /common
parente104b7aa60c63282f7eef24b567cdf6dad07a3b4 (diff)
downloadmeta-intel-a1518230dcf8d1f59e981e874e38ab293db0e60f.tar.gz
linux-firmware: remove bbappend
With the SRCREV bump in OE-core, all the firmware bits we need are already included so we don't need this anymore. Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-kernel/linux-firmware/linux-firmware_%.bbappend23
1 files changed, 0 insertions, 23 deletions
diff --git a/common/recipes-kernel/linux-firmware/linux-firmware_%.bbappend b/common/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
deleted file mode 100644
index f6968af8..00000000
--- a/common/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
+++ /dev/null
@@ -1,23 +0,0 @@
1# meta-intel maintains a recipe that installs iwlwifi's LinuxCore wifi
2# driver releases. For some iwfwifi LinuxCore supported wireless chips, the
3# best/latest firmware blobs are found in the iwlwifi's linux-firmware.git fork.
4#
5# See: https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/core_release
6#
7# This bbappend fetches the -31.ucode (currently, for Intel Wireless 8260
8# only!) that is the best match for the iwlwifi LinuxCore release built.
9#
10# Note: keep these in sync when updating the iwlwifi_git.bb LinuxCore
11# versions.
12
13SRC_URI_append_intel-x86-common = " https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/linux-firmware.git/plain/iwlwifi-8000C-31.ucode?id=${IWLWIFI_SRCREV};name=iwlwifi-8000C-31"
14
15IWLWIFI_SRCREV = "942f14f65363f33c3fd8a06db58c8ccca0559335"
16
17SRC_URI[iwlwifi-8000C-31.md5sum] = "428a84a780bbe864a7af6a6734c4b529"
18SRC_URI[iwlwifi-8000C-31.sha256sum] = "5a337c52f9d7a7cb5cb0a13c93232f4de742ed0debef757d68231bdb55455406"
19
20do_install_append_intel-x86-common() {
21 # Copy the iwlwifi/LinuxCore required ucode for Intel Wireless 8260
22 cp ${WORKDIR}/iwlwifi-8000C-31.ucode\?id\=${IWLWIFI_SRCREV} ${D}/${nonarch_base_libdir}/firmware/iwlwifi-8000C-31.ucode
23}