summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2012-05-18 12:55:44 -0500
committerTom Zanussi <tom.zanussi@intel.com>2012-05-30 14:22:51 -0500
commit6da5358cb1e2d55dd24bbb9d00861402753ec64c (patch)
treeaf5034daadd168e9fe39542dd8282f7fd9ad5bdd /common
parent1cb907e1ba88d3e758f5df899afa5dfbf300a454 (diff)
downloadmeta-intel-6da5358cb1e2d55dd24bbb9d00861402753ec64c.tar.gz
gst-va-intel: add conditional vaapi implementation
Use different versions of vaapi interface implementaion depending on what a machine specifies. The default if no MACHINE_FEATURE is specified is gstreamer-vaapi. Other machines may need a different implementation e.g. a machine using emgd would specify 'gst-va-mixvideo' in its MACHINE_FEATURES in order to have the implementation satisfied by emgd instead of gstreamer-vaapi, which this also implements. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-multimedia/gstreamer/gst-va-intel.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/common/recipes-multimedia/gstreamer/gst-va-intel.bb b/common/recipes-multimedia/gstreamer/gst-va-intel.bb
index 31bde4e3..4f7fe9ff 100644
--- a/common/recipes-multimedia/gstreamer/gst-va-intel.bb
+++ b/common/recipes-multimedia/gstreamer/gst-va-intel.bb
@@ -6,10 +6,14 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
6 6
7PR = "r0" 7PR = "r0"
8 8
9VAAPI_IMPL = "${@base_contains('MACHINE_FEATURES', 'gst-va-mixvideo', 'gst-va-mixvideo-vaapi', \
10 'gst-va-intel-vaapi', d)}"
11
9PACKAGES = "\ 12PACKAGES = "\
10 gst-va-intel \ 13 gst-va-intel \
11 gst-va-intel-general \ 14 gst-va-intel-general \
12 gst-va-intel-video \ 15 gst-va-intel-video \
16 ${VAAPI_IMPL} \
13 " 17 "
14 18
15ALLOW_EMPTY = "1" 19ALLOW_EMPTY = "1"
@@ -17,6 +21,7 @@ ALLOW_EMPTY = "1"
17RDEPENDS_gst-va-intel = "\ 21RDEPENDS_gst-va-intel = "\
18 gst-va-intel-general \ 22 gst-va-intel-general \
19 gst-va-intel-video \ 23 gst-va-intel-video \
24 ${VAAPI_IMPL} \
20 " 25 "
21 26
22RDEPENDS_gst-va-intel-general = "\ 27RDEPENDS_gst-va-intel-general = "\
@@ -26,3 +31,11 @@ RDEPENDS_gst-va-intel-general = "\
26RDEPENDS_gst-va-intel-video = "\ 31RDEPENDS_gst-va-intel-video = "\
27 gst-plugins-good-isomp4 \ 32 gst-plugins-good-isomp4 \
28 " 33 "
34
35RDEPENDS_gst-va-intel-vaapi = "\
36 gstreamer-vaapi \
37 "
38
39RDEPENDS_gst-va-mixvideo-vaapi = "\
40 emgd-driver-bin \
41 "