summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-04-04 11:34:06 -0700
committerSaul Wold <sgw@linux.intel.com>2017-04-04 11:38:07 -0700
commit60c270394755c36d3cf2d1df61b3795521e1caa0 (patch)
tree50f57c0a4295d317d7ec4844f620a68043dd73c3 /common
parentdf5bc8a1f909eab1d1c77f04d7657873afbbc3db (diff)
downloadmeta-intel-60c270394755c36d3cf2d1df61b3795521e1caa0.tar.gz
cryptodev-module: Fix the check
A case was found where the PREFERRED_VERSION_linux-intel was not set even with linix-intel being the PREFERRED_PROVIDER and this code fails. So, just check for linux-intel now, we know until the next LTS version comes out that this kernel will have the API change patch. A more detailed check may need to be added. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend6
1 files changed, 3 insertions, 3 deletions
diff --git a/common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend b/common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend
index cf4863ca..91362290 100644
--- a/common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend
+++ b/common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend
@@ -1,9 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3python() { 3python() {
4 if ((d.getVar("PREFERRED_PROVIDER_virtual/kernel").startswith("linux-intel")) and 4 # When we add more kernels for linux-intel, we may have to add a Version check
5 (d.getVar("PREFERRED_VERSION_linux-intel").startswith("4.9"))): 5 if (d.getVar("PREFERRED_PROVIDER_virtual/kernel") == "linux-intel"):
6 src_uri = d.getVar("SRC_URI") 6 src_uri = d.getVar("SRC_URI")
7 d.setVar("SRC_URI", src_uri + 7 d.setVar("SRC_URI", src_uri +
8 " file://0001-zc-Force-4.10-get_user_pages_remote-API.patch") 8 " file://0001-zc-Force-4.10-get_user_pages_remote-API.patch")
9} 9}