summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-23 14:20:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-23 14:20:22 +0100
commit1fcd3a2a24736f3ed44345525928467098cb3023 (patch)
tree4dd3767e206c32fa44ab5bd68ee97f27f546da65 /common
parentdacbc86ef39e7545ac266ba1d3a7bf6338fd0ad4 (diff)
downloadmeta-intel-1fcd3a2a24736f3ed44345525928467098cb3023.tar.gz
linux-yocto: Drop 4.1 kernel bbappends
The 4.1 kernel was dropped from OE-Core. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend33
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend12
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.1.bbappend43
3 files changed, 0 insertions, 88 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
deleted file mode 100644
index 68e394e9..00000000
--- a/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
+++ /dev/null
@@ -1,33 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3LINUX_VERSION_INTEL_COMMON = "4.1.41"
4SRCREV_META_INTEL_COMMON ?= "9f9c9a66ef3452343586adf150137967e955d71a"
5SRCREV_MACHINE_INTEL_COMMON ?= "73a3cf15f693701c7a1a24c8e6d4dd3b070e29b2"
6
7KBRANCH_INTEL_COMMON = "standard/preempt-rt/intel/base"
8
9KERNEL_FEATURES_INTEL_COMMON ?= ""
10
11LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
12COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
13KMACHINE_core2-32-intel-common = "intel-core2-32"
14KBRANCH_core2-32-intel-common = "${KBRANCH_INTEL_COMMON}"
15SRCREV_meta_core2-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
16SRCREV_machine_core2-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
17KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
18
19LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
20COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
21KMACHINE_corei7-64-intel-common = "intel-corei7-64"
22KBRANCH_corei7-64-intel-common = "${KBRANCH_INTEL_COMMON}"
23SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
24SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
25KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
26
27LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
28COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
29KMACHINE_i586-nlp-32-intel-common = "intel-quark"
30KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}"
31SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
32SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
33KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend
deleted file mode 100644
index fb274e31..00000000
--- a/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend
+++ /dev/null
@@ -1,12 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3KERNEL_FEATURES_INTEL_COMMON ?= ""
4
5LINUX_VERSION_i586-nlp-32-intel-common = "4.1.41"
6SRCREV_meta_i586-nlp-32-intel-common = "9f9c9a66ef3452343586adf150137967e955d71a"
7SRCREV_machine_i586-nlp-32-intel-common = "ff69a6453667e1ecfcfaf002ab116616398eb397"
8
9COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
10KBRANCH_i586-nlp-32-intel-common = "standard/tiny/intel/base"
11KMACHINE_i586-nlp-32-intel-common = "intel-quark"
12KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
diff --git a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
deleted file mode 100644
index d40a46c5..00000000
--- a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
+++ /dev/null
@@ -1,43 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3LINUX_VERSION_INTEL_COMMON = "4.1.42"
4SRCREV_META_INTEL_COMMON = "9f9c9a66ef3452343586adf150137967e955d71a"
5SRCREV_MACHINE_INTEL_COMMON = "05418d19b8f75b2cdcd616641c8749ec2079cd81"
6
7KBRANCH_INTEL_COMMON = "standard/intel/base"
8
9KERNEL_FEATURES_INTEL_COMMON ?= ""
10
11LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
12COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
13KMACHINE_core2-32-intel-common = "intel-core2-32"
14KBRANCH_core2-32-intel-common = "${KBRANCH_INTEL_COMMON}"
15SRCREV_meta_core2-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
16SRCREV_machine_core2-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
17KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
18
19LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
20COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
21KMACHINE_corei7-64-intel-common = "intel-corei7-64"
22KBRANCH_corei7-64-intel-common = "${KBRANCH_INTEL_COMMON}"
23SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
24SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
25KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
26
27# Quark / X1000 BSP Info
28LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
29COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
30KMACHINE_i586-nlp-32-intel-common = "intel-quark"
31KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}"
32SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
33SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
34KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
35
36
37# For Crystalforest and Romley
38KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
39KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
40
41# For FRI2, NUC
42KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
43KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"