summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2017-07-26 16:36:14 -0700
committerSaul Wold <sgw@linux.intel.com>2017-07-31 09:00:58 -0700
commit03e589efedb03515d3bfe4542e257b1acc83445d (patch)
tree614161bb22bb043bccd3ffe7144b57326f073c2a /common
parent867a8df51ed5abed44332e2edea72ad900b1dc4d (diff)
downloadmeta-intel-03e589efedb03515d3bfe4542e257b1acc83445d.tar.gz
iwlwifi_git.bb: run make_scripts earlier
This out-of-tree module requires we create scripts before configuration but module.bbclass runs make scripts sometime before do_compile. In some builds this results in a failure, as it might not be soon enough. Run make scripts again but earlier. Ideally we change module.bbclass instead, but its currently frozen for M2 testing, so we need this temporary local fix. Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-kernel/iwlwifi/iwlwifi_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/common/recipes-kernel/iwlwifi/iwlwifi_git.bb b/common/recipes-kernel/iwlwifi/iwlwifi_git.bb
index a88eabe7..53568e95 100644
--- a/common/recipes-kernel/iwlwifi/iwlwifi_git.bb
+++ b/common/recipes-kernel/iwlwifi/iwlwifi_git.bb
@@ -39,3 +39,5 @@ RDEPENDS_${PN} = "linux-firmware-iwlwifi"
39 39
40KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi" 40KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
41KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi" 41KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"
42
43addtask make_scripts after do_prepare_recipe_sysroot before do_configure