summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorJianxun Zhang <jianxun.zhang@linux.intel.com>2016-08-30 14:03:08 -0700
committerTom Zanussi <tom.zanussi@linux.intel.com>2016-08-31 09:09:01 -0500
commita2221d6dd18095a7e872bb194ec840467db09f52 (patch)
treef1f7208de8c510fa5aecb206e052fc1605e7bad2 /common
parent8b1ca8fcb0359e75ee1ef7da6095a69cfb63b8ba (diff)
downloadmeta-intel-a2221d6dd18095a7e872bb194ec840467db09f52.tar.gz
rmc: Explicitly specify hash style for linker
The QA sanity checker in OE fails when an ELF binary has a symbol table without GNU hash. There is no issue so far because rmc is statically linked with C libraries and the symbol table is stripped out in build. But once we compile rmc with dynamic linking, the symbol table in the dynamic section stays. Thus it fails the QA checker because the default hash style is sysv. To have some peace of mind, we specify "both" for the hash style to the linker. Signed-off-by: Jianxun Zhang <jianxun.zhang@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-bsp/rmc/rmc.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/common/recipes-bsp/rmc/rmc.bb b/common/recipes-bsp/rmc/rmc.bb
index d8e538b2..d77ad31a 100644
--- a/common/recipes-bsp/rmc/rmc.bb
+++ b/common/recipes-bsp/rmc/rmc.bb
@@ -20,6 +20,8 @@ S = "${WORKDIR}/git"
20 20
21DEPENDS_class-target = "gnu-efi" 21DEPENDS_class-target = "gnu-efi"
22 22
23EXTRA_OEMAKE='RMC_CFLAGS="-Wl,--hash-style=both"'
24
23# from gnu-efi, we should align arch-mapping with it. 25# from gnu-efi, we should align arch-mapping with it.
24def rmc_efi_arch(d): 26def rmc_efi_arch(d):
25 import re 27 import re