summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-07-17 16:12:40 +0100
committerDarren Hart <dvhart@linux.intel.com>2015-07-20 09:53:04 -0700
commita114dca8c1daec76ea61848cb405b4b8b1e48666 (patch)
treeb911a5191257b50e3176ab14e7983aa6c6942011 /common
parenteeb5db0dc19b0ebf9e9afa813c5cd79a6ffec01d (diff)
downloadmeta-intel-a114dca8c1daec76ea61848cb405b4b8b1e48666.tar.gz
lttng-modules: remove obsolete bbappend
oe-core now has lttng-modules 2.6.1 so this bbappend isn't required, and is actively harmful when lttng-modules moves past 2.6.1 as it forces the SRVREV back to 2.6.1. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch71
-rw-r--r--common/recipes-kernel/lttng/lttng-modules_2.6.%.bbappend9
2 files changed, 0 insertions, 80 deletions
diff --git a/common/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch b/common/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
deleted file mode 100644
index ccc6c54f..00000000
--- a/common/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
+++ /dev/null
@@ -1,71 +0,0 @@
1Upstream-Status: Inappropriate [embedded specific]
2
3lttng-modules: replace KERNELDIR with KERNEL_SRC
4
5Since lttng-modules uses the default way of module.bbclass to
6build and install lttng-modules, we do this replacement for
7it as-is.
8
9Signed-off-by: Zumeng Chen <zumeng.chen@windriver.com>
10[sgw - rebased for 2.6.1]
11Signed-off-by: Saul wold <sgw@linux.intel.com>
12
13Index: git/Makefile
14===================================================================
15--- git.orig/Makefile
16+++ git/Makefile
17@@ -68,19 +68,19 @@ obj-m += lib/
18 endif # CONFIG_TRACEPOINTS
19
20 else # KERNELRELEASE
21- KERNELDIR ?= /lib/modules/$(shell uname -r)/build
22- PWD := $(shell pwd)
23- CFLAGS = $(EXTCFLAGS)
24-
25+ KERNEL_SRC ?= /lib/modules/$(shell uname -r)/build
26+ PWD := $(shell pwd)
27+ CFLAGS = $(EXTCFLAGS)
28+
29 default:
30- LTTNG_KERNELDIR=$(KERNELDIR) $(MAKE) -C $(KERNELDIR) M=$(PWD) modules
31+ LTTNG_KERNELDIR=$(KERNEL_SRC) $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules
32
33 modules_install:
34- LTTNG_KERNELDIR=$(KERNELDIR) $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
35+ LTTNG_KERNELDIR=$(KERNEL_SRC) $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules_install
36
37 clean:
38- LTTNG_KERNELDIR=$(KERNELDIR) $(MAKE) -C $(KERNELDIR) M=$(PWD) clean
39+ LTTNG_KERNELDIR=$(KERNEL_SRC) $(MAKE) -C $(KERNEL_SRC) M=$(PWD) clean
40
41 %.i: %.c
42- LTTNG_KERNELDIR=$(KERNELDIR) $(MAKE) -C $(KERNELDIR) M=$(PWD) $@
43+ LTTNG_KERNELDIR=$(KERNEL_SRC) $(MAKE) -C $(KERNEL_SRC) M=$(PWD) $@
44 endif # KERNELRELEASE
45Index: git/probes/Makefile
46===================================================================
47--- git.orig/probes/Makefile
48+++ git/probes/Makefile
49@@ -267,18 +267,18 @@ endif
50 endif
51
52 else
53- KERNELDIR ?= /lib/modules/$(shell uname -r)/build
54+ KERNEL_SRC ?= /lib/modules/$(shell uname -r)/build
55 PWD := $(shell pwd)
56 CFLAGS = $(EXTCFLAGS)
57
58 default:
59- $(MAKE) -C $(KERNELDIR) M=$(PWD) modules
60+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules
61
62 modules_install:
63- $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
64+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules_install
65 /sbin/depmod -a
66
67 clean:
68- $(MAKE) -C $(KERNELDIR) M=$(PWD) clean
69+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) clean
70
71 endif
diff --git a/common/recipes-kernel/lttng/lttng-modules_2.6.%.bbappend b/common/recipes-kernel/lttng/lttng-modules_2.6.%.bbappend
deleted file mode 100644
index 6d88e305..00000000
--- a/common/recipes-kernel/lttng/lttng-modules_2.6.%.bbappend
+++ /dev/null
@@ -1,9 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRCREV = "62080b2248fd8ec4111ffc379d0bc5eaf0a5c16d"
4
5#SRC_URI = "git://git.lttng.org/lttng-modules.git;branch=stable-2.6 \
6# file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch \
7# "
8
9