summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorReinette Chatre <reinette.chatre@intel.com>2016-02-09 15:57:54 -0800
committerSaul Wold <sgw@linux.intel.com>2016-02-12 14:20:51 -0800
commit39544083034168d0d75b4dc0d7053ce448c16e31 (patch)
tree3a9d5f9e32cf51000510e112b50208c5b5359936 /common
parent785ab470df480192fe1a973056f5e92e6ae91322 (diff)
downloadmeta-intel-39544083034168d0d75b4dc0d7053ce448c16e31.tar.gz
intel-gpu-tools: modify packaging to support different usages
The intel-gpu-tools recipe describes itself as "Variety of small tools for testing intel graphics.". Current packaging does not support "small" usages. Here we separate out the tests (about 25MB) and benchmarks (about 2MB) into two new packages that can be installed when they are needed. For the usages that only need the tools, the intel-gpu-tools package contains those. Suggested-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Reinette Chatre <reinette.chatre@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-graphics/intel-gpu-tools/intel-gpu-tools_1.13.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/common/recipes-graphics/intel-gpu-tools/intel-gpu-tools_1.13.bb b/common/recipes-graphics/intel-gpu-tools/intel-gpu-tools_1.13.bb
index 71a30f8d..94772cad 100644
--- a/common/recipes-graphics/intel-gpu-tools/intel-gpu-tools_1.13.bb
+++ b/common/recipes-graphics/intel-gpu-tools/intel-gpu-tools_1.13.bb
@@ -9,6 +9,9 @@ inherit autotools gtk-doc
9 9
10DEPENDS += "libdrm libpciaccess cairo udev glib-2.0 libxv libx11 libxext libxrandr" 10DEPENDS += "libdrm libpciaccess cairo udev glib-2.0 libxv libx11 libxext libxrandr"
11RDEPENDS_${PN} += "bash" 11RDEPENDS_${PN} += "bash"
12RDEPENDS_${PN}-tests += "bash"
13
14PACKAGE_BEFORE_PN = "${PN}-benchmarks ${PN}-tests"
12 15
13SRC_URI[md5sum] = "9ef0d6385e2665db7afa6432f1418ed3" 16SRC_URI[md5sum] = "9ef0d6385e2665db7afa6432f1418ed3"
14SRC_URI[sha256sum] = "c6e65884c106eff4af3a6896ae3fede6bf309337962f2e75ab897f116872ae34" 17SRC_URI[sha256sum] = "c6e65884c106eff4af3a6896ae3fede6bf309337962f2e75ab897f116872ae34"
@@ -25,3 +28,10 @@ gputools_sysroot_preprocess() {
25SYSROOT_PREPROCESS_FUNCS += "gputools_sysroot_preprocess" 28SYSROOT_PREPROCESS_FUNCS += "gputools_sysroot_preprocess"
26 29
27FILES_${PN} += "${libdir}/intel_aubdump.so" 30FILES_${PN} += "${libdir}/intel_aubdump.so"
31FILES_${PN}-benchmarks += "${libexecdir}/intel-gpu-tools/benchmarks"
32FILES_${PN}-tests += "\
33 ${libexecdir}/intel-gpu-tools/*\
34 ${datadir}/intel-gpu-tools/1080p-right.png\
35 ${datadir}/intel-gpu-tools/1080p-left.png\
36 ${datadir}/intel-gpu-tools/pass.png\
37 ${datadir}/intel-gpu-tools/test-list.txt"