diff options
author | Syed Mohamad Fauzi, Syed Johan Arif <syed.johan.arif.syed.mohamad.fauzi@intel.com> | 2017-07-28 16:42:51 +0800 |
---|---|---|
committer | Saul Wold <sgw@linux.intel.com> | 2017-07-31 09:00:58 -0700 |
commit | da5f7e708166ad2ecc5dabc88e78f414ca75970a (patch) | |
tree | c0a2c48bf29d2135af86e8f141c5f1922034715f /common | |
parent | d0ba6fc045dffda5aa1e6e015b926615febfbf9f (diff) | |
download | meta-intel-da5f7e708166ad2ecc5dabc88e78f414ca75970a.tar.gz |
dpdk: upgrade to version 17.05
Signed-off-by: Syed Mohamad Fauzi, Syed Johan Arif <syed.johan.arif.syed.mohamad.fauzi@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common')
-rw-r--r-- | common/recipes-extended/dpdk/dpdk.inc | 3 | ||||
-rw-r--r-- | common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-config-variable-to-enable-disable-dpdk_qat.patch | 31 | ||||
-rw-r--r-- | common/recipes-extended/dpdk/dpdk/dpdk-16.04-point-to-the-right-include-and-lib-path.patch | 43 | ||||
-rw-r--r-- | common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch | 6 | ||||
-rw-r--r-- | common/recipes-extended/dpdk/dpdk_17.05.bb (renamed from common/recipes-extended/dpdk/dpdk_17.02.bb) | 5 |
5 files changed, 6 insertions, 82 deletions
diff --git a/common/recipes-extended/dpdk/dpdk.inc b/common/recipes-extended/dpdk/dpdk.inc index bfb30341..642aade3 100644 --- a/common/recipes-extended/dpdk/dpdk.inc +++ b/common/recipes-extended/dpdk/dpdk.inc | |||
@@ -6,7 +6,6 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe" | |||
6 | SRC_URI = "http://fast.dpdk.org/rel/${BP}.tar.gz;name=dpdk \ | 6 | SRC_URI = "http://fast.dpdk.org/rel/${BP}.tar.gz;name=dpdk \ |
7 | file://dpdk-16.04-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \ | 7 | file://dpdk-16.04-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \ |
8 | file://dpdk-16.07-add-sysroot-option-within-app-makefile.patch \ | 8 | file://dpdk-16.07-add-sysroot-option-within-app-makefile.patch \ |
9 | file://dpdk-16.04-point-to-the-right-include-and-lib-path.patch \ | ||
10 | file://dpdk-16.04-Fix-for-misleading-indentation-error.patch \ | 9 | file://dpdk-16.04-Fix-for-misleading-indentation-error.patch \ |
11 | file://dpdk-16.04-dpdk-fix-compilation-with-dynamic-libs.patch \ | 10 | file://dpdk-16.04-dpdk-fix-compilation-with-dynamic-libs.patch \ |
12 | file://dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch \ | 11 | file://dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch \ |
@@ -61,7 +60,7 @@ def get_dpdk_target_mach(bb, d): | |||
61 | "mohonpeak64": "atm", | 60 | "mohonpeak64": "atm", |
62 | "mohonpeak32": "atm", | 61 | "mohonpeak32": "atm", |
63 | "crystalforest": "ivb", | 62 | "crystalforest": "ivb", |
64 | "intel_corei7_64": "hsw", | 63 | "intel_corei7_64": "atm", |
65 | } | 64 | } |
66 | 65 | ||
67 | if target_arch in multiarch_options : | 66 | if target_arch in multiarch_options : |
diff --git a/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-config-variable-to-enable-disable-dpdk_qat.patch b/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-config-variable-to-enable-disable-dpdk_qat.patch deleted file mode 100644 index cd517052..00000000 --- a/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-config-variable-to-enable-disable-dpdk_qat.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From a424a79b1422f1877de3ee7aee6f781aeacc3630 Mon Sep 17 00:00:00 2001 | ||
2 | From: Anuj Mittal <anujx.mittal@intel.com> | ||
3 | Date: Tue, 18 Aug 2015 12:36:02 +0800 | ||
4 | Subject: [PATCH] examples: add config variable to enable/disable dpdk_qat | ||
5 | |||
6 | Upstream-Status: Inappropriate [configuration] | ||
7 | |||
8 | Add CONFIG_EXAMPLE_DPDK_QAT to control compilation of dpdk_qat | ||
9 | example by PACKAGECONFIG | ||
10 | |||
11 | Signed-off-by: Anuj Mittal <anujx.mittal@intel.com> | ||
12 | --- | ||
13 | examples/Makefile | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/examples/Makefile b/examples/Makefile | ||
17 | index b4eddbd..1bc14b0 100644 | ||
18 | --- a/examples/Makefile | ||
19 | +++ b/examples/Makefile | ||
20 | @@ -41,7 +41,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond | ||
21 | DIRS-y += cmdline | ||
22 | DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor | ||
23 | ifneq ($(ICP_ROOT),) | ||
24 | -DIRS-y += dpdk_qat | ||
25 | +DIRS-$(CONFIG_EXAMPLE_DPDK_QAT) += dpdk_qat | ||
26 | endif | ||
27 | DIRS-y += exception_path | ||
28 | DIRS-y += helloworld | ||
29 | -- | ||
30 | 1.7.9.5 | ||
31 | |||
diff --git a/common/recipes-extended/dpdk/dpdk/dpdk-16.04-point-to-the-right-include-and-lib-path.patch b/common/recipes-extended/dpdk/dpdk/dpdk-16.04-point-to-the-right-include-and-lib-path.patch deleted file mode 100644 index 75bb517d..00000000 --- a/common/recipes-extended/dpdk/dpdk/dpdk-16.04-point-to-the-right-include-and-lib-path.patch +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | From 928595c80ae28d19861d7e76ed898a8fb3f2c1dc Mon Sep 17 00:00:00 2001 | ||
2 | From: Anuj Mittal <anujx.mittal@intel.com> | ||
3 | Date: Fri, 24 Jul 2015 23:57:17 +0800 | ||
4 | Subject: [PATCH] dpdk: point to the right include and lib path | ||
5 | |||
6 | Upstream-Status: Inappropriate [Configuration] | ||
7 | |||
8 | Make sure that we point to the right location of qat | ||
9 | lac headers and library. | ||
10 | |||
11 | Signed-off-by: Anuj Mittal <anujx.mittal@intel.com> | ||
12 | --- | ||
13 | examples/dpdk_qat/Makefile | 7 ++----- | ||
14 | 1 file changed, 2 insertions(+), 5 deletions(-) | ||
15 | |||
16 | diff --git a/examples/dpdk_qat/Makefile b/examples/dpdk_qat/Makefile | ||
17 | index f1e06a1..5b906f7 100644 | ||
18 | --- a/examples/dpdk_qat/Makefile | ||
19 | +++ b/examples/dpdk_qat/Makefile | ||
20 | @@ -66,18 +66,15 @@ SRCS-y := main.c crypto.c | ||
21 | |||
22 | CFLAGS += -O3 | ||
23 | CFLAGS += $(WERROR_FLAGS) | ||
24 | -CFLAGS += -I$(ICP_ROOT)/quickassist/include \ | ||
25 | - -I$(ICP_ROOT)/quickassist/include/lac \ | ||
26 | - -I$(ICP_ROOT)/quickassist/lookaside/access_layer/include | ||
27 | +CFLAGS += -I$(ICP_LAC_API_DIR) | ||
28 | |||
29 | # From CRF 1.2 driver, library was renamed to libicp_qa_al.a | ||
30 | ifneq ($(wildcard $(ICP_ROOT)/build/icp_qa_al.a),) | ||
31 | ICP_LIBRARY_PATH = $(ICP_ROOT)/build/icp_qa_al.a | ||
32 | else | ||
33 | -ICP_LIBRARY_PATH = $(ICP_ROOT)/build/libicp_qa_al.a | ||
34 | +ICP_LIBRARY_PATH = $(ICP_LIB_ROOT)/libicp_qa_al.a | ||
35 | endif | ||
36 | |||
37 | -LDLIBS += -L$(ICP_ROOT)/build | ||
38 | LDLIBS += $(ICP_LIBRARY_PATH) \ | ||
39 | -lz \ | ||
40 | -losal \ | ||
41 | -- | ||
42 | 1.7.9.5 | ||
43 | |||
diff --git a/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch b/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch index e17d80d1..fc965fa4 100644 --- a/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch +++ b/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch | |||
@@ -18,9 +18,9 @@ index 18b41b9..c7c2beb 100644 | |||
18 | --- a/examples/Makefile | 18 | --- a/examples/Makefile |
19 | +++ b/examples/Makefile | 19 | +++ b/examples/Makefile |
20 | @@ -43,6 +43,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor | 20 | @@ -43,6 +43,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor |
21 | ifneq ($(ICP_ROOT),) | 21 | DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond |
22 | DIRS-y += dpdk_qat | 22 | DIRS-y += cmdline |
23 | endif | 23 | DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor |
24 | +DEPDIRS-y += examples/ethtool/lib | 24 | +DEPDIRS-y += examples/ethtool/lib |
25 | DIRS-y += ethtool | 25 | DIRS-y += ethtool |
26 | DIRS-y += exception_path | 26 | DIRS-y += exception_path |
diff --git a/common/recipes-extended/dpdk/dpdk_17.02.bb b/common/recipes-extended/dpdk/dpdk_17.05.bb index ed549694..9c23fadd 100644 --- a/common/recipes-extended/dpdk/dpdk_17.02.bb +++ b/common/recipes-extended/dpdk/dpdk_17.05.bb | |||
@@ -1,12 +1,11 @@ | |||
1 | include dpdk.inc | 1 | include dpdk.inc |
2 | 2 | ||
3 | SRC_URI += "\ | 3 | SRC_URI += "\ |
4 | file://dpdk-16.04-add-config-variable-to-enable-disable-dpdk_qat.patch \ | ||
5 | file://dpdk-16.04-dpdk-enable-ip_fragmentation-in-common_base-config.patch \ | 4 | file://dpdk-16.04-dpdk-enable-ip_fragmentation-in-common_base-config.patch \ |
6 | " | 5 | " |
7 | 6 | ||
8 | SRC_URI[dpdk.md5sum] = "9ac25cffecbf550e145c45e53db03a3d" | 7 | SRC_URI[dpdk.md5sum] = "39c4e1110dd1ef9dab33edbae820f939" |
9 | SRC_URI[dpdk.sha256sum] = "b07b546e910095174bdb6152bb0d7ce057cc4b79aaa74771aeee4e8a7219fb38" | 8 | SRC_URI[dpdk.sha256sum] = "763bfb7e1765efcc949e79d645dc9f1ebd16591431ba0db5ce22becd928dcd0a" |
10 | 9 | ||
11 | export EXAMPLES_BUILD_DIR = "${RTE_TARGET}" | 10 | export EXAMPLES_BUILD_DIR = "${RTE_TARGET}" |
12 | export ARCHDIR = "generic" | 11 | export ARCHDIR = "generic" |