diff options
author | Ross Burton <ross.burton@intel.com> | 2017-09-18 15:00:30 +0100 |
---|---|---|
committer | Saul Wold <sgw@linux.intel.com> | 2017-09-18 13:38:39 -0700 |
commit | 9bf043497c48c45c425081989d142c68968a1385 (patch) | |
tree | 52785370563165450843ac8f5e57ca9db1d3b586 /common | |
parent | 8f5a9ade6be554c1860eb1bcf55f7c33f0333372 (diff) | |
download | meta-intel-9bf043497c48c45c425081989d142c68968a1385.tar.gz |
libyami: use git clone instead of unstable tarball
GitHub has confirmed that the /archive/ tarballs that are generated on demand
from git tags are not persistant and can change over time.
This is no longer an academic problem as this has been observed occuring.
libyami doesn't have any official maintainer-generated tarballs, so switch to
fetching over git.
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common')
-rw-r--r-- | common/recipes-multimedia/libyami/libyami-utils_1.2.0.bb | 8 | ||||
-rw-r--r-- | common/recipes-multimedia/libyami/libyami_1.2.0.bb | 6 |
2 files changed, 7 insertions, 7 deletions
diff --git a/common/recipes-multimedia/libyami/libyami-utils_1.2.0.bb b/common/recipes-multimedia/libyami/libyami-utils_1.2.0.bb index 672b8989..62d62d58 100644 --- a/common/recipes-multimedia/libyami/libyami-utils_1.2.0.bb +++ b/common/recipes-multimedia/libyami/libyami-utils_1.2.0.bb | |||
@@ -7,15 +7,15 @@ BUGTRACKER = "https://github.com/01org/libyami-utils/issues/new" | |||
7 | LICENSE = "Apache-2.0" | 7 | LICENSE = "Apache-2.0" |
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" | 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
9 | 9 | ||
10 | SRC_URI = "https://github.com/01org/libyami-utils/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz \ | 10 | SRC_URI = "git://github.com/01org/libyami-utils.git \ |
11 | file://0001-Fix-build-with-clang.patch \ | 11 | file://0001-Fix-build-with-clang.patch \ |
12 | " | 12 | " |
13 | SRC_URI[md5sum] = "b4637f1a384e3de20076bf01ca2515d3" | 13 | SRCREV = "b480c0594a7e761a8ccfe6b19b3f9bd0c3d871a1" |
14 | SRC_URI[sha256sum] = "3dbaedc797bf2d0e03879bfdbea462c3ec2aac89b49c1ed55cbff1be2590d1e8" | 14 | S = "${WORKDIR}/git" |
15 | 15 | ||
16 | DEPENDS = "libva libyami" | 16 | DEPENDS = "libva libyami" |
17 | 17 | ||
18 | EXTRA_OECONF = " --enable-tests-gles --disable-md5" | 18 | EXTRA_OECONF = "--enable-tests-gles --disable-md5" |
19 | 19 | ||
20 | inherit autotools pkgconfig distro_features_check | 20 | inherit autotools pkgconfig distro_features_check |
21 | 21 | ||
diff --git a/common/recipes-multimedia/libyami/libyami_1.2.0.bb b/common/recipes-multimedia/libyami/libyami_1.2.0.bb index e3462dd2..1d1d02fa 100644 --- a/common/recipes-multimedia/libyami/libyami_1.2.0.bb +++ b/common/recipes-multimedia/libyami/libyami_1.2.0.bb | |||
@@ -8,7 +8,7 @@ BUGTRACKER = "https://github.com/01org/libyami/issues/new" | |||
8 | LICENSE = "Apache-2.0" | 8 | LICENSE = "Apache-2.0" |
9 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=3b83ef96387f14655fc854ddc3c6bd57" | 9 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=3b83ef96387f14655fc854ddc3c6bd57" |
10 | 10 | ||
11 | SRC_URI = "https://github.com/01org/libyami/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz \ | 11 | SRC_URI = "git://github.com/01org/libyami.git;branch=apache \ |
12 | file://0001-bitWriter.cpp-Delete-unused-CACHEBYTES.patch \ | 12 | file://0001-bitWriter.cpp-Delete-unused-CACHEBYTES.patch \ |
13 | file://0002-typecast-index-from-size_t-to-int.patch \ | 13 | file://0002-typecast-index-from-size_t-to-int.patch \ |
14 | file://0003-Add-Wno-invalid-offsetof-to-compiler-commandline.patch \ | 14 | file://0003-Add-Wno-invalid-offsetof-to-compiler-commandline.patch \ |
@@ -19,8 +19,8 @@ SRC_URI = "https://github.com/01org/libyami/archive/${PV}.tar.gz;downloadfilenam | |||
19 | file://0008-NalUnit-is-declared-in-different-namespace.patch \ | 19 | file://0008-NalUnit-is-declared-in-different-namespace.patch \ |
20 | file://0009-Fix-clang-warnings.patch \ | 20 | file://0009-Fix-clang-warnings.patch \ |
21 | " | 21 | " |
22 | SRC_URI[md5sum] = "2e2ed3bd900866476eced140799ee48b" | 22 | SRCREV = "c884fc3facbf1a0adf2082a1cf95cb146300a5ca" |
23 | SRC_URI[sha256sum] = "fdc3025f828c065a4434e73f5629e7ab8af593f1abbe097449dd5a13fa7d465f" | 23 | S = "${WORKDIR}/git" |
24 | 24 | ||
25 | PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)}" | 25 | PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)}" |
26 | PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender" | 26 | PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender" |