summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorKishore Bodke <kishore.k.bodke@intel.com>2013-04-09 14:08:06 -0700
committerTom Zanussi <tom.zanussi@intel.com>2013-04-10 14:17:08 -0500
commite3f78500b1eba6fce602bd146affa868357c2d66 (patch)
treeac15da01aaa1e287a8e817c186cada01389cccae /common
parentfd58fb07cf4fcc0553d0608f5688fc03e41ea15c (diff)
downloadmeta-intel-e3f78500b1eba6fce602bd146affa868357c2d66.tar.gz
crystalforest: Fix build issues for openssl-qat-module
openssl-qat-module and zlib-qat-module recipes have the same kernel module name, which causes the build to fail. So remove one of them from building and update the README with the instructions on how to enable. Fixes [YOCTO #4126]. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb11
1 files changed, 1 insertions, 10 deletions
diff --git a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb b/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
index fb863b0a..fdeebbb8 100644
--- a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
+++ b/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
@@ -45,14 +45,6 @@ do_compile() {
45 oe_runmake KERNEL_CC="${KERNEL_CC}" 45 oe_runmake KERNEL_CC="${KERNEL_CC}"
46} 46}
47 47
48KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}"
49MODULE_DIR="${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers"
50
51do_install() {
52 install -m 0755 -d ${MODULE_DIR}
53 install -m 0755 ${S}/qat_mem.ko ${MODULE_DIR}
54}
55
56do_install_append() { 48do_install_append() {
57 install -m 0755 -d ${D}${bindir} \ 49 install -m 0755 -d ${D}${bindir} \
58 ${D}${includedir}/engines/qat_engine/qat_mem 50 ${D}${includedir}/engines/qat_engine/qat_mem
@@ -61,5 +53,4 @@ do_install_append() {
61 install -m 0750 ${S}/*.h ${D}${includedir}/engines/qat_engine/qat_mem/ 53 install -m 0750 ${S}/*.h ${D}${includedir}/engines/qat_engine/qat_mem/
62} 54}
63 55
64FILES_${PN} += "${bindir}/qat_mem_test \ 56FILES_${PN} += "${bindir}/qat_mem_test"
65 ${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers"