summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-11-29 11:21:39 +0000
committerTom Zanussi <tom.zanussi@intel.com>2012-11-29 09:15:27 -0600
commitba2cac6f5b1866a788457d4b9b1ab6fb229b547c (patch)
tree437734cf8d1759e6edee961bfc317ec8e86ef900 /common
parent154156a4db56f7b33fb1765cf6b87e683d027af9 (diff)
downloadmeta-intel-ba2cac6f5b1866a788457d4b9b1ab6fb229b547c.tar.gz
xf86-video-mga: upgrade and fix build
1.4.13 doesn't build against new X servers as XAA has been dropped, so upgrade to 1.6.2 which makes XAA optional. Also configure.ac is using AC_CHECK_FILE which doesn't cross-compile, so remove those. [ YOCTO #3495 ] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-graphics/xorg-driver/xf86-video-mga/checkfile.patch68
-rw-r--r--[-rwxr-xr-x]common/recipes-graphics/xorg-driver/xf86-video-mga_1.6.2.bb (renamed from common/recipes-graphics/xorg-driver/xf86-video-mga_1.4.13.bb)6
2 files changed, 72 insertions, 2 deletions
diff --git a/common/recipes-graphics/xorg-driver/xf86-video-mga/checkfile.patch b/common/recipes-graphics/xorg-driver/xf86-video-mga/checkfile.patch
new file mode 100644
index 00000000..ceae6dfb
--- /dev/null
+++ b/common/recipes-graphics/xorg-driver/xf86-video-mga/checkfile.patch
@@ -0,0 +1,68 @@
1Upstream-Status: Submitted [https://bugs.freedesktop.org/show_bug.cgi?id=57606]
2Signed-off-by: Ross Burton <ross.burton@intel.com>
3
4From c9014a8f3c9b691b5aa7b1f3ec66cf7c84b8211b Mon Sep 17 00:00:00 2001
5From: Ross Burton <ross.burton@intel.com>
6Date: Thu, 29 Nov 2012 11:00:43 +0000
7Subject: [PATCH] build: dont use AC_CHECK_FILE when enabling DRI
8
9Automatically enabling or disabling a feature based on installed files isn't
10deterministic, and AC_CHECK_FILE returns an error when cross-compiling.
11
12Fix this by enabling DRI by default, and removing the explicit file checks as
13pkg-config is good enough.
14
15(#57606)
16
17Signed-off-by: Ross Burton <ross.burton@intel.com>
18---
19 configure.ac | 25 ++-----------------------
20 1 file changed, 2 insertions(+), 23 deletions(-)
21
22diff --git a/configure.ac b/configure.ac
23index fca1a9c..d2aa2ed 100644
24--- a/configure.ac
25+++ b/configure.ac
26@@ -55,9 +55,9 @@ AC_ARG_WITH(xorg-module-dir,
27 [moduledir="$libdir/xorg/modules"])
28
29 AC_ARG_ENABLE(dri, AS_HELP_STRING([--disable-dri],
30- [Disable DRI support [[default=auto]]]),
31+ [Disable DRI support [[default=enabled]]]),
32 [DRI="$enableval"],
33- [DRI=auto])
34+ [DRI=yes])
35 AC_ARG_ENABLE(exa,
36 AS_HELP_STRING([--disable-exa],
37 [Disable EXA support [[default=enabled]]]),
38@@ -76,27 +76,6 @@ sdkdir=`$PKG_CONFIG --variable=sdkdir xorg-server`
39
40 # Checks for libraries.
41
42-if test "x$DRI" != xno; then
43- AC_CHECK_FILE([${sdkdir}/dri.h],
44- [have_dri_h="yes"], [have_dri_h="no"])
45- AC_CHECK_FILE([${sdkdir}/sarea.h],
46- [have_sarea_h="yes"], [have_sarea_h="no"])
47- AC_CHECK_FILE([${sdkdir}/dristruct.h],
48- [have_dristruct_h="yes"], [have_dristruct_h="no"])
49-fi
50-
51-AC_MSG_CHECKING([whether to include DRI support])
52-if test "x$DRI" = xauto; then
53- if test "x$have_dri_h" = xyes && \
54- test "x$have_sarea_h" = xyes && \
55- test "x$have_dristruct_h" = xyes; then
56- DRI="yes"
57- else
58- DRI="no"
59- fi
60-fi
61-AC_MSG_RESULT([$DRI])
62-
63 AM_CONDITIONAL(DRI, test "x$DRI" = xyes)
64 if test "x$DRI" = xyes; then
65 PKG_CHECK_MODULES(DRI, [libdrm >= 2.0 xf86driproto])
66--
671.7.10.4
68
diff --git a/common/recipes-graphics/xorg-driver/xf86-video-mga_1.4.13.bb b/common/recipes-graphics/xorg-driver/xf86-video-mga_1.6.2.bb
index b48e56d8..d20cadf5 100755..100644
--- a/common/recipes-graphics/xorg-driver/xf86-video-mga_1.4.13.bb
+++ b/common/recipes-graphics/xorg-driver/xf86-video-mga_1.6.2.bb
@@ -6,6 +6,8 @@ DESCRIPTION = "mga is an Xorg driver for Matrox video cards"
6 6
7LIC_FILES_CHKSUM = "file://COPYING;md5=bc1395d2cd32dfc5d6c57d2d8f83d3fc" 7LIC_FILES_CHKSUM = "file://COPYING;md5=bc1395d2cd32dfc5d6c57d2d8f83d3fc"
8 8
9SRC_URI += "file://checkfile.patch"
10
9DEPENDS += "virtual/libx11 libxvmc drm xf86driproto glproto \ 11DEPENDS += "virtual/libx11 libxvmc drm xf86driproto glproto \
10 virtual/libgl xineramaproto libpciaccess" 12 virtual/libgl xineramaproto libpciaccess"
11 13
@@ -15,5 +17,5 @@ PR = "r0"
15 17
16COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)' 18COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)'
17 19
18SRC_URI[md5sum] = "f967fb3e655f6f68aa3f495eaadcaac2" 20SRC_URI[md5sum] = "f543877db4e260d8b43c7da3095605ed"
19SRC_URI[sha256sum] = "b657bd5fec4aade6396c683886739b7c8ce57924278bee0e36f13a966eeddff6" 21SRC_URI[sha256sum] = "3f89ce250eea93f0de890954687790e06c0bab9e3e303df393e8759a187eca6c"