summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-11-21 12:36:54 -0800
committerTom Zanussi <tom.zanussi@intel.com>2012-11-22 00:22:17 -0600
commit92a8b18dbd0b7b025f2c857dd2d19a7e4b232e0f (patch)
treeea07227b7f8a1e44c9662fcffc78b8e5af0fb44d /common
parent24a252c47b7c1d1692faa97d14a4330b48f4258c (diff)
downloadmeta-intel-92a8b18dbd0b7b025f2c857dd2d19a7e4b232e0f.tar.gz
mesa-dri_8.0.4.bbappend: Remove tabs from python code
check for xserver to be non-empty before using it fixed errors like ERROR: Failed to parse recipe: /b/kraj/yocto/poky/meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb ERROR: Error executing a python function in <code>: AttributeError: 'NoneType' object has no attribute 'split' Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend8
1 files changed, 4 insertions, 4 deletions
diff --git a/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend b/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend
index 6bfa9686..b92831d3 100644
--- a/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend
+++ b/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend
@@ -6,13 +6,13 @@
6python __anonymous () { 6python __anonymous () {
7 import re 7 import re
8 xserver = d.getVar('XSERVER', True) 8 xserver = d.getVar('XSERVER', True)
9 if 'emgd-driver-bin' in xserver.split(' '): 9 if xserver and 'emgd-driver-bin' in xserver.split(' '):
10 extra_oeconf = d.getVar('EXTRA_OECONF', True).split() 10 extra_oeconf = d.getVar('EXTRA_OECONF', True).split()
11 take_out = ["--enable-egl", "--enable-gles1", "--enable-gles2"] 11 take_out = ["--enable-egl", "--enable-gles1", "--enable-gles2"]
12 put_in = ["--disable-egl", "--disable-gles1", "--disable-gles2"] 12 put_in = ["--disable-egl", "--disable-gles1", "--disable-gles2"]
13 pattern = re.compile("--with-egl-platforms") 13 pattern = re.compile("--with-egl-platforms")
14 new_extra_oeconf = [ ] 14 new_extra_oeconf = [ ]
15 for i in extra_oeconf: 15 for i in extra_oeconf:
16 if ( i not in take_out ) and ( not pattern.match(i)): 16 if ( i not in take_out ) and ( not pattern.match(i)):
17 new_extra_oeconf.append(i) 17 new_extra_oeconf.append(i)
18 for i in put_in: 18 for i in put_in: