summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2013-07-26 10:36:06 -0700
committerDarren Hart <dvhart@linux.intel.com>2013-07-30 12:58:26 -0700
commit8834d8376838487bfc3ff04a16cffb064cb765cf (patch)
tree184748a5020b7f4646e3a926662178c602feb816 /common
parent1759e70a22abfa34652d0ba08bd697dff7a89b3c (diff)
downloadmeta-intel-8834d8376838487bfc3ff04a16cffb064cb765cf.tar.gz
gnu-efi: Update to 3.0u
Update to 3.0u. Remove the now upstreamed cross-compile-support patch and update the parallel-make-archives patch for the 3.0u Makefiles. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-bsp/gnu-efi/gnu-efi/cross-compile-support.patch31
-rw-r--r--common/recipes-bsp/gnu-efi/gnu-efi/parallel-make-archives.patch45
-rw-r--r--common/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb (renamed from common/recipes-bsp/gnu-efi/gnu-efi_3.0m.bb)15
3 files changed, 6 insertions, 85 deletions
diff --git a/common/recipes-bsp/gnu-efi/gnu-efi/cross-compile-support.patch b/common/recipes-bsp/gnu-efi/gnu-efi/cross-compile-support.patch
deleted file mode 100644
index 221f80ed..00000000
--- a/common/recipes-bsp/gnu-efi/gnu-efi/cross-compile-support.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1Add cross compile support
2
3Upstream-Status: Submitted [Maintainer directly]
4
5All the user to specify the build variables in the environment.
6
7Signed-off-by: Darren Hart <dvhart@Linux.intel.com>
8
9Index: gnu-efi-3.0/Make.defaults
10===================================================================
11--- gnu-efi-3.0.orig/Make.defaults
12+++ gnu-efi-3.0/Make.defaults
13@@ -54,12 +55,12 @@ LDFLAGS = -nostdlib
14 INSTALL = install
15 prefix = /usr/bin/
16
17-CC = $(prefix)gcc
18-AS = $(prefix)as
19-LD = $(prefix)ld
20-AR = $(prefix)ar
21-RANLIB = $(prefix)ranlib
22-OBJCOPY = $(prefix)objcopy
23+CC := $(prefix)gcc
24+AS := $(prefix)as
25+LD := $(prefix)ld
26+AR := $(prefix)ar
27+RANLIB := $(prefix)ranlib
28+OBJCOPY := $(prefix)objcopy
29
30 ifeq ($(ARCH),ia64)
31 CFLAGS += -mfixed-range=f32-f127
diff --git a/common/recipes-bsp/gnu-efi/gnu-efi/parallel-make-archives.patch b/common/recipes-bsp/gnu-efi/gnu-efi/parallel-make-archives.patch
deleted file mode 100644
index 092bd903..00000000
--- a/common/recipes-bsp/gnu-efi/gnu-efi/parallel-make-archives.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1Fix parallel make failure for archives
2
3Upstream-Status: Pending
4
5The lib and gnuefi makefiles were using the lib.a() form which compiles
6and ar's as a pair instead of compiling all and then ar'ing which can
7parallelize better. This was resulting in build failures on larger values
8of -j.
9
10Signed-off-by: Saul Wold <sgw@linux.intel.com>
11Signed-off-by: Darren Hart <dvhart@linux.intel.com>
12---
13---
14 gnuefi/Makefile | 3 ++-
15 lib/Makefile | 3 ++-
16 2 files changed, 4 insertions(+), 2 deletions(-)
17
18Index: gnu-efi-3.0/lib/Makefile
19===================================================================
20--- gnu-efi-3.0.orig/lib/Makefile
21+++ gnu-efi-3.0/lib/Makefile
22@@ -66,7 +66,8 @@ all: libsubdirs libefi.a
23 libsubdirs:
24 for sdir in $(SUBDIRS); do mkdir -p $$sdir; done
25
26-libefi.a: libefi.a($(OBJS))
27+libefi.a: $(OBJS)
28+ $(AR) rv $@ $(OBJS)
29
30 clean:
31 rm -f libefi.a *~ $(OBJS) */*.o
32Index: gnu-efi-3.0/gnuefi/Makefile
33===================================================================
34--- gnu-efi-3.0.orig/gnuefi/Makefile
35+++ gnu-efi-3.0/gnuefi/Makefile
36@@ -51,7 +51,8 @@ TARGETS = crt0-efi-$(ARCH).o libgnuefi.a
37
38 all: $(TARGETS)
39
40-libgnuefi.a: libgnuefi.a($(OBJS))
41+libgnuefi.a: $(OBJS)
42+ $(AR) rv $@ $(OBJS)
43
44 clean:
45 rm -f $(TARGETS) *~ *.o $(OBJS)
diff --git a/common/recipes-bsp/gnu-efi/gnu-efi_3.0m.bb b/common/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb
index 16ba5404..505c4887 100644
--- a/common/recipes-bsp/gnu-efi/gnu-efi_3.0m.bb
+++ b/common/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb
@@ -4,17 +4,14 @@ SECTION = "devel"
4LICENSE = "GPLv2+" 4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://debian/copyright;md5=5fb358a180f484b285b0d99acdc29666" 5LIC_FILES_CHKSUM = "file://debian/copyright;md5=5fb358a180f484b285b0d99acdc29666"
6 6
7PR = "r3" 7PR = "r0"
8 8
9SRCREV = "74" 9SRC_URI = "http://downloads.sourceforge.net/gnu-efi/gnu-efi_3.0u.orig.tar.gz \
10
11SRC_URI = "http://downloads.sourceforge.net/gnu-efi/gnu-efi_3.0m.orig.tar.gz \
12 file://cross-compile-support.patch \
13 file://parallel-make.patch \ 10 file://parallel-make.patch \
14 file://parallel-make-archives.patch \ 11 file://parallel-make-archives.patch \
15 " 12 "
16SRC_URI[md5sum] = "d0a21125aee56c0c7291ad260e916cb3" 13SRC_URI[md5sum] = "d15d3c700e79a1e2938544d73edc572d"
17SRC_URI[sha256sum] = "b7fb638f5ec8faa6edebe54beb90957f01ccccf70a2a948d1b58b834c8d7f86d" 14SRC_URI[sha256sum] = "3c0d450d5829204ca05dcb3b2aae772e52c379b7c7e09146759c6315606f934e"
18 15
19COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux" 16COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
20 17
@@ -28,11 +25,11 @@ def gnu_efi_arch(d):
28 return tarch 25 return tarch
29 26
30EXTRA_OEMAKE = "'ARCH=${@gnu_efi_arch(d)}' 'CC=${CC}' 'AS=${AS}' 'LD=${LD}' 'AR=${AR}' \ 27EXTRA_OEMAKE = "'ARCH=${@gnu_efi_arch(d)}' 'CC=${CC}' 'AS=${AS}' 'LD=${LD}' 'AR=${AR}' \
31 'RANLIB=${RANLIB}' 'OBJCOPY=${OBJCOPY}' \ 28 'RANLIB=${RANLIB}' 'OBJCOPY=${OBJCOPY}' 'PREFIX=${prefix}'\
32 " 29 "
33 30
34do_install() { 31do_install() {
35 oe_runmake install INSTALLROOT="${D}${prefix}" 32 oe_runmake install INSTALLROOT="${D}"
36} 33}
37 34
38FILES_${PN} += "${libdir}/*.lds" 35FILES_${PN} += "${libdir}/*.lds"