summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2011-09-14 15:25:09 -0500
committerTom Zanussi <tom.zanussi@intel.com>2011-09-14 22:57:10 -0500
commit49277afd9e5e510f7b1f82fd8cd10732e3bf2633 (patch)
tree69f8096e66f8572206b2ab48a9cea4df9ff6643f /common
parent072b217edf7ebea81a3503915223eccdf26af23d (diff)
downloadmeta-intel-49277afd9e5e510f7b1f82fd8cd10732e3bf2633.tar.gz
meta-intel/common: remove initramfs-live-install .bbappend1.1_M4.rc2+
This has been moved into oe-core, so remove it and init-install.sh from meta-intel. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-core/initrdscripts/initramfs-live-install/init-install.sh188
-rw-r--r--common/recipes-core/initrdscripts/initramfs-live-install_1.0.bbappend2
2 files changed, 0 insertions, 190 deletions
diff --git a/common/recipes-core/initrdscripts/initramfs-live-install/init-install.sh b/common/recipes-core/initrdscripts/initramfs-live-install/init-install.sh
deleted file mode 100644
index 7d801905..00000000
--- a/common/recipes-core/initrdscripts/initramfs-live-install/init-install.sh
+++ /dev/null
@@ -1,188 +0,0 @@
1#!/bin/sh -e
2#
3# Copyright (C) 2008 Intel
4#
5# install.sh [device_name] [rootfs_name] [video_mode] [vga_mode]
6#
7
8# We need 20 Mb for the boot partition
9boot_size=20
10
11# 5% for the swap
12swap_ratio=5
13
14found="no"
15
16echo "Searching for a hard drive..."
17for device in 'hda' 'hdb' 'sda' 'sdb'
18 do
19 if [ -e /sys/block/${device}/removable ]; then
20 if [ "$(cat /sys/block/${device}/removable)" = "0" ]; then
21 found="yes"
22
23 while true; do
24 echo "Found drive at /dev/${device}. Do you want to install poky there ? [y/n]"
25 read answer
26 if [ "$answer" = "y" ] ; then
27 break
28 fi
29
30 if [ "$answer" = "n" ] ; then
31 found=no
32 break
33 fi
34
35 echo "Please answer by y or n"
36 done
37 fi
38 fi
39
40 if [ "$found" = "yes" ]; then
41 break;
42 fi
43
44done
45
46if [ "$found" = "no" ]; then
47 exit 1
48fi
49
50echo "Installing image on /dev/${device}"
51
52#
53# The udev automounter can cause pain here, kill it
54#
55rm -f /etc/udev/scripts/mount*
56
57#
58# Unmount anything the automounter had mounted
59#
60umount /dev/${device} 2> /dev/null || /bin/true
61umount /dev/${device}1 2> /dev/null || /bin/true
62umount /dev/${device}2 2> /dev/null || /bin/true
63umount /dev/${device}3 2> /dev/null || /bin/true
64umount /dev/${device}4 2> /dev/null || /bin/true
65umount /dev/${device}5 2> /dev/null || /bin/true
66umount /dev/${device}6 2> /dev/null || /bin/true
67
68if [ ! -b /dev/sda ] ; then
69 mknod /dev/sda b 8 0
70fi
71
72if [ ! -b /dev/sdb ] ; then
73 mknod /dev/sdb b 8 16
74fi
75
76if [ ! -b /dev/loop0 ] ; then
77 mknod /dev/loop0 b 7 0
78fi
79
80mkdir -p /tmp
81cat /proc/mounts > /etc/mtab
82
83disk_size=$(parted /dev/${device} unit mb print | grep Disk | cut -d" " -f 3 | sed -e "s/MB//")
84
85swap_size=$((disk_size*5/100))
86rootfs_size=$((disk_size-boot_size-swap_size))
87
88rootfs_start=$((boot_size + 1))
89rootfs_end=$((rootfs_start+rootfs_size))
90swap_start=$((rootfs_end+1))
91
92bootfs=/dev/${device}1
93rootfs=/dev/${device}2
94swap=/dev/${device}3
95
96echo "*****************"
97echo "Boot partition size: $boot_size MB (/dev/${device}1)"
98echo "Rootfs partition size: $rootfs_size MB (/dev/${device}2)"
99echo "Swap partition size: $swap_size MB (/dev/${device}3)"
100echo "*****************"
101echo "Deleting partition table on /dev/${device} ..."
102dd if=/dev/zero of=/dev/${device} bs=512 count=2
103
104echo "Creating new partition table on /dev/${device} ..."
105parted /dev/${device} mklabel msdos
106
107echo "Creating boot partition on /dev/${device}1"
108parted /dev/${device} mkpart primary 0 $boot_size
109
110echo "Creating rootfs partition on /dev/${device}2"
111parted /dev/${device} mkpart primary $rootfs_start $rootfs_end
112
113echo "Creating swap partition on /dev/${device}3"
114parted /dev/${device} mkpart primary $swap_start $disk_size
115
116parted /dev/${device} print
117
118echo "Formatting /dev/${device}1 to ext2..."
119mkfs.ext3 $bootfs
120
121echo "Formatting /dev/${device}2 to ext3..."
122mkfs.ext3 $rootfs
123
124echo "Formatting swap partition...(/dev/${device}3)"
125mkswap $swap
126
127mkdir /ssd
128mkdir /rootmnt
129mkdir /bootmnt
130
131mount $rootfs /ssd
132mount -o rw,loop,noatime,nodiratime /media/$1/$2 /rootmnt
133
134echo "Copying rootfs files..."
135cp -a /rootmnt/* /ssd
136
137if [ -d /ssd/etc/ ] ; then
138 echo "$swap swap swap defaults 0 0" >> /ssd/etc/fstab
139
140 # We dont want udev to mount our root device while we're booting...
141 if [ -d /ssd/etc/udev/ ] ; then
142 echo "/dev/${device}" >> /ssd/etc/udev/mount.blacklist
143 fi
144fi
145
146if [ -f /ssd/etc/grub.d/40_custom ] ; then
147 sed -i "s@__ROOTFS__@$rootfs@g" /ssd/etc/grub.d/40_custom
148 sed -i "s/__VIDEO_MODE__/$3/g" /ssd/etc/grub.d/40_custom
149 sed -i "s/__VGA_MODE__/$4/g" /ssd/etc/grub.d/40_custom
150 mount $bootfs /bootmnt
151 cp /ssd/etc/grub.d/40_custom /bootmnt/40_custom
152 umount /bootmnt
153 force="--force"
154fi
155
156umount /ssd
157umount /rootmnt
158
159echo "Preparing boot partition..."
160mount $bootfs /ssd
161grub-install $force --root-directory=/ssd /dev/${device}
162
163echo "(hd0) /dev/${device}" > /ssd/boot/grub/device.map
164
165if [ -f /ssd/40_custom ] ; then
166 mv /ssd/40_custom /ssd/boot/grub/grub.cfg
167 sed -i "/#/d" /ssd/boot/grub/grub.cfg
168 sed -i "/exec tail/d" /ssd/boot/grub/grub.cfg
169 chmod 0444 /ssd/boot/grub/grub.cfg
170else
171 echo "default 0" > /ssd/boot/grub/menu.lst
172 echo "timeout 30" >> /ssd/boot/grub/menu.lst
173 echo "title Poky-Netbook" >> /ssd/boot/grub/menu.lst
174 echo "root (hd0,1)" >> /ssd/boot/grub/menu.lst
175 echo "kernel /boot/vmlinuz root=$rootfs rw $3 $4 quiet" >> /ssd/boot/grub/menu.lst
176fi
177
178cp /media/$1/vmlinuz /ssd/boot/
179
180umount /ssd
181sync
182
183echo "Remove your installation media, and press ENTER"
184
185read enter
186
187echo "Rebooting..."
188reboot -f
diff --git a/common/recipes-core/initrdscripts/initramfs-live-install_1.0.bbappend b/common/recipes-core/initrdscripts/initramfs-live-install_1.0.bbappend
deleted file mode 100644
index d3420e0a..00000000
--- a/common/recipes-core/initrdscripts/initramfs-live-install_1.0.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
1THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
2FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"