summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2011-09-09 15:36:10 -0500
committerTom Zanussi <tom.zanussi@intel.com>2011-09-14 22:55:42 -0500
commit3c335937950c28950409e8bc1b3087c53b5b7561 (patch)
tree8206f47c58423533d96ec4687c2daac48753b8f5 /common
parent354080ceaf7ab9090e4eb5271c22612a79708512 (diff)
downloadmeta-intel-3c335937950c28950409e8bc1b3087c53b5b7561.tar.gz
meta-intel/common: remove grub-1.98
This has been moved into oe-core, so remove it from meta-intel. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common')
-rwxr-xr-xcommon/recipes-bsp/grub/grub-1.98/40_custom9
-rw-r--r--common/recipes-bsp/grub/grub-1.98/gentrigtables-compile-fix.patch52
-rw-r--r--common/recipes-bsp/grub/grub-1.98/grub-install.in.patch13
-rw-r--r--common/recipes-bsp/grub/grub-1.98/uninit-shdr-fix.patch31
-rw-r--r--common/recipes-bsp/grub/grub_1.98.bb46
5 files changed, 0 insertions, 151 deletions
diff --git a/common/recipes-bsp/grub/grub-1.98/40_custom b/common/recipes-bsp/grub/grub-1.98/40_custom
deleted file mode 100755
index 30dad39a..00000000
--- a/common/recipes-bsp/grub/grub-1.98/40_custom
+++ /dev/null
@@ -1,9 +0,0 @@
1#!/bin/sh
2exec tail -n +3 $0
3# This file provides an easy way to add custom menu entries. Simply type the
4# menu entries you want to add after this comment. Be careful not to change
5# the 'exec tail' line above.
6menuentry "Yocto Linux" {
7 set root=(hd0,1)
8 linux /boot/vmlinuz root=__ROOTFS__ rw __VIDEO_MODE__ __VGA_MODE__ quiet
9}
diff --git a/common/recipes-bsp/grub/grub-1.98/gentrigtables-compile-fix.patch b/common/recipes-bsp/grub/grub-1.98/gentrigtables-compile-fix.patch
deleted file mode 100644
index d09ecf52..00000000
--- a/common/recipes-bsp/grub/grub-1.98/gentrigtables-compile-fix.patch
+++ /dev/null
@@ -1,52 +0,0 @@
1Index: grub-1.98/conf/any-emu.mk
2===================================================================
3--- grub-1.98.orig/conf/any-emu.mk 2011-02-24 00:54:20.825116207 -0600
4+++ grub-1.98/conf/any-emu.mk 2011-02-24 00:55:55.465116194 -0600
5@@ -820,7 +820,7 @@
6 ./gentrigtables > $@
7 DISTCLEANFILES += trigtables.c
8 gentrigtables: gentrigtables.c
9- $(CC) -o $@ $^ $(CPPFLAGS) -lm
10+ $(BUILD_CC) -o $@ $^ $(BUILD_CPPFLAGS) -I${top_srcdir}/include -lm
11 DISTCLEANFILES += gentrigtables
12
13 # For grub-mkfont.
14Index: grub-1.98/conf/any-emu.rmk
15===================================================================
16--- grub-1.98.orig/conf/any-emu.rmk 2011-02-24 00:54:24.565116208 -0600
17+++ grub-1.98/conf/any-emu.rmk 2011-02-24 00:56:40.665116186 -0600
18@@ -110,7 +110,7 @@
19 ./gentrigtables > $@
20 DISTCLEANFILES += trigtables.c
21 gentrigtables: gentrigtables.c
22- $(CC) -o $@ $^ $(CPPFLAGS) -lm
23+ $(BUILD_CC) -o $@ $^ $(BUILD_CPPFLAGS) -I${top_srcdir}/include -lm
24 DISTCLEANFILES += gentrigtables
25
26 # For grub-mkfont.
27Index: grub-1.98/conf/common.mk
28===================================================================
29--- grub-1.98.orig/conf/common.mk 2011-02-24 00:54:30.345116207 -0600
30+++ grub-1.98/conf/common.mk 2011-02-24 00:57:08.415116181 -0600
31@@ -11159,7 +11159,7 @@
32 ./gentrigtables > $@
33 DISTCLEANFILES += trigtables.c
34 gentrigtables: gentrigtables.c
35- $(CC) -o $@ $^ $(CPPFLAGS) -lm
36+ $(BUILD_CC) -o $@ $^ $(BUILD_CPPFLAGS) -I${top_srcdir}/include -lm
37 DISTCLEANFILES += gentrigtables
38
39 pkglib_MODULES += setjmp.mod
40Index: grub-1.98/conf/common.rmk
41===================================================================
42--- grub-1.98.orig/conf/common.rmk 2011-02-24 00:54:34.035116205 -0600
43+++ grub-1.98/conf/common.rmk 2011-02-24 00:57:31.045116179 -0600
44@@ -736,7 +736,7 @@
45 ./gentrigtables > $@
46 DISTCLEANFILES += trigtables.c
47 gentrigtables: gentrigtables.c
48- $(CC) -o $@ $^ $(CPPFLAGS) -lm
49+ $(BUILD_CC) -o $@ $^ $(BUILD_CPPFLAGS) -I${top_srcdir}/include -lm
50 DISTCLEANFILES += gentrigtables
51
52 pkglib_MODULES += setjmp.mod
diff --git a/common/recipes-bsp/grub/grub-1.98/grub-install.in.patch b/common/recipes-bsp/grub/grub-1.98/grub-install.in.patch
deleted file mode 100644
index ac964193..00000000
--- a/common/recipes-bsp/grub/grub-1.98/grub-install.in.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1Index: grub-1.98/util/grub-install.in
2===================================================================
3--- grub-1.98.orig/util/grub-install.in 2011-01-25 23:47:05.587521825 -0600
4+++ grub-1.98/util/grub-install.in 2011-01-25 23:47:23.867521822 -0600
5@@ -306,7 +306,7 @@
6
7 if [ "x${devabstraction_module}" = "x" ] ; then
8 if [ x"${install_device}" != x ]; then
9- if echo "${install_device}" | grep -qx "(.*)" ; then
10+ if echo "${install_device}" | grep -q "(.*)" ; then
11 install_drive="${install_device}"
12 else
13 install_drive="`$grub_probe --target=drive --device ${install_device}`"
diff --git a/common/recipes-bsp/grub/grub-1.98/uninit-shdr-fix.patch b/common/recipes-bsp/grub/grub-1.98/uninit-shdr-fix.patch
deleted file mode 100644
index 67af594b..00000000
--- a/common/recipes-bsp/grub/grub-1.98/uninit-shdr-fix.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1Index: grub-1.98/loader/i386/bsdXX.c
2===================================================================
3--- grub-1.98.orig/loader/i386/bsdXX.c 2011-01-25 00:12:14.967535179 -0600
4+++ grub-1.98/loader/i386/bsdXX.c 2011-01-25 00:13:16.387535169 -0600
5@@ -80,7 +80,7 @@
6 {
7 Elf_Ehdr e;
8 Elf_Shdr *s;
9- char *shdr;
10+ char *shdr = NULL;
11 grub_addr_t curload, module;
12 grub_err_t err;
13
14@@ -148,7 +148,7 @@
15 {
16 Elf_Ehdr e;
17 Elf_Shdr *s;
18- char *shdr;
19+ char *shdr = NULL;
20 grub_addr_t curload, module;
21 grub_err_t err;
22
23@@ -223,7 +223,7 @@
24 grub_err_t err;
25 Elf_Ehdr e;
26 Elf_Shdr *s;
27- char *shdr;
28+ char *shdr = NULL;
29 unsigned symoff, stroff, symsize, strsize;
30 grub_addr_t curload;
31 grub_freebsd_addr_t symstart, symend, symentsize, dynamic;
diff --git a/common/recipes-bsp/grub/grub_1.98.bb b/common/recipes-bsp/grub/grub_1.98.bb
deleted file mode 100644
index 1b3040b4..00000000
--- a/common/recipes-bsp/grub/grub_1.98.bb
+++ /dev/null
@@ -1,46 +0,0 @@
1SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader"
2
3DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \
4intended to unify bootloading across x86 operating systems. In \
5addition to loading the Linux kernel, it implements the Multiboot \
6standard, which allows for flexible loading of multiple boot images."
7
8HOMEPAGE = "http://www.gnu.org/software/grub/"
9SECTION = "bootloaders"
10PRIORITY = "optional"
11
12LICENSE = "GPLv3"
13LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
14
15RDEPENDS = "diffutils freetype"
16PR = "r1"
17
18SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz \
19 file://uninit-shdr-fix.patch;apply=yes \
20 file://grub-install.in.patch;apply=yes \
21 file://gentrigtables-compile-fix.patch;apply=yes \
22 file://40_custom"
23
24inherit autotools
25inherit gettext
26
27EXTRA_OECONF = "--with-platform=pc --target=i386 --disable-grub-mkfont"
28
29do_configure() {
30 oe_runconf
31}
32
33python __anonymous () {
34 import re
35 host = bb.data.getVar('HOST_SYS', d, 1)
36 if not re.match('x86.64.*-linux', host):
37 raise bb.parse.SkipPackage("incompatible with host %s" % host)
38}
39
40do_install_append () {
41 install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom
42}
43
44FILES_${PN}-doc = "${datadir}"
45FILES_${PN} = "/usr /etc"
46