summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2011-02-24 01:08:07 -0600
committerSaul Wold <sgw@linux.intel.com>2011-02-24 10:50:18 -0800
commit17992386d3416cb24cfdf5857411ed143de20371 (patch)
treeba3d4ab10c01c9fecf96aa714a46d7dab09d6d06 /common
parentfd301c36a5d1909bf3fd7a602683cb36ae60262a (diff)
downloadmeta-intel-17992386d3416cb24cfdf5857411ed143de20371.tar.gz
meta-intel: fix for x86_32 build failures
Fixes [BUG #711]. gentrigtables was being build as a 64-bit binary which wouldn't run on the build machine. grub-mkfont was also causing compile failures, add dependency on libfreetype for that. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-bsp/grub/grub-1.98/gentrigtables-compile-fix.patch52
-rw-r--r--common/recipes-bsp/grub/grub_1.98.bb5
2 files changed, 55 insertions, 2 deletions
diff --git a/common/recipes-bsp/grub/grub-1.98/gentrigtables-compile-fix.patch b/common/recipes-bsp/grub/grub-1.98/gentrigtables-compile-fix.patch
new file mode 100644
index 00000000..d09ecf52
--- /dev/null
+++ b/common/recipes-bsp/grub/grub-1.98/gentrigtables-compile-fix.patch
@@ -0,0 +1,52 @@
1Index: grub-1.98/conf/any-emu.mk
2===================================================================
3--- grub-1.98.orig/conf/any-emu.mk 2011-02-24 00:54:20.825116207 -0600
4+++ grub-1.98/conf/any-emu.mk 2011-02-24 00:55:55.465116194 -0600
5@@ -820,7 +820,7 @@
6 ./gentrigtables > $@
7 DISTCLEANFILES += trigtables.c
8 gentrigtables: gentrigtables.c
9- $(CC) -o $@ $^ $(CPPFLAGS) -lm
10+ $(BUILD_CC) -o $@ $^ $(BUILD_CPPFLAGS) -I${top_srcdir}/include -lm
11 DISTCLEANFILES += gentrigtables
12
13 # For grub-mkfont.
14Index: grub-1.98/conf/any-emu.rmk
15===================================================================
16--- grub-1.98.orig/conf/any-emu.rmk 2011-02-24 00:54:24.565116208 -0600
17+++ grub-1.98/conf/any-emu.rmk 2011-02-24 00:56:40.665116186 -0600
18@@ -110,7 +110,7 @@
19 ./gentrigtables > $@
20 DISTCLEANFILES += trigtables.c
21 gentrigtables: gentrigtables.c
22- $(CC) -o $@ $^ $(CPPFLAGS) -lm
23+ $(BUILD_CC) -o $@ $^ $(BUILD_CPPFLAGS) -I${top_srcdir}/include -lm
24 DISTCLEANFILES += gentrigtables
25
26 # For grub-mkfont.
27Index: grub-1.98/conf/common.mk
28===================================================================
29--- grub-1.98.orig/conf/common.mk 2011-02-24 00:54:30.345116207 -0600
30+++ grub-1.98/conf/common.mk 2011-02-24 00:57:08.415116181 -0600
31@@ -11159,7 +11159,7 @@
32 ./gentrigtables > $@
33 DISTCLEANFILES += trigtables.c
34 gentrigtables: gentrigtables.c
35- $(CC) -o $@ $^ $(CPPFLAGS) -lm
36+ $(BUILD_CC) -o $@ $^ $(BUILD_CPPFLAGS) -I${top_srcdir}/include -lm
37 DISTCLEANFILES += gentrigtables
38
39 pkglib_MODULES += setjmp.mod
40Index: grub-1.98/conf/common.rmk
41===================================================================
42--- grub-1.98.orig/conf/common.rmk 2011-02-24 00:54:34.035116205 -0600
43+++ grub-1.98/conf/common.rmk 2011-02-24 00:57:31.045116179 -0600
44@@ -736,7 +736,7 @@
45 ./gentrigtables > $@
46 DISTCLEANFILES += trigtables.c
47 gentrigtables: gentrigtables.c
48- $(CC) -o $@ $^ $(CPPFLAGS) -lm
49+ $(BUILD_CC) -o $@ $^ $(BUILD_CPPFLAGS) -I${top_srcdir}/include -lm
50 DISTCLEANFILES += gentrigtables
51
52 pkglib_MODULES += setjmp.mod
diff --git a/common/recipes-bsp/grub/grub_1.98.bb b/common/recipes-bsp/grub/grub_1.98.bb
index b9d04fc5..0cd3a403 100644
--- a/common/recipes-bsp/grub/grub_1.98.bb
+++ b/common/recipes-bsp/grub/grub_1.98.bb
@@ -12,12 +12,13 @@ PRIORITY = "optional"
12LICENSE = "GPLv2+" 12LICENSE = "GPLv2+"
13LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 13LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
14 14
15RDEPENDS = "diffutils" 15RDEPENDS = "diffutils freetype"
16PR = "r0" 16PR = "r1"
17 17
18SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz \ 18SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz \
19 file://uninit-shdr-fix.patch;apply=yes \ 19 file://uninit-shdr-fix.patch;apply=yes \
20 file://grub-install.in.patch;apply=yes \ 20 file://grub-install.in.patch;apply=yes \
21 file://gentrigtables-compile-fix.patch;apply=yes \
21 file://40_custom" 22 file://40_custom"
22 23
23inherit autotools 24inherit autotools