summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2011-12-28 23:15:33 -0600
committerTom Zanussi <tom.zanussi@intel.com>2012-01-30 14:58:53 -0600
commite3c05341f29b675fae7c8481a472ac5d280bfd95 (patch)
treee242d05bd57fa9875c7d0fbd16b719697286bf12 /common
parentac4e45ae6f5cba7916deb20c19c1c41c54116246 (diff)
downloadmeta-intel-e3c05341f29b675fae7c8481a472ac5d280bfd95.tar.gz
meta-intel: new recipe for emgd 1.10 driver
This adds a new recipe for the emgd 1.10 driver. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-graphics/xorg-xserver/emgd-driver-bin_1.10.bb89
1 files changed, 89 insertions, 0 deletions
diff --git a/common/recipes-graphics/xorg-xserver/emgd-driver-bin_1.10.bb b/common/recipes-graphics/xorg-xserver/emgd-driver-bin_1.10.bb
new file mode 100644
index 00000000..28fd0c16
--- /dev/null
+++ b/common/recipes-graphics/xorg-xserver/emgd-driver-bin_1.10.bb
@@ -0,0 +1,89 @@
1SUMMARY = "EMGD 1.10 xserver binaries"
2DESCRIPTION = "EMGD 1.10 includes some userspace binaries that use non-free \
3licensing, which are now available via a non-click-through downloadable \
4tarball, and is what this recipe now uses. Since it is a non-free license, \
5this recipe is marked as 'License_emgd-driver-bin_1.10' and you need to add \
6to LICENSE_FLAGS_WHITELIST += \"License_emgd-driver-bin_1.10\" to your \
7local.conf in order to enable it in a build."
8LICENSE = "Intel-binary-only"
9LICENSE_FLAGS = "license_${PN}_${PV}"
10PR = "r0"
11
12EMGD_LIC_DIR = "IEMGD_HEAD_Linux/License"
13EMGD_RPM_DIR = "IEMGD_HEAD_Linux/MeeGo1.2"
14EMGD_VIDEO_PLUGIN_DIR = "../common/video_plugin"
15
16LIC_FILES_CHKSUM = "file://${WORKDIR}/${EMGD_LIC_DIR}/License.txt;md5=b54f01caaf8483b3cb60c0c40f2bf22d"
17
18DEPENDS = "rpm-native xz-native"
19
20SRC_URI = "https://edc.intel.com/App_Shared/Downloads/LIN_EMGD_1_10_RC_2209.tgz"
21
22SRC_URI[md5sum] = "e4a38d9efa0b086ae21b68145c4db4e9"
23SRC_URI[sha256sum] = "acea5f0f93a31553553428623c007d7ed0c604cf715fd87dfe075751da4be548"
24
25FILES_${PN} += "${libdir}/dri ${libdir}/gstreamer-0.10 ${libdir}/xorg/modules/drivers"
26FILES_${PN}-dev += "${libdir}/dri ${libdir}/xorg/modules/drivers"
27FILES_${PN}-dbg += "${libdir}/xorg/modules/drivers/.debug ${libdir}/dri/.debug"
28
29S = "${WORKDIR}/${EMGD_RPM_DIR}"
30
31do_install () {
32 # A gstreamer VA buffer library
33 rpm2cpio ${S}/${EMGD_VIDEO_PLUGIN_DIR}/gst-vabuffer*.rpm | cpio -id
34
35 # MIX Common contains common classes, datatype, header files used by other MIX components
36 rpm2cpio ${S}/${EMGD_VIDEO_PLUGIN_DIR}/mixcommon*.rpm | cpio -id
37
38 # MIX Video Bitstream Parser is an user library interface for various video format bitstream parsing
39 rpm2cpio ${S}/${EMGD_VIDEO_PLUGIN_DIR}/mixvbp*.rpm | cpio -id
40
41 # MIX Video is an user library interface for various video codecs available on the platform.
42 rpm2cpio ${S}/${EMGD_VIDEO_PLUGIN_DIR}/mixvideo*.rpm | cpio -id
43
44 install -d -m 0755 ${D}${libdir}/gstreamer-0.10
45 install -m 0755 ${S}/usr/lib/* ${D}${libdir}/
46
47 # A gstreamer plugin that uses MIX Video for hardware accelerated video decoding and rendering.
48 rpm2cpio ${S}/${EMGD_VIDEO_PLUGIN_DIR}/gst-plugins-mixvideo*.rpm | cpio -id
49
50 # A collection of gstreamer plugins that uses VA libraries for hardware accelerated video rendering and text overlay.
51 rpm2cpio ${S}/${EMGD_VIDEO_PLUGIN_DIR}/gst-plugins-va*.rpm | cpio -id
52
53 install -m 0755 ${S}/usr/lib/gstreamer-0.10/* ${D}${libdir}/gstreamer-0.10/
54
55 # EMGD runtime graphics libraries
56 rpm2cpio ${S}/emgd-bin*.rpm | xz -d | cpio -id
57
58 install -d -m 0755 ${D}${libdir}/dri
59 install -d -m 0755 ${D}${libdir}/xorg/modules/drivers
60 install -d -m 0755 ${D}${sysconfdir}
61 install -d -m 0755 ${D}${mandir}/man4
62 install -m 0755 ${S}/usr/lib/*.so.* ${D}${libdir}/
63 install -m 0755 ${S}/usr/lib/dri/* ${D}${libdir}/dri/
64 install -m 0755 ${S}/usr/lib/xorg/modules/drivers/* ${D}${libdir}/xorg/modules/drivers/
65 install -m 0755 ${S}/etc/* ${D}${sysconfdir}/
66 install -m 0755 ${S}/usr/share/man/man4/* ${D}${mandir}/man4/
67
68 # Khronos development headers needed for EGL, OpenGL-ES, and OpenVG development
69 rpm2cpio ${S}/emgd-devel*.rpm | xz -d | cpio -id
70
71 install -d -m 0755 ${D}${includedir}/EGL
72 install -m 0755 ${S}/usr/include/EGL/*.h ${D}${includedir}/EGL/
73 install -d -m 0755 ${D}${includedir}/GLES
74 install -m 0755 ${S}/usr/include/GLES/*.h ${D}${includedir}/GLES/
75 install -d -m 0755 ${D}${includedir}/GLES2
76 install -m 0755 ${S}/usr/include/GLES2/*.h ${D}${includedir}/GLES2/
77 install -d -m 0755 ${D}${includedir}/KHR
78 install -m 0755 ${S}/usr/include/KHR/*.h ${D}${includedir}/KHR/
79 install -d -m 0755 ${D}${includedir}/VG
80 install -m 0755 ${S}/usr/include/VG/*.h ${D}${includedir}/VG/
81
82 ln -sf libEGL.so.1 ${D}${libdir}/libEGL.so
83 ln -sf libGLES_CM.so.1 ${D}${libdir}/libGLES_CM.so
84 ln -sf libGLESv2.so.2 ${D}${libdir}/libGLESv2.so
85 ln -sf libOpenVG.so.1 ${D}${libdir}/libOpenVG.so
86 ln -sf libOpenVGU.so.1 ${D}${libdir}/libOpenVGU.so
87}
88
89LEAD_SONAME = "libEGL.so"