summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2012-05-29 23:02:56 -0500
committerTom Zanussi <tom.zanussi@intel.com>2012-05-30 14:22:52 -0500
commitda5dc7186d3caf42ae206fce538d73d5fafb2741 (patch)
treeadde76667ddcf120e1cbf433293b62a24d491e65 /common
parentceab55d2d68a15e76146f1a85d1dc0b108bb97c5 (diff)
downloadmeta-intel-da5dc7186d3caf42ae206fce538d73d5fafb2741.tar.gz
gstreamer-vaapi: fix glib includes
Fix "Only <glib.h> can be included directly" compilation errors seen when building with 1.3/master. Patch pulled from a post-0.2.9 gstreamer-vaapi version (which however doesn't work with the current stack so a straight upgrade won't work as a fix at this point). Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi/glib-includes.patch49
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb4
2 files changed, 52 insertions, 1 deletions
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi/glib-includes.patch b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/glib-includes.patch
new file mode 100644
index 00000000..381e507e
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/glib-includes.patch
@@ -0,0 +1,49 @@
1commit a698766a8b155b9c282ee1d53c39a833c826616d
2Author: Gwenole Beauchesne <gwenole.beauchesne@intel.com>
3Date: Tue Feb 7 10:01:01 2012 +0100
4
5 glib: fix includes.
6
7Upstream-Status: Backport
8
9Signed-off-by: Tom Zanussi <tom.zanussi (a] intel.com>
10
11Index: git/gst-libs/gst/vaapi/gstvaapiutils.h
12===================================================================
13--- git.orig/gst-libs/gst/vaapi/gstvaapiutils.h 2012-05-29 22:30:37.007259101 -0500
14+++ git/gst-libs/gst/vaapi/gstvaapiutils.h 2012-05-29 22:32:03.896466158 -0500
15@@ -23,7 +23,7 @@
16 #define GST_VAAPI_UTILS_H
17
18 #include "config.h"
19-#include <glib/gtypes.h>
20+#include <glib.h>
21
22 #ifdef GST_VAAPI_USE_OLD_VAAPI_0_29
23 # include <va.h>
24Index: git/gst-libs/gst/vaapi/gstvaapiutils_glx.h
25===================================================================
26--- git.orig/gst-libs/gst/vaapi/gstvaapiutils_glx.h 2012-05-29 22:30:47.497252785 -0500
27+++ git/gst-libs/gst/vaapi/gstvaapiutils_glx.h 2012-05-29 22:32:03.907085421 -0500
28@@ -27,7 +27,7 @@
29 #include <GL/glext.h>
30 #include <GL/glx.h>
31 #include <GL/glxext.h>
32-#include <glib/gtypes.h>
33+#include <glib.h>
34
35 #if GLX_GLXEXT_VERSION < 18
36 typedef void (*PFNGLXBINDTEXIMAGEEXTPROC)(Display *, GLXDrawable, int, const int *);
37Index: git/gst-libs/gst/vaapi/gstvaapiutils_x11.h
38===================================================================
39--- git.orig/gst-libs/gst/vaapi/gstvaapiutils_x11.h 2012-05-29 22:30:56.827305274 -0500
40+++ git/gst-libs/gst/vaapi/gstvaapiutils_x11.h 2012-05-29 22:32:03.916668015 -0500
41@@ -24,7 +24,7 @@
42
43 #include "config.h"
44 #include <X11/Xlib.h>
45-#include <glib/gtypes.h>
46+#include <glib.h>
47
48 void x11_trap_errors(void)
49 attribute_hidden;
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb b/common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb
index 8ffbb516..fe601cca 100644
--- a/common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb
+++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb
@@ -13,7 +13,9 @@ SRCREV = "c98c14bd32855467a5a0ff21b6c703e9e3461467"
13PV = "0.2.9+git${SRCPV}" 13PV = "0.2.9+git${SRCPV}"
14PR = "r0" 14PR = "r0"
15 15
16SRC_URI = "git://gitorious.org/vaapi/gstreamer-vaapi.git" 16SRC_URI = "git://gitorious.org/vaapi/gstreamer-vaapi.git \
17 file://glib-includes.patch"
18
17SRC_URI[md5sum] = "729d75f21df79114a8c81d896489e5ad" 19SRC_URI[md5sum] = "729d75f21df79114a8c81d896489e5ad"
18SRC_URI[sha256sum] = "f1770c4537f1615701dbc845eee5732fbb1036b3acafbc7488e551fab334a31d" 20SRC_URI[sha256sum] = "f1770c4537f1615701dbc845eee5732fbb1036b3acafbc7488e551fab334a31d"
19 21