diff options
author | Ross Burton <ross.burton@intel.com> | 2013-11-13 15:07:03 +0000 |
---|---|---|
committer | Tom Zanussi <tom.zanussi@intel.com> | 2013-11-14 15:56:15 -0600 |
commit | a9f02ffa711079ba835af431802e0a3b7b006904 (patch) | |
tree | 2cfc76bd656874d17affa92f3163d3d3108ce458 /common | |
parent | b74b419f08a040b5170addda5d17026e8c50290f (diff) | |
download | meta-intel-a9f02ffa711079ba835af431802e0a3b7b006904.tar.gz |
mesa: remove, mesa-gl is used with EMGD now
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common')
-rw-r--r-- | common/recipes-graphics/mesa/mesa_9.2.2.bbappend | 24 |
1 files changed, 0 insertions, 24 deletions
diff --git a/common/recipes-graphics/mesa/mesa_9.2.2.bbappend b/common/recipes-graphics/mesa/mesa_9.2.2.bbappend deleted file mode 100644 index b92831d3..00000000 --- a/common/recipes-graphics/mesa/mesa_9.2.2.bbappend +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | |||
2 | # The emgd binary driver also provides egl, gles1, gles2 library & headers. | ||
3 | # To avoid conflict disable egl, gles1, gles2 from meta-dri if the BSP image | ||
4 | # is bundling the emgd driver. | ||
5 | |||
6 | python __anonymous () { | ||
7 | import re | ||
8 | xserver = d.getVar('XSERVER', True) | ||
9 | if xserver and 'emgd-driver-bin' in xserver.split(' '): | ||
10 | extra_oeconf = d.getVar('EXTRA_OECONF', True).split() | ||
11 | take_out = ["--enable-egl", "--enable-gles1", "--enable-gles2"] | ||
12 | put_in = ["--disable-egl", "--disable-gles1", "--disable-gles2"] | ||
13 | pattern = re.compile("--with-egl-platforms") | ||
14 | new_extra_oeconf = [ ] | ||
15 | for i in extra_oeconf: | ||
16 | if ( i not in take_out ) and ( not pattern.match(i)): | ||
17 | new_extra_oeconf.append(i) | ||
18 | for i in put_in: | ||
19 | new_extra_oeconf.append(i) | ||
20 | |||
21 | d.setVar('EXTRA_OECONF', ' '.join(new_extra_oeconf)) | ||
22 | depends = d.getVar('DEPENDS', True) | ||
23 | d.setVar('DEPENDS', depends + " emgd-driver-bin") | ||
24 | } | ||