summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2012-05-17 22:20:30 -0500
committerTom Zanussi <tom.zanussi@intel.com>2012-05-30 14:22:51 -0500
commit72779500c9a15c2adc2646c8b7a11d1f013ffc3e (patch)
tree50fdb19cd20cd6177ddaa90e77149757ffe586bc /common
parent37dee2e3ea78746be32057074ead9f9de5124670 (diff)
downloadmeta-intel-72779500c9a15c2adc2646c8b7a11d1f013ffc3e.tar.gz
meta-intel: add gstreamer-vaapi_git recipe
Based on the gstreamer-vaapi_0.2.5.bb recipe from the Yocto Project meta-demo layer (git://git.yoctoproject.org/meta-demo): commit a33dd433b629f08bc6517ef2ad3bdd36814ebe85 Author: Joshua Lock <josh@linux.intel.com> Date: Tue Mar 22 12:11:42 2011 +0000 gstreamer-vaapi: new recipe currently untested but will likely be useful in future so commiting it so that it doesn't get lost Signed-off-by: Joshua Lock <josh@linux.intel.com> Additional changes made by Tom Zanussi <tom.zanussi@intel.com> in order to work with the other multimedia recipes in meta-intel/common: - summary and description - correct license - changed into a _git recipe in order to pick up post-0.2.5 versions - additional inherits - tested Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb b/common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb
new file mode 100644
index 00000000..8ffbb516
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb
@@ -0,0 +1,26 @@
1SUMMARY = "VA-API support to GStreamer"
2DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
3based plugins for GStreamer and helper libraries: `vaapidecode', \
4`vaapiconvert', and `vaapisink'."
5
6LICENSE = "LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
8
9DEPENDS = "gstreamer libva ffmpeg"
10
11# 0.2.9 tag
12SRCREV = "c98c14bd32855467a5a0ff21b6c703e9e3461467"
13PV = "0.2.9+git${SRCPV}"
14PR = "r0"
15
16SRC_URI = "git://gitorious.org/vaapi/gstreamer-vaapi.git"
17SRC_URI[md5sum] = "729d75f21df79114a8c81d896489e5ad"
18SRC_URI[sha256sum] = "f1770c4537f1615701dbc845eee5732fbb1036b3acafbc7488e551fab334a31d"
19
20S = "${WORKDIR}/git"
21
22inherit autotools pkgconfig gtk-doc
23
24FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
25FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
26FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"