diff options
author | Nitin A Kamble <nitin.a.kamble@intel.com> | 2014-04-04 11:16:43 -0700 |
---|---|---|
committer | Tom Zanussi <tom.zanussi@intel.com> | 2014-04-04 14:45:19 -0500 |
commit | 3b45a0b5b22a2d6c72a819a8cb8717bbf45e6aab (patch) | |
tree | a68aab1f0c8d202f86f174b9082df573575e819d /common | |
parent | c8992ab5445dadaf4311016440d412c46531d5fb (diff) | |
download | meta-intel-3b45a0b5b22a2d6c72a819a8cb8717bbf45e6aab.tar.gz |
common kernels: fix typos in overrides
In the intel common kernel recipes, instead of corei7-64-intel-common,
intel-corei7-64-intel-common was specified as override. This was masking
the KMACHINE and KBRANCH variables defined in these recipes causing
unexpected build issues for kernels of BSPs like nuc.
Fixes bug:
[YOCTO #6123]
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'common')
4 files changed, 8 insertions, 8 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-dev.bbappend b/common/recipes-kernel/linux/linux-yocto-dev.bbappend index f01933fe..1133ebb3 100644 --- a/common/recipes-kernel/linux/linux-yocto-dev.bbappend +++ b/common/recipes-kernel/linux/linux-yocto-dev.bbappend | |||
@@ -14,8 +14,8 @@ LINUX_VERSION_corei7-64-intel-common = "3.14-rc8" | |||
14 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | 14 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" |
15 | SRCREV_meta_corei7-64-intel-common = "3689f99f4d2a051e8d3ff72345a67d4d04a88020" | 15 | SRCREV_meta_corei7-64-intel-common = "3689f99f4d2a051e8d3ff72345a67d4d04a88020" |
16 | SRCREV_machine_corei7-64-intel-common = "fecc3fd7d31bd93766ff4f0431fecdbbfa4c3a7c" | 16 | SRCREV_machine_corei7-64-intel-common = "fecc3fd7d31bd93766ff4f0431fecdbbfa4c3a7c" |
17 | KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64" | 17 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
18 | KBRANCH_intel-corei7-64-intel-common = "standard/base" | 18 | KBRANCH_corei7-64-intel-common = "standard/base" |
19 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 19 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
20 | 20 | ||
21 | # For Crystalforest and Romley | 21 | # For Crystalforest and Romley |
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend index cfb41930..f4712ef8 100644 --- a/common/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend +++ b/common/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend | |||
@@ -14,6 +14,6 @@ KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | |||
14 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | 14 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" |
15 | #SRCREV_meta_corei7-64-intel-common = "${AUTOREV}" | 15 | #SRCREV_meta_corei7-64-intel-common = "${AUTOREV}" |
16 | #SRCREV_machine_corei7-64-intel-common = "${AUTOREV}" | 16 | #SRCREV_machine_corei7-64-intel-common = "${AUTOREV}" |
17 | KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64" | 17 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
18 | KBRANCH_intel-corei7-64-intel-common = "standard/preempt-rt/base" | 18 | KBRANCH_corei7-64-intel-common = "standard/preempt-rt/base" |
19 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 19 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
diff --git a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend index a3fc207f..539ea646 100644 --- a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend +++ b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend | |||
@@ -15,8 +15,8 @@ LINUX_VERSION_corei7-64-intel-common = "3.10.35" | |||
15 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | 15 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" |
16 | SRCREV_meta_corei7-64-intel-common = "b6e58b33dd427fe471f8827c83e311acdf4558a4" | 16 | SRCREV_meta_corei7-64-intel-common = "b6e58b33dd427fe471f8827c83e311acdf4558a4" |
17 | SRCREV_machine_corei7-64-intel-common = "cee957655fe67826b2e827e2db41f156fa8f0cc4" | 17 | SRCREV_machine_corei7-64-intel-common = "cee957655fe67826b2e827e2db41f156fa8f0cc4" |
18 | KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64" | 18 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
19 | KBRANCH_intel-corei7-64-intel-common = "standard/base" | 19 | KBRANCH_corei7-64-intel-common = "standard/base" |
20 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 20 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
21 | 21 | ||
22 | # For Crystalforest and Romley | 22 | # For Crystalforest and Romley |
diff --git a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend index 0add0803..9c1dd6af 100644 --- a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend +++ b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend | |||
@@ -15,8 +15,8 @@ LINUX_VERSION_corei7-64-intel-common = "3.14.0" | |||
15 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | 15 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" |
16 | SRCREV_meta_corei7-64-intel-common = "fc8c30398dbc3cdea787a1042242d4aab689d0ae" | 16 | SRCREV_meta_corei7-64-intel-common = "fc8c30398dbc3cdea787a1042242d4aab689d0ae" |
17 | SRCREV_machine_corei7-64-intel-common = "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0" | 17 | SRCREV_machine_corei7-64-intel-common = "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0" |
18 | KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64" | 18 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
19 | KBRANCH_intel-corei7-64-intel-common = "standard/base" | 19 | KBRANCH_corei7-64-intel-common = "standard/base" |
20 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 20 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
21 | 21 | ||
22 | # For Crystalforest and Romley | 22 | # For Crystalforest and Romley |