summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2011-06-01 00:58:20 -0500
committerTom Zanussi <tom.zanussi@intel.com>2011-06-01 22:20:19 -0500
commit7c19e43c9c8cbb12bdc8c50d5b3eab6383bd8518 (patch)
tree535feaca91139b19ff14bbde7fe71810752c9701 /common
parent9902e2fee4b993bf1c689efcc3d16ff53a238afd (diff)
downloadmeta-intel-7c19e43c9c8cbb12bdc8c50d5b3eab6383bd8518.tar.gz
meta-intel: add xserver-xf86-dri-lite_1.9.3 to common
emgd 1.6 requires xserver 1.9.3, which is no longer in meta, and it needs to be shared by multiple BSPs, so add it to common. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Acked-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/crosscompile.patch22
-rw-r--r--common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/fix_open_max_preprocessor_error.patch15
-rw-r--r--common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/macro_tweak.patch30
-rw-r--r--common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/nodolt.patch14
-rw-r--r--common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite_1.9.3.bb19
5 files changed, 100 insertions, 0 deletions
diff --git a/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/crosscompile.patch b/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/crosscompile.patch
new file mode 100644
index 00000000..2f98bb8c
--- /dev/null
+++ b/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/crosscompile.patch
@@ -0,0 +1,22 @@
1Upstream-Status: Inappropriate [configuration]
2
3diff --git a/configure.ac b/configure.ac
4index b3b752c..600500b 100644
5--- a/configure.ac
6+++ b/configure.ac
7@@ -523,13 +523,9 @@ dnl Uses --default-font-path if set, otherwise checks for /etc/X11/fontpath.d,
8 dnl otherwise uses standard subdirectories of FONTROOTDIR. When cross
9 dnl compiling, assume default font path uses standard FONTROOTDIR directories.
10 DEFAULT_FONT_PATH="${FONTMISCDIR}/,${FONTTTFDIR}/,${FONTOTFDIR}/,${FONTTYPE1DIR}/,${FONT100DPIDIR}/,${FONT75DPIDIR}/"
11-if test "$cross_compiling" != yes; then
12- AC_CHECK_FILE([${sysconfdir}/X11/fontpath.d],
13- [DEFAULT_FONT_PATH='catalogue:${sysconfdir}/X11/fontpath.d'],
14- [case $host_os in
15+ case $host_os in
16 darwin*) DEFAULT_FONT_PATH="${DEFAULT_FONT_PATH},/Library/Fonts,/System/Library/Fonts" ;;
17- esac])
18-fi
19+ esac
20 AC_ARG_WITH(default-font-path, AS_HELP_STRING([--with-default-font-path=PATH], [Comma separated list of font dirs]),
21 [ FONTPATH="$withval" ],
22 [ FONTPATH="${DEFAULT_FONT_PATH}" ])
diff --git a/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/fix_open_max_preprocessor_error.patch b/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/fix_open_max_preprocessor_error.patch
new file mode 100644
index 00000000..9c33072c
--- /dev/null
+++ b/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/fix_open_max_preprocessor_error.patch
@@ -0,0 +1,15 @@
1Upstream-Status: Inappropriate [embedded specific]
2
3Index: git/os/osdep.h
4===================================================================
5--- git.orig/os/osdep.h 2008-10-07 18:38:21.000000000 +0100
6+++ git/os/osdep.h 2008-10-07 18:39:36.000000000 +0100
7@@ -92,7 +92,7 @@
8 * like sysconf(_SC_OPEN_MAX) is not supported.
9 */
10
11-#if OPEN_MAX <= 256
12+#if 0
13 #define MAXSOCKS (OPEN_MAX - 1)
14 #else
15 #define MAXSOCKS 256
diff --git a/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/macro_tweak.patch b/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/macro_tweak.patch
new file mode 100644
index 00000000..2b754271
--- /dev/null
+++ b/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/macro_tweak.patch
@@ -0,0 +1,30 @@
1This is the revised version of files/macro_tweak.patch for
2xorg-server 1.8.99.904.
3
4the files/macro_tweak.patch can not removed now since it is used by
5xserver-kdrive-1.7.99.2 and xserver-xf86-lite_1.7.99.2. Once they
6are all upgraded to 1.8.99.904, the the files/macro_tweak.patch
7can be safely replace by this patch.
8
9Upstream-Status: Pending
10
11Signed-off-by: Yu Ke <ke.yu@intel.com>
12
13diff --git a/xorg-server.m4 b/xorg-server.m4
14index bdecf62..040fdb8 100644
15--- a/xorg-server.m4
16+++ b/xorg-server.m4
17@@ -28,10 +28,12 @@ dnl
18 # Checks for the $1 define in xorg-server.h (from the sdk). If it
19 # is defined, then add $1 to $REQUIRED_MODULES.
20
21+m4_pattern_allow(PKG_CONFIG_SYSROOT_DIR)
22+
23 AC_DEFUN([XORG_DRIVER_CHECK_EXT],[
24 AC_REQUIRE([PKG_PROG_PKG_CONFIG])
25 SAVE_CFLAGS="$CFLAGS"
26- CFLAGS="$CFLAGS -I`$PKG_CONFIG --variable=sdkdir xorg-server`"
27+ CFLAGS="$CFLAGS -I$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=sdkdir xorg-server`"
28 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
29 #include "xorg-server.h"
30 #if !defined $1
diff --git a/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/nodolt.patch b/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/nodolt.patch
new file mode 100644
index 00000000..9cd7f932
--- /dev/null
+++ b/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite/nodolt.patch
@@ -0,0 +1,14 @@
1Upstream-Status: Inappropriate [configuration]
2
3Index: git/configure.ac
4===================================================================
5--- git.orig/configure.ac 2009-01-15 20:35:31.000000000 +0000
6+++ git/configure.ac 2009-01-15 20:35:38.000000000 +0000
7@@ -62,7 +62,6 @@
8 AC_LIBTOOL_WIN32_DLL
9 AC_DISABLE_STATIC
10 AC_PROG_LIBTOOL
11-DOLT
12 AC_PROG_MAKE_SET
13 PKG_PROG_PKG_CONFIG
14 AC_PROG_LEX
diff --git a/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite_1.9.3.bb b/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite_1.9.3.bb
new file mode 100644
index 00000000..81d70bcd
--- /dev/null
+++ b/common/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite_1.9.3.bb
@@ -0,0 +1,19 @@
1require recipes-graphics/xorg-xserver/xserver-xf86-dri-lite.inc
2
3PROTO_DEPS += "xf86driproto dri2proto"
4
5DEPENDS += "font-util"
6
7PE = "1"
8PR = "r0"
9
10SRC_URI += "file://nodolt.patch \
11 file://crosscompile.patch"
12
13# Misc build failure for master HEAD
14SRC_URI += "file://fix_open_max_preprocessor_error.patch"
15
16SRC_URI[md5sum] = "5bef6839a76d029204ab31aa2fcb5201"
17SRC_URI[sha256sum] = "864831f51e841ff37f2445d1c85b86b559c8860a435fb496aead4f256a2b141d"
18
19EXTRA_OECONF += "--enable-dri --enable-dri2 --enable-dga"