summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-12-07 16:40:22 -0800
committerCalifornia Sullivan <california.l.sullivan@intel.com>2017-12-21 11:48:38 -0800
commit1f16f45c875883c9ab0e9686527671945b12329a (patch)
tree9103dc56aef4d800c246d126d8d1ccfe90d59666 /common
parent5adbf6df4fd89e7531ccccfb9cec7a5314d635f0 (diff)
downloadmeta-intel-1f16f45c875883c9ab0e9686527671945b12329a.tar.gz
linux-intel: Update 4.9 SRCREV and refactor
This has a SRCREV update to bring linux-intel to HEAD with some audio and pnp patches. The refactor moves the selection of branch to the versioned recipe so we can have a shared linux-intel-lts repo with multiple LTS version branches. Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: California Sullivan <california.l.sullivan@intel.com> (cherry picked from commit 8d37591e1186dcfbf679c1db660d6f9ffa41bb39) Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-kernel/linux/linux-intel-rt_4.9.bb9
-rw-r--r--common/recipes-kernel/linux/linux-intel.inc6
-rw-r--r--common/recipes-kernel/linux/linux-intel_4.9.bb9
3 files changed, 14 insertions, 10 deletions
diff --git a/common/recipes-kernel/linux/linux-intel-rt_4.9.bb b/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
index 02192735..7a14c053 100644
--- a/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
+++ b/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
@@ -10,8 +10,11 @@ python () {
10 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it") 10 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
11} 11}
12 12
13KBRANCH = "base-rt" 13KBRANCH = "4.9/yocto/base-rt"
14SRCREV_machine ?= "44f76edc2079f1551be33b8ab473349d00f814a7" 14KMETA_BRANCH = "yocto-4.9"
15SRCREV_meta ?= "3d5b27b2d138b71052a1d17a5cca73aa0ec75328" 15
16LINUX_VERSION ?= "4.9.61"
17SRCREV_machine ?= "8eb1a43e7232c412673aaaeb968b02122e42de4d"
18SRCREV_meta ?= "3e7fedea919b2c59801ceca25f57a23710ebadcd"
16 19
17LINUX_KERNEL_TYPE = "preempt-rt" 20LINUX_KERNEL_TYPE = "preempt-rt"
diff --git a/common/recipes-kernel/linux/linux-intel.inc b/common/recipes-kernel/linux/linux-intel.inc
index 1f26d451..bde24ba5 100644
--- a/common/recipes-kernel/linux/linux-intel.inc
+++ b/common/recipes-kernel/linux/linux-intel.inc
@@ -3,17 +3,15 @@ require recipes-kernel/linux/linux-yocto.inc
3FILESEXTRAPATHS_prepend := "${THISDIR}/linux-intel:" 3FILESEXTRAPATHS_prepend := "${THISDIR}/linux-intel:"
4 4
5KERNEL_CONFIG_URI ?= " \ 5KERNEL_CONFIG_URI ?= " \
6 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA} \ 6 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${KMETA_BRANCH};destsuffix=${KMETA} \
7 " 7 "
8SRC_URI = " \ 8SRC_URI = " \
9 git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machine;branch=${KBRANCH}; \ 9 git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \
10 ${KERNEL_CONFIG_URI} \ 10 ${KERNEL_CONFIG_URI} \
11 " 11 "
12 12
13SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg" 13SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg"
14 14
15
16LINUX_VERSION ?= "4.9.56"
17LINUX_VERSION_EXTENSION ?= "-intel-pk-${LINUX_KERNEL_TYPE}" 15LINUX_VERSION_EXTENSION ?= "-intel-pk-${LINUX_KERNEL_TYPE}"
18 16
19PV = "${LINUX_VERSION}+git${SRCPV}" 17PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/common/recipes-kernel/linux/linux-intel_4.9.bb b/common/recipes-kernel/linux/linux-intel_4.9.bb
index ec239242..85cb9bbe 100644
--- a/common/recipes-kernel/linux/linux-intel_4.9.bb
+++ b/common/recipes-kernel/linux/linux-intel_4.9.bb
@@ -1,9 +1,12 @@
1 1
2require linux-intel.inc 2require linux-intel.inc
3 3
4KBRANCH = "base" 4KBRANCH = "4.9/yocto/base"
5SRCREV_machine ?= "e8405acd549563650e2e4774a49e069d161e8fe1" 5KMETA_BRANCH = "yocto-4.9"
6SRCREV_meta ?= "3d5b27b2d138b71052a1d17a5cca73aa0ec75328" 6
7LINUX_VERSION ?= "4.9.61"
8SRCREV_machine ?= "03469c2e703e40ed42ed72f415fd27c7d7f7f8cf"
9SRCREV_meta ?= "3e7fedea919b2c59801ceca25f57a23710ebadcd"
7 10
8# For Crystalforest and Romley 11# For Crystalforest and Romley
9KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" 12KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"