summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2014-09-04 15:55:06 -0700
committerTom Zanussi <tom.zanussi@linux.intel.com>2014-09-16 20:12:28 -0500
commitc939705c186388df1eb68341a207fb2c6ac95f66 (patch)
treed3cfe7ef4b1d00822ad23bae82d5a0b8df5a82a2 /common/recipes-multimedia
parent964d5daa7cea2b357c68eb2c91d17779eeba6a49 (diff)
downloadmeta-intel-c939705c186388df1eb68341a207fb2c6ac95f66.tar.gz
Remove all the changes related to the proprietary EMGD graphics driver
As all the EMGD based BSPs have been retired, there is no need for the proprietary EMGD support in the meta-intel layer. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'common/recipes-multimedia')
-rw-r--r--common/recipes-multimedia/gstreamer/gst-va-intel.bb9
-rw-r--r--common/recipes-multimedia/libva/va-intel.bb3
2 files changed, 0 insertions, 12 deletions
diff --git a/common/recipes-multimedia/gstreamer/gst-va-intel.bb b/common/recipes-multimedia/gstreamer/gst-va-intel.bb
index 5e4dd991..9e179b9a 100644
--- a/common/recipes-multimedia/gstreamer/gst-va-intel.bb
+++ b/common/recipes-multimedia/gstreamer/gst-va-intel.bb
@@ -7,8 +7,6 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d
7PR = "r2" 7PR = "r2"
8 8
9def map_gst_vaapi(d): 9def map_gst_vaapi(d):
10 if base_contains('MACHINE_FEATURES', 'va-impl-mixvideo', "1", "0", d) == "1":
11 return "gst-va-mixvideo-vaapi"
12 if base_contains('MACHINE_FEATURES', 'va-impl-intel', "1", "0", d) == "1": 10 if base_contains('MACHINE_FEATURES', 'va-impl-intel', "1", "0", d) == "1":
13 return "gst-va-intel-vaapi" 11 return "gst-va-intel-vaapi"
14 return "" 12 return ""
@@ -26,7 +24,6 @@ ALLOW_EMPTY_gst-va-intel = "1"
26ALLOW_EMPTY_gst-va-intel-general = "1" 24ALLOW_EMPTY_gst-va-intel-general = "1"
27ALLOW_EMPTY_gst-va-intel-video = "1" 25ALLOW_EMPTY_gst-va-intel-video = "1"
28ALLOW_EMPTY_gst-va-intel-vaapi = "1" 26ALLOW_EMPTY_gst-va-intel-vaapi = "1"
29ALLOW_EMPTY_gst-va-mixvideo-vaapi = "1"
30 27
31RDEPENDS_gst-va-intel = "\ 28RDEPENDS_gst-va-intel = "\
32 gst-va-intel-general \ 29 gst-va-intel-general \
@@ -48,9 +45,3 @@ RDEPENDS_gst-va-intel-video = "\
48RDEPENDS_gst-va-intel-vaapi = "\ 45RDEPENDS_gst-va-intel-vaapi = "\
49 gstreamer-vaapi \ 46 gstreamer-vaapi \
50 " 47 "
51
52# The emgd driver contains the vaapi implementation
53#
54RDEPENDS_gst-va-mixvideo-vaapi = "\
55 emgd-driver-bin \
56 "
diff --git a/common/recipes-multimedia/libva/va-intel.bb b/common/recipes-multimedia/libva/va-intel.bb
index 57a16097..93df94d2 100644
--- a/common/recipes-multimedia/libva/va-intel.bb
+++ b/common/recipes-multimedia/libva/va-intel.bb
@@ -6,9 +6,6 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d
6PR = "r1" 6PR = "r1"
7 7
8def map_valibs(d): 8def map_valibs(d):
9 # The emgd mixvideo implementation requires libva-x11/tpi/glx/egl
10 if base_contains('MACHINE_FEATURES', 'va-impl-mixvideo', "1", "0", d) == "1":
11 return "libva libva-x11 libva-tpi libva-glx libva-egl"
12 # The intel implementation requires the libva-intel-driver package 9 # The intel implementation requires the libva-intel-driver package
13 if base_contains('MACHINE_FEATURES', 'va-impl-intel', "1", "0", d) == "1": 10 if base_contains('MACHINE_FEATURES', 'va-impl-intel', "1", "0", d) == "1":
14 return "libva libva-intel-driver" 11 return "libva libva-intel-driver"